Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

bsfs1988

1991 Suzuki King Quad 300 carb problems

Recommended Posts

hey guys im new to this place and i hope u guys can help me. i did look at sum forums but nothing to what i am experincing i got a 91 kingquad 300 i rebuilt the carb i got the needle jet bck out 2 turns after it was fully in. and i got the air mixture screw all the way in and if i try to start it without doin nothing it wnt do nothing choke in or out. if i take my finger and hold the slider half way up she will crank and idle high but thats bc of the mixture screw all the way up but soon as i let it drop she cuts off :mad: but as long as i hold the slider up she will stay cranked. i did take the bowl cover off and saw 2 little pin holes in the rubber gasket for the bowl i dnt know whats its called but i guess it does sumthn with air.i need it to stay idle so i can set my mixture screw. i got good spark,fuel is pumping, i looked at the intake boot no cracks or anything there, but just those 2 lil pin holes on the bowl gasket will that make it not stay idle? i rebuilt the carb bc it was extremely hard to start.it does smoke when its started which is a lil aggrevating but i just wanna get it running right now, and i need a seal for the compression switch it leaks a lil oil but not a biggie. i need help guys and im mechanically inclined but hvnt done much 4wheeler wrk but lots of auto wrk so im sure its understandable

Share this post


Link to post
Share on other sites


Did you do a full rebuild, soak it? You probably have a jet clogged or something like that. Did you get a full rebuild kit?

* Added year and manufacturer to thread title.

Share this post


Link to post
Share on other sites

Yep rebuild all new jets and even soaked carb everything came out nice and clean if I hold the diaphram slider half way up il get it to idle but she will die once I let it down like I was saying my diaphram rubber bowl basket got 2 very small holes do u think that will make it not idle by itself

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By MarkinAR
      What is the opinion on carb kits? What's one of the better brands of aftermarket? OEM is always preferred but not practical, chinese cheapie is never a good option. 
      Thoughts ?
    • By raybob
      replacing carb,, the bigger line on right side top of carb does it just vent to the air,, cant find where to hook it up to also I want to check the oil and gear oil I checked the oil in motor and the rear end my question is looks like allen plug on left side of motor if you are setting on the 4 wheller, ps it hs a oli leak any help would be great. Ray in kentucky
    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By raybob
      I have it all but can find where the vacuum line on the carb goes its a 2000 suzuki 500 quadmaster I know where the two vent lines go but not the bigger vacuum line goes it has vacuum on this line. need help. Ray
       
    • By cavry
      I installed a new China made carb months ago. So far all is well.  This carb has a heater, while the original did notI never considered hooking it up.  Here in far N. Ga,  0 deg. is about the coldest it normally gets in a bad winter. Should I bother hooking the heater up and will it need a sensor or just an off/on toggle switch? Totally new subject to me.
  • Similar Tagged Content

    • By Paul Maple
      I have a 1999 Sportsman  500, it was running fine, than started to lose power in the winter, I adjusted the idle screw and away I went, than a few weeks ago it died, I have found that i am flooding the engine, compression was at 70PSI and due to the compression release mech. i assume i am good as it compared to the same PSI on a 2000 sportsman 500 i have. i cannot start the atv unless i go full throttle and it starts an runs for about 30 sec than dies, again it is flooded. i ordered a new carb off ebay as i could get one for around $40. put that in same issue, i have checked the timing, (good), valves out of adjustment i adjusted to .006 still same issue, i have found the exhaust lobe and rocker arm to have some wear, i have ordered new ones, but am looking for any other input in this area as well. would the exhaust cam and rocker arm cause the engine to flood? i have used a bore scope and the piston liner has good cross hatching still? any input would be great.
    • By Tubecatgs
      A friend of mine has this Bayou 220 that started running bad and parked it a few years ago. I foolishly volunteered to take a look at it. I noticed right away the choke plunger on the carb was broken and probably the reason it was running bad but now the old gas was evaporated and like turpentine. Before i even tried to start it, i drained/ thoroughly washed the tank out, new fuel filter, new fuel lines. Blew air through the petcock etc. Changed the oil and filter and air filter and new choke plunger and cable. I disassembled the carb and rebuilt it with a kit. I cleaned the main jet with solvent and poked a wire through it to make sure it is clean.. the engine now fires right up with the choke on and dies when i take the choke off. I adjusted the air/fuel screw to about 1.5 turns out and the idle screw about 2.5 turns out. The rubber boot between the carb and head does not have any cracks in it so I don't think it is leaking air. I originally had the clip on the needle on the second from the top ring... when i moved it all the way to the bottom it starts, runs and idles really fast and will idle eeally high with the choke off but if i adjust the throttle cable and/or idle screw to a slower idle it will sometimes stall but the idle will go up and down every few seconds and when you give it gas there is a hesitation... i tried moving the clip down to rhe second from bottom and same problem... i replaced all the parts in the pic to the top right. However, there appears to be a small o ring, washer and spring left over from the kit... i did not see these get removed..... a) any idea if where these extra parts go and if i need them and b) any other ideas on why i cant get it to idle right or carb adjustment ideas?
      Thanks
    • By bradley nelson
      What is the best and easiest way to tune your carburetor? Any tips or tricks?
    • By LTZ-Zach
      So i was riding the other day and my quad randomly shut off. It started back up and ran completely fine for a little while and then it started idling terribly.
      I cleaned the carb and changed all the jets and everything except the float due to the rebuild kit not coming with one and it actually runs worse then it did before.
      It will run and idle decent now but when I give it gas it dies.
      Does anybody know what could be wrong?
      I also changed the spark plug and air filter along with the oil and oil filter.
       
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...