Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

I have a continuous problem with the inner CV boot tearing repeatedly! Does anyone know of an upgraded CV boot or a better fix than the factory boot?

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By JacobSlabach
      First of all sorry I have been MIA here for a while, been busy with school and work.  I'll try and reply on some other threads asap, but posting this one because I just picked up a 2017 sportsman 570 before the new year and popped a boot on it going through a mud hole.  The former owner had aftermarket axles on it to accommodate the 4in lift and idk what brand they are but they're skinny as heck and idk what boot to buy to rebuild with?  It's the rear right lower boot (under the brake calp.).  I'll post some pics when I can and sorry again I've missed yall on the forum!
    • By colin james
      View File 2017-2019 sportsman 450/570 with eps factory service manual
      This  is the factory service manual for the 2017-2019 factory service manual for the sportsman 450/570 with electronic power steering 
       
      Submitter colin james Submitted 09/06/2018 Category Polaris ATV  
    • By Ted Craig
      I know a lot of people say not to use anything but Oem. For the sake of the those who chose not to, or the OEM part cost more than the project, lets hold back negative comments. 
        I just purchased a carburetor that is supposed to be up to OEM specs. The company has a good reputation on eBay and Amazon. The Carb is supposed to be for this bike and jetted exactly. 
        This question should basically go under carb adjustment. I installed the new carb, the bike idles fine. On throttle it sputters half the time and the other half it will rev up fine. Does this sound like the needle is set at the wrong point? Does it sound like the main jet is the wrong size? Or is there another adjustment besides the air/fuel screw thats is 2 turns out? 
        Yes i could truck through old threads and possibly find the answer, but i thought it would be nice to have one tailored to new carb installs. 
    • By Jeff Miller
      I'm trying to troubleshoot a starting issue. For a while, maybe a year sometimes I would hit the starter button and I'd hear a single loud click, but the starter wouldn't turn. Usually if I could pull the pull start or roll it in gear it would then start. (now I'm thinking that was coincidence) Now it only clicks. I tried to check what I could, battery is good, solenoid clicks strong, cleaned all connections (which were 80% clean anyway). I started thinking the starter wasn't spinning. I pulled it and it spins freely. The gear that it contacts in the engine-I can wiggle it maybe 1/16th to 1/8th inch back and forth. When I reinstall the starter I feel it jerk when I hit the button. I'm thinking maybe it's the starter clutch? It seems when there's a problem with them they usually just spin freely and don't engage at all. Is it possibly something is causing it to lock? I'm a bit lost now.
  • Similar Tagged Content

    • By mikeexplorer
      Wiring diagram for 2007 Arctic Cat 700 EFI 4x4
       
       
    • By Beb1041
      Looking for a download of a manual
    • By patricknperkins
      Ok, so got this thing, assembled, and even added acid/assembled the battery with a solid trickle charge and the battery is fine.
      As far as I can tell, I have checked all the fuses I can find, but I have ZERO power to anything. Even the console will not light up when turned to ON.
      Is there some sort of hidden parental/child disconnect or safety switch that I'm not aware of? ANY help would be appreciated.
    • By warkcol
      I am having an issue where it sounds like the gears are slipping if I hit the throttle really hard and also after letting off when the engine brake is applied. Also, the drive train that goes to the front also rides again the gear shift box. I will attach pictures and a video here shortly.
      Thanks in advance!
      [ame]
      [/ame]https://postimg.org/image/cdlu6fza9/
    • By Weldingrod47
      Trying to change front wheel bearings. I removed the cotter pin and castle nut. Hub won't budge. Is there an additional retaining clip? Seems to be one of those push on type that barbs on the thread of the spindle. How do I remove it?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...