Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

Hello , I have a 2007 ODES 400 CC ATV... Can anyone help me find where to get a instructment guage assemble..??? mine is broke... I need the whole panel... thanks

Share this post


Link to post
Share on other sites


Hello , I have a 2007 ODES 400 CC ATV... Can anyone help me find where to get a instructment guage assemble..??? mine is broke... I need the whole panel... thanks

Whats a 2007 ODES 400 CC ATV ? not familiar with that brand ?

Share this post


Link to post
Share on other sites


HELLO , The part is for a friend... he pick it up last year and did not know how to find out where one is.... I had DAVID WANG from ODES try to get me to buy some of these in 2007 .. but I BROUGHT OVER SOME jianshe ( or hemsin ) 400 cc atvs... they were very good.. most of the ones that I sold are still running around... no real parts ever needed... I did email the CHINA PARTS place mentioned in the other reply... I see Wholesale Kids ATV Dealer, Youth Mini ATV, Kids ATVS, Kid Quad, Youth Dirt Bike, Youth 4 Wheeler Helmets, Kids Chinese ATV Parts and Service in the USA has the same atv... So maybe they have something.. the crystal for the LCD dash panel is not showing the display... hope to fing one for him..

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Bob Hill
      I need a motor but i really dont hsve lots of cash and im on the kenai peninsula. Up here in Alaska i really need help
    • By Scott Sirr
      View File 2007-2012 Yamaha Big Bear 400 4x4 Service Manual
      2007-2012 Yamaha big bear 400 4x4 irs service manual
      YFM40FBW
      Submitter Scott Sirr Submitted 12/22/2019 Category Yamaha ATV  
    • By Brian Simmons
      I am looking at a 90cc Arctic cat 90cc not sure what year right off hand . The shaft broke off right outside the motor . Can anyone help me ? What do I need to do to fix it ? Do you have any pictures or videos ? Let me know ?
       
    • By josephnbl91
      My four wheeler when i first got it seemed like it was very slow when i first got it and it had no throttle response so i replaced the belt and cleaned all of the rollers thinking that would solve the problem from what i read on the forums. well it turned out that it wasnt. so i went to the next thing i took out the injector to check it out and i seen that there was a tiny bit of debree in it so i cleaned it and it seemed to improve a little bit. but still did not solve the problem. i later found out how to find the trouble codes out from the lcd screen using a paper clip on the diagnostic port and it showed the code which stood for no codes C00. i also forgot to mention that the throttle position censor is working perfect. before i started all of this the four wheeler ran just not to its potential. after my friend and i did the trouble code test the bike wouldnt even start anymore and the injector would spray for a few seconds for the start up then it stops and the fuel injection light comes on and blinks. the four wheeler wouldnt start anymore. i took it over to the local shop and they hooked it up to the computer to see if there was any codes and it still showed it was free of codes. they hooked it up to the fuel pressure gauge and we found that it was making 22 pounds and it should be making around 43. i then bought a new fuel pump and put it in. it now starts and runs for a few seconds and then it stalls out and the fuel injection light comes on again. which then leads me to think it is the ecu now but i want to be sure before i invest around $500 more into it. any opinions on whether or not anyone thinks this is the problem or if they have had a similar problem before would be really appreciated. sorry for writing a novel and not spelling very well. also i forgot to put the year in the title it is a 2007
    • By Zachary Coombs
      Hello, I’m new to this forum, I have a 2007 trail boss 330 that’s been overheating after about 5 minutes of riding. No problems before it overheats from a cold start but then it backfires and loses power. The fan comes on but the temp light doesn’t. I’ve had someone clean the carburetor, I’ve replaced the spark plug and air filter and put in a new battery. I also tried cleaning the radiator with a hose, Any help is appreciated, Thanks
  • Similar Tagged Content

    • By mikeexplorer
      Wiring diagram for 2007 Arctic Cat 700 EFI 4x4
       
       
    • Guest huntingstill
      By Guest huntingstill
      k I would like to take my one person off road go cart and turn it into a sand rail LIFT it new engine and transmission make it so you have to shift w/ a clutch and all the fun stuff a car has
    • By Aidan
      Hi, 2 years ago I got a 2002 Kawasaki Lakota Sport 300 for $50. Yes, I know, vary cheap, and it came with issues. The issues were, a leaky oil cap, a carburetor that fails when going up or down hill, and a flat tire that will not fill up. It also has a broken exhaust, as in broken, the tip of the exhaust is no longer there, so it is loud, but works fine. I have the oil cap, and a carb repair kit, but I need help finding a right rear tire for it, also I need ether a entirely new exhaust for it or somehow repair it, I dont have the old piece to the exhaust. Feel free to ask me questions. I will put a pic of what the exhaust is supposed to look like.


    • By Mikes700efi
      I just bought my first arctic cat. I changed the oil and filter. Now my atv smokes only when u rev the engine. Smoke looks white grey.. slight light blue tint.. when it. Idles it doesn't smoke.. Any body have a clue what is going on. The dealer said it's not the rings.. it has the 700cc suzuki engine..
    • By Mikes700efi
      Can someone tell me how to remove the rear sifferential. I've got the cv axels out. Do I remove the rear shaft. Or do I pull differential off shaft. Noticed the axel shaft leaking where it go's in the engine. .
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...