Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

We had a 4000, 5000, & 6000 member thread...so now I'm gonna start the 7000 member drive thread! :laugh:

We're at 6424!

Share this post


Link to post
Share on other sites


I would say it's time to spam facebook and twitter again with links to quad crazy.

Share this post


Link to post
Share on other sites

I put it on my Facebook page.

Share this post


Link to post
Share on other sites


6936...:huh: getting close!

Share this post


Link to post
Share on other sites


That's cool...growing faster each year!

Share this post


Link to post
Share on other sites

Congratulations to QUADCRAZY!

Threads: 7,127, Posts: 63,340, Members: 7024

Share this post


Link to post
Share on other sites


8000 members! Congrats QUADCRAZY!

Time for a 9000 member drive!!!! :yes:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Rich1028
      New Member from Saginaw,MI.

      I have A 1991 Honda 250X bought it new,still kinda good shape,want to get back to ridding some trails with it.
      have not been on the trails since 1995.
      used to ride from Houton Lake to St. Helen get gas and food and turn around,made for a great days ride.


      looking to read lots in this forum.

    • By gouletp
      The thing sat since Christmas 2018 and while I decided whether to replace the starter (which I finally did today).  I am not sure if I added fuel stabilizer or not but chances are good I did.  I kept the one year-old battery well charged during the winter.  It turns over well but won't start.  I have a blue spark on a brand new plug.  When I pour a bit of fuel down the cylinder, the engine starts and runs for a few seconds (once for as long as about 8 sections) and then dies.  Even before adding fuel to the cylinder I noticed that the spark plug was wet with fuel.
      The air filter looks a bit dirty so I removed it just to see if the engine would start better but it made no difference.
      If the fuel did not contain stabilizer then the carb may be gummed up.  I don't really want to remove the carb to do a thorough cleaning.  Is there a product I can spray into the carb while the engine turns over that will clean the carb?
      Any other suggestions?
      Thank you
    • By benwheeler
      Hi all, 
      Just joined up with premium membership.  I wish to download a service manual or 2 (specifically the Polaris 110 EFI manual).   I paid for the membership, but when I try to download it says it's not available to me.  I know I haven't posted anything until now, but I thought the premium membership gave instant access to downloads.     Not sure what I'm doing wrong?  
      Thanks!
       
      Bill 
    • By Travis Mitchel
      Hello all just recently acquired this atv which as you can see in the pics that it has had an unsheltered life. i did get it running and put some used tires on the front.
      It still needs a bit more well needed maintenance, chains tightened and oiled. needs an airbox or air cleaner and other misc items.


    • By Azrial
      I recently bought a 2008 Kawasaki Teryx LE 4x4. It is an old beast, but in super good condition with only 30 original hours on it. It belonged to an old man who used it to check his mail some days. I have a very steep piece of property and intend to use it as a light weight tractor.

      I would also like to score a spare set of wheels to mount some Turf-type tires on it. Every now and then I may use it as a patrol vehicle when working a large property. I am a semi-retired cop and do this kind of work on the side.

      My intentions are to mount lights, a winch, and perhaps a stereo to it. Other than that, I am afraid that stock will be good enough for me!
  • Similar Tagged Content

    • By Cobra_GT
      What’s up people I am new to the forum and am glad to be here. I have been into bikes for oh I guess 40+ years or so. I haven’t had one in a while but my 27-year-old son has always wanted a Banshee and he finally got one and the guy he bought it from had two of them. I almost bought the second one but I did not want to spend the next month on the sofa. So he had a LT-Z 400 Suzuki and I picked it up for $800, I could not pass that deal up. We could have bought both Banshee for $7000 as he wanted $7900 for both of them. But He wanted $4200 and was not budging for the one my son bought and $1400 for the Z400 and we got both of them for $5000. He wanted $4200 for the Banshee so I got the Z400 for $800, a steal. Anyway it’s good to be here. Peace.
    • By oldcomet
      Morning Folks
      Ok so I have taken the front hubs apart everything is good and working fluids changed and full In 2 wheel drive the bike works great However in 4 wheel drive high I get a grinding clunking noise right near the foot pegs The universals are all brand new in the complete bike The problem just started after my last ride Sometimes I have to change the rpm to get the bike to go into gear in forward and reverse The bike doesn't make the grinding noise when I have the bike in 4 wheel driver low gear only in high gear Could the shifter need adjusting any help would be great Thanks for your time
      Oldcomet
    • By bodatiouskid
      Just bought a 2003 Kodiak 450.At take off,the belt doesnt grab for a few seconds.Is there any wat to tighten belt?& how tight should it be?
    • By Tivy
      My boot on the drive shaft came off this weekend. When I tried to put it back on it appeared to be about 2" too large. Any explanations????
      Also when the boot cam off, there was oil in the boot. Is this normal???
      Thanks for your help.
    • By toonces
      New to ATVing here and just got a '11 Grizz with the belt drive transmission and I've been suggested to take along an extra CVT belt along in remote rides just in case. I'm somewhat knowledgeable about where to get quality parts for cars but not so much for ATVs. Who makes the best CVT belt for my bike? Also, who makes just ok belts and who should I stay away from?
      Also, I'm looking at getting a snatch block for a synthetic rope winch and wondered if the type rope determines what type of block you should get...or are all snatch blocks the same and I'm just thinking about this one too much?
      Thanks
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...