Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

G'day all,

just sayin howdy and to introduce myself, Name is Garth, 38 with two kids (9 & 4 months) live in darwin australia, i own three quads 2 raptors(2011 700 & 2003 660) and a suzuki ltz90(my daughters) havent ridden for about 20 years so have a bit of catching up to do:australiaflag:

Share this post


Link to post
Share on other sites






Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By mmmPUDDIN
      I've had this machine for 2ish years, has ran great up until winter. Sometime during then, I managed to break the exhaust right before the muffler. The summer before it had a hard time idling, but we fixed it by cleaning the carb, and messing with idle. Near the end of last year, the only way for it to fire was the have full choke, and full throttle, and the engine bogged down and you had to keep on throttle for 25mins. Over winter, the throttle had dislocated, and I got it back in place. We got it running, and all was good. Spring came along, and now it doesn't start at all. A fluid is coming out of the exhaust, and I'm told it could be water from over winter. I checked the airbox, and the air filter isn't for this quad, it also is barely sucking air. There appears to be little to no compression, based on this. I'm pretty sure the engine is flooded, as the spark plug produces a spark, but is oxidized. I don't know how the previous owner treated it, or when it's last oil change was. A bolt on the engine has either oil or gas seeping through it,abd was loose. I tightened it and it consisted. The engine is basically positioned in the rear, and it needs a good clean, I don't have a pressure washer, so I can get the built on dirt off. any recommendations on how to get the beast started again?
    • By StolenATV
      Loud Mini blue 4 wheeler with little orange was stolen late at night from our yard. Does not have a key only a kill switch no stickers just plane no license plate due to it not being road legal. Was seen drove on four wheeler trails in Hibbing. It was my 5 year olds birthday present and means the world to him. He’s been very upset and hurt that someone could steal his four wheeler and is so little for him to understand that some heartless people in the world do bad things And is trying to do yard work for a reward and to buy a new one 🙁 we just want our sons smile to be brought to his innocent face. Thank you for taking the time to read
      The post STOLEN ATV: BLUE RF MINI SPED STAR CLONE 50cc KIDS ATV appeared first on STOLEN 911.
      View the full article
    • By StolenATV
      Attention! Stolen! From a deployed soldier on independence day! 2014 Honda Foreman 500 and 2003 Yamaha 660 Raptor. Please spread the word in helping find them. A report was filed with Franklin County as well.
      The post 2003 Yamaha 660 Raptor and 2014 Honda Foreman 500 appeared first on STOLEN 911.
      View the full article
    • By Venom
      Hi, All

      I started this project a while ago.. I have decided to make one thread I can continuously update..

      So , here we go. I got this Raptor 80 in really bad condition.. Rear end frozen, Engine toast, tires dry rotted, tons of rust..etc.. They admitted they beat on it very hard.

      Since they do not make these with a drive shaft anymore I decided to restore it from top to bottom..

      These are photos of when I got it home.

      Next up, the tear down..



      First, I needed to tear it down and determine if the rear end was still good... As we all know... That is where it would be cost prohibitive to restore if it is trashed..

      Got it completely stripped down and I lucked out... The rear Drum brake was caked solid inside with dried mud. That was causing the rear end to lock up. Took off the rear brakes and the rear end spun perfectly smooth.

      Once I got it all stripped apart I needed to take the finish off all the parts. I am going to be powder coating the frame and many parts.. Once the finish is off each part it will need to be sandblasted to white metal .. The guy I use for powder coating gives me a hefty discount if I bring the parts to him ready to go.

      You could just sand blast, but that would take a long time to get the finish off. First I used Aircraft Paint Remover.. That stuff is pretty toxic Goggles and Resperator are required. That quickly gets you down to the metal... Then you can sand blast to white metal pretty quickly...


      I had another thread I had started about a problem with the tear down... It has some great info .... here is the link... It is about removing the frame bushings. ....
       
      https://www.quadcrazy.com/atvforum/topic/14209-raptor-80-frame-bushings/?tab=comments#comment-104702
  • Similar Tagged Content

    • By dubs
      I am new to this forum and dont know how to post a question , maybe im already in the right place. I have a 2001 warrior 350, runs great but will not shift in to gear, when i do get it to shift it acts like it wants to go but does nothing. Even with it off and in 1st gear it rolls easy like its not engaged, any help???? thanks
    • By ironeaglejtwells
      Hello fellow rider;
      My Names is James. I am stationed in Ca. I am new to the sport. I own a '07 Polaris Sportsman 500x2. Looking forward on going on my first trail ride w/the new quad this weekend.
      -Ride Safe!!!
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...