Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Which would you rather race!?  

15 members have voted

  1. 1. Which would you rather race!?

    • Yamaha YFZ450
    • Suzuki LTR450
    • Honda TRX450
    • KTM 505XC


Recommended Posts

Which do you think is an all around better quad!?

Yamaha YFZ450

Suzuki LTR450

Honda TRX450

KTM 525XC

Share this post


Link to post
Share on other sites






i am biased....ride green! and yes, i know it wasn't a selectable choice

yeah , green is faster ..............:laugh:

Share this post


Link to post
Share on other sites
tell us what one to go for after fridays race :wink:

hahaha well u heard what happened friday so u know wat to go with lmao....he got :SNEMOTICON8:

Share this post


Link to post
Share on other sites
I'm not voting. They all have their advantages and disadvantages.

rappy is right they all have ups and downs just get wat u like and wat feels comfortable im just sayin wat i would go with:yes:

Share this post


Link to post
Share on other sites


well i have worked on the yammi the suzuki and the honda ... i have only seen 1 or 2 of the ktm's ..but i have heard a few good and bad about them also... the yammi has had alot of oil system problems over the years and they claim to have thoes fixed .. but they still have an oil system problem... the suzuki has had alot of suspension problems on there 450's but have gotten them all fixed in the last year or 2 ... and its not a bad machine ... the honda has had its bugs also but has been a very good machine as they usually build ... and repair costs on them are cheaper than the other 3 ... so i would have to say and go with the honda ....

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Ajmboy
      Got my Yamaha Grizzly buttoned up finally and went for a quick 2 hour ride in the power lines with my neighbor, who has a Yamaha Kodiak. We have access from his yard, which is nice. Was a beautiful day today to get out and will try to go more often. Ran into two other quad riders with a sportsman and I think grizzly. Also ran into a dirt bike rider. 😎




       
    • By Asen_77
      Hi All,
      My name is Asen and I am from Eastern Europe, Bulgaria. Riding a Yamaha Raptor 700R and this is my first Quad wanted for a vey long time :)

       
    • By John Victor
      My father-in-law gave my boy a 1999 350 Big Bear. It's been sitting in a barn for a bunch of years. It runs great! My boy has been riding a couple weeks now and it has developed a squeal coming from the front end when you get off the gas at speed. No noise during acceleration. At first I thought brakes. I took it for a ride and I don't think it is the brakes. I feel it is the front prop shaft U-joints, front differential or one/both axles. I pulled the fill plug on the differential and I can't find anywhere how much gear oil should be in there. My gut says up to the fill opening. It doesn't have a manual. It's wet in there, just don't see any gear oil.

      #1 Should I fill the differential with gear oil up to the fill opening?

      #2 How do I check or know if the u-joints are bad? That looks like a "Big Bear" of a job if they don't need to be replaced.

      #3 What else could it be? I don't think it is the front bearings. I jacked the front wheels off ground and no play in the right wheel. Very little play in the left wheel, looks like the lower control bushing is where that play is coming from. The rubber CV boots look original but all still intact. Wheels spin easily without any noise.

      Thanks for any help!
    • By wwdubose
      I have two 2003 Suzuki Ozark 250s, both 2-wheel drive.  Last time we rode them about a year ago, the red one was not running well, didn't want to idle, backfired a lot.  The green one ran fine. 
      Fast forward...I ordered a carb kit for both of them, thinking the red one has some trash in a jet.  Both of these ATVs have had little use and I've always ran the gas out after use (put an inline cutoff valve in gas line).  I pull started the red one to verify it was still running bad.  It will start and idle, but as soon as you give it any throttle, it dies instantly.  Give it a little choke, dies instantly.  Took the carb apart and it was spotless.  Went ahead and cleaned all the holes with carb cleaner and blew everything out with compressed air.  All new jets, main jet holder, and needles.  Put it back on and nothing changed.  Starts, idles (not for a long time), but dies as soon as you give it gas.  Same happens when you put the choke on.  It does the same thing when I try to run it turned to prime on the petcock as it does in the on position.
      Not an air filter issue.  It is clean and it does the same exact thing with no filter on it.
      Thought maybe there was a float issue or maybe a damaged diaphragm, so I took the carb off the green Ozark and put it on red.  Started up and initially ran normal and revved for about 10 seconds and then started doing the same exact thing.  Starts, idles (not for a long time), but dies as soon as you give it gas.  Same happens when you put the choke on. 
      So...not the carb
      Thought maybe vacuum petcock was bad, but there's no gas in the vacuum line going from petcock to carb and gas flows freely when on prime.  I even plugged the vacuum line at both the petcock and carb end and tried to run it with valve set to prime.  Gas flows freely, but does exactly the same thing.  I unscrewed the screw at the bottom of the bowl and gas flows thru carb and out bowl drain line when petcock is set to prime.
      So, I'm assuming petcock is good?
      Checked spark plug and it wasn't fouled.  Reset gap, didn't help.  Will swap plugs between Ozarks tomorrow but I don't think that is it.
      Anyway, that he history and now you're all caught up.  Scratching my head.  Valves? These were bought at same time and have had little use.  Suggestions?
      Thanks!   
  • Similar Tagged Content

    • By Aj Hurtibise
      I have a 2000 Honda trx90 I got from a buddy for free he said it needed a carb so I put his old carb back on it to try to get something out of it and it does not have any Spark. I already replaced the ignition coil I don't know much about four wheelers but I am a technician so I do know my way around a motor any electrical help would be wonderful or specs I don't have the best digital multimeter either.
    • By Aj Hurtibise
      Hey guys I'm new to the Forum I just got a 2000 Honda trx90 looking to make it go a little bit quicker I don't know much about four wheelers but I am a technician at a dealership so I know my way around a motor.
    • By Admin
      Looking for Honda ATV VIN (Vehicle Identification Number) Number Decoders? Once you find your ATV VIN number off the tag on your Honda ATV, you can go to all kinds of websites that have VIN Decoders available. The best ones are backed by the Honda ATV manufacturer, however there are plenty of aftermarket Honda ATV VIN Decoder websites on the web. This topic will stay pinned and if you find any to add, please do it with a reply. 
      The following Honda ATV VIN Decoder websites are available where you can just enter your VIN number and it will shows you some of your ATV model details:
      CycleVIN https://www.cyclevin.com/
      KBB.com https://www.kbb.com/vehicle-history-report/ 
      CARFAX https://www.carfax.com
      autoDNA https://www.autodna.com
      VinAudit http://www.vinaudit.com/
      decodeTHIS https://www.decodethis.com
      VINCario https://vindecoder.eu/
      NICB Theft Check https://www.nicb.org/theft_and_fraud_awareness/vincheck 
    • By Guythis448
      Looking for help on wiring up stock wiring harness specifically for a '88 Honda TRX 300 
      If anyone could drop a link or send me a PM it would be much appreciated 
    • By Wali
      I was riding my 400ex one day and when i shut it off to put it in the garage i tried to start it put again to drive it into the garge and it wouldnt start.I put a compression tester on it and its like 30 psi with out throttle and 0 psi WITH THROTTLE.
      when i put my finger over the hole it fell likes its pulling my finger in more then its pushing it out 
       
      Has good spark.When i took it into the shop the said it had 1oz of oil in it and a tiny pit of metal shaving(TINY BIT LIKE 30 flakes)
      When i try to pull start (push start/roll start) it made a not normal sound  and wouldnt stay running.
      If my bottom end is blow why would it still turn over fine,
      Are my valves siezed or not working properly 
      or is my timing off causeing valves to not open in correct order with fire 
      PLEASE HELP all help is appreciated 
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...