Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Chet

1997 Suzuki King Quad idling problems

Recommended Posts

My neighbor who had hip surgery 6 years ago parked his King Quad in a shed and it has not been fired up since that time. He replaced the battery, but could not get the unit to run. He asked me for assistance, so we towed the unit over to my shop. I got the unit running, but could not keep it idling without turning up the the RPMs...and when I tried to drive the unit it seems like it ran out of gas after a couple of hundred yards. I tore the carburetor out...dropped the float bowl and discovered a bug (about the size of a housefly) in the bottom. I removed the bug...cleaned what jets and other components I could, put the unit back together...with the same results. I once again removed the carburetor...have removed the plug for access to the pilot needle adjustment and I am preparing to dunk the whole unit into a can of carburetor cleaner. I cannot get the diaphragm screws loose and was wondering if that would hurt the rubber diaphragm if I just left it on the carb...and what should the pilot needle adjustment be set to. Any help would be appreciated.

Chet

P.S. What should the fuel switch under the gas tank be set to. On-Pri-Reserv

Share this post


Link to post
Share on other sites


Take a dremel to and cut a slot across the screws in the diaphragm cover then remove the screws with a straight screw driver.

Set the petcock to pri, this lets fuel flow all the time not just when the engine is cranking.

Share this post


Link to post
Share on other sites

Did you check the float for movement and make sure it doesn't stick? The pin can get corroded.

Share this post


Link to post
Share on other sites

Thanks...removed the diaphragm, removed all the jets..soaked the whole carb in carb cleaner...still have a question regarding the setting of the pilot needle adjustment...it is a mikuni 19BE K681...pilot was set at 3 turns out, but the unit still is not idling right...since I removed the plug for cleaning I now have access to that adjustment...any clues

Thanks

Chet

Share this post


Link to post
Share on other sites

Thanks...removed the diaphragm, removed all the jets..soaked the whole carb in carb cleaner...still have a question regarding the setting of the pilot needle adjustment...it is a mikuni 19BE K681...pilot was set at 3 turns out, but the unit still is not idling right...since I removed the plug for cleaning I now have access to that adjustment...any clues? Float is not sticking.

Thanks

Chet

Share this post


Link to post
Share on other sites


Chet, Thuds4evr here.

I have been following your post and am wondering if you solved the idling problem .

I am new to the forum, do not know that I will be able to contribute much as I see the guys in here are a long ways out in front of me on 4 whlrs. It sure is great to see how quick they are to jump in and offer help though. Have been other type forums that this sure was not the case. Tom

Share this post


Link to post
Share on other sites
Chet, Thuds4evr here.

It sure is great to see how quick they are to jump in and offer help though. Have been other type forums that this sure was not the case. Tom

isn't that the truth !! this is why i have stayed with this forum too. deleted all the rest :yes:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Meg Sam
      Hi I have bought a Bashan bs200s-3 and I am wondering where I can buy parts for this as I need a full new wireing loom also does this model have reverse gear?
    • By Shane Pillar
      Talk about what kind of atv you have and what you do with it.
    • By dp19
      Hi, I'm a newbie on here.  I just got a 2007 Suzuki KingQuad LT-A450X.  Are there any specific issues to look for on this model?  Any specific maintenance to do other than the usual oil and filter changes?  
      Thanks
    • By Jack Briggs
      Just bought 06 KingQuad 700 and first ride out hit a mud hole, not to deep and it shut off and would not start. 
      Got it home and found the spark plug hole was full of mud and water. Went and bout a new spark plug and began cleaning it out. Put a deep socket in there and it wouldn’t grab. Took a pic with my flash and this is what I see. Any suggestions? And what is it??
       
      previous owner said it had a new coil so that’s why I decided to change out the spark plug, also ordered new coil should be here by the weekend. 


  • Similar Tagged Content

    • Guest Fox300exchic
      By Guest Fox300exchic
      The Hop-Up: You may be saying to yourself, “that’s a chick bike,” and you’re right. But honestly, it’s so much more than that. It’s one badass bike. http://www.quadmagazine.com/quad/features/article/0,24942,1587044,00.html
    • By Jers
      I need to know what I have and what tire really go on it, Mine has 24x11x10 on the back and 22x8x10 on the front and I need new tire but I don't think are the right size. Also I can't find the model number listed but it looks like a 250 quadrunner 2wd and I think it is a 1987 maybe, can anyone help me, also I it has a rich running sound and I put a carb diap in it and cleaned the carb. is there a jet needing replaced?
    • By skgw1
      Feul pump went out. Replaced. At times quad cuts out like its not getting gas. Saw article on new pump needs to be calibrated. Told how to go into a service mode. Does not tell how to calibrate after going into mode. Can anyone shed light on this procedure.
    • By katasha2
      I took apart the carburator to clean out and I can't remember exactly where the springs that are inside the float are supposed to go I've tried to look up schematics but I think I am missing a spring maybe need helpt:confused::confused:
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...