Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

rbstern

1994 Suzuki King Quad 300 - Rear Brake Adjustment

Recommended Posts

1994 King Quad 300.

I replaced the rear pads a few weeks ago. After I adjust the foot and hand lever mechanisms, I get decent stopping power and the parking brake holds fine. But after just a little bit of use, the brake controls (both foot and hand lever) seem to be out of adjustment again. I'm fairly certain I've got the fastners tight everywhere they need to be, but I can't seem to get this gremlin licked.

Any suggestions appreciated.

Share this post


Link to post
Share on other sites


I don't recall, are those hydraulic brakes? Maybe there is a leak somewhere? Are you able to adjust them again when the brakes feel low?

* Added year, make, and model to topic title, shortened issue.

Share this post


Link to post
Share on other sites

Double nut the adjusters on the cable ends where they go to the lever on the rear drum cam. Mine did the same thing and double nutting them did the trick. ( by double nutting I mean get the adjusters set where yah want then thread a 1/4-20 nut on the threaded rods to lock the adjuster nuts in place. ) I have to assume your rear brake set-up is similar, if not the same as mine.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By crochet homemade
      I have bought a 1996 suzuki king quad 300 and I have noticed that it smokes but I have put oil in it and plenty of gas had to fix shifter bc the nuts and bolts came out somewhere. I have had to replace the wire for the starter but now when I try to start it it wont idle at all and when it does run it smokes really bad like a whitish blue I guess, and it likes to stall a lot. So anybody can help me out please and thank you

      10000000_310855426253462_714534016610467840_n.mp4
    • By Ted Aregi
      I've got a king quad 750cc has anyone converted the fuel pump relay to a stronger fuel pump relay on there king quad?
    • By Andrzej Polak
      hi
      Where installing a winch to KINGQUAD ltf300?? someone have any pic?
    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By Gary Skriba
      just got a 99 Kawasaki bayou replace the coil because the spark was very weak still have the same issue before it would start after a while that it would start everyday as long as you started it every day but if you let it set you play hell starting it looking for information on what could possibly be wrong maybe the CDI box not sure any help would greatly be appreciated thank you
  • Similar Tagged Content

    • Guest Fox300exchic
      By Guest Fox300exchic
      Indicators that tell you to check your toe-in.
    • By dirtybear00
      I have a 2000 big bear 400 manual shift. Does not have a shift lever on gender like a Kodiak has left foot operated rn12345 on left foot lever. I replaced the stator and pick up coil and now it is difficult to shift. I marked (indexed) the lever, rod and pivot clamp prior to removal and not sure where to go .  Maybe a clutch adjustment ? Anyone have a manual for this model ? I was sent a manual but it is for a shiftless Kodiak yet it states big bear as well 
    • By arvellaspoon
      When I push down on the rear brake pedal, it makes the left hand brake very sloppy. Is there a way to adjust that? I have a 2007 Suzuki Vinson
    • By chuckcnm
      Hi, just picked up a MOTO 4 YFM255 and want to replace the rear brake pads. How do I get to the back. Guessing I need to remove the brake disk, question any easy way to do this?
      Thanks
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...