Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

strick0323

Kawasaki Prairie 650 - Please help!!!!!!!!!

Recommended Posts

I have a Kawasaki prairie 650. It has about 500hrs. Anyway I changed the front differential oil and I noticed it was slipping. As I turned around to head home my front end became extremely wobbly. As I slowed down to baby it home I heard a really loud bang. It made it home but barley. Nothing visibility broke so I'm figuring the differential locked up. Can someone please lead me in the right direction. Thanks

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Sonders
      It appears that the Service Manual thread at top of forum is dead as all the links no longer work.  I'm actually looking for service manual for a 2000 KVF300 Prairie that I just picked up.  Does anybody have link to one that they can share, or know where I can find one?  Thanks in advance for any help.
    • By Andrew Baker
      I need help with wiring on a 1998 (I think, 10th digit of the VIN was W) Bayou. I'm not getting spark, I'm pretty sure it is due to grounds being off because the harness is pretty hacked as far as the electric start and charging system goes. I'm needing a good wiring schematic. I found one online and there are a few things that don't add up on it so I'm skeptical that it is really for my year and model. Any help would be appreciated. Thanks. 
       
    • By Chris2018
      I have a 1996 Kawasaki Mojave KSF250. I have no manual on it and it has a no spark issue. If anyone could give me a hand with this or would possibly have a manual would appreciate it. 
    • By bradleyheathhays
      I have an '02 Taurus with 85k miles on her that I just bought.  Today when I was checking something under the hood I noticed this metal line cold and dripping with water...
       

       
      I had the air on but turned to the position of arrows pointing out of the dash and floor vents only.  The defrost or a/c function was not selected.  It seems to be doing it consistently.  I haven't traced all the parts of this car's a/c system yet but I don't know of anything else under a hood that turns cold and sweats.  Why would my compressor be working when it's not selected?  What tests should I run?
       
       
       
       
    • By Christopher Freshwater
      I just got a 750 brute force was not running been working on it all day finally got it running but rear cylinder acts like it cuts out and then starts working again and the fan does not come on
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...