Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Earthmover

problems RZR XP 900

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Ben Lennon
      Hi guys new to this forum and thought I’d jump on as I’ve just bought my first quad a Kawasaki bayou klf300c 89 model. It had starting issues when I bought it so I’ve gone thru and replaced the cdi, voltage regulator and starter solenoid aswell as rebuilt the starter motor after all this it was still free spinning on electric start so I pulled the stator cover off to find the fly wheel wasn’t spinning so replaced the one way clutch bearing put it all back together and still not engaging at all. I’m at a loss and looking for some ideas on we’re to look next to solve the problem
      cheers Ben 👍
    • By lanow
      Hi Everyone,
      I am new to this forum and hope that someone out there can help me, I have an early Suzuki King Quad 300 (280cc) which starts intstantly every time but at about half revs or there abouts it starts spluttering and will not rev any higher, this fault is present whether choke is applied or not, some one suggested that silencer maybe be clogged so removed baffle but no improvement have removed carb and stripped 3 times but still no joy.
      Any ideas would be most welcome.
      Cheers Rob
    • By colin james
      View File 2017-2019 sportsman 450/570 with eps factory service manual
      This  is the factory service manual for the 2017-2019 factory service manual for the sportsman 450/570 with electronic power steering 
       
      Submitter colin james Submitted 09/06/2018 Category Polaris ATV  
    • By Flipper Tiffany Roper Jones
      All I have been through everything. Bought brand new.
      Throttle safety switch 
      Cam and rockers
      ECM
      Carborator
      Stator
      Fuel safety switch 
      Battery
      Everything every forum has spoken of I've bought sealed airbox completely tight unplugged black wire on trans. I have literally done everything in the book.Checked oil today full of gas anyone no anything what might b wrong. Next I'm taking head off and making sure valves seat any ideas.
    • By Ryann Racho
      So Id say about 2 years back I bought a 2013 Polaris Sportsman 500 H.O. off of my uncle. It ran perfectly, nothing wrong at all. I usually go mudding with it or just ride trails with buddies. So as you would assume, the quad is quite dirty from sitting for a few weeks.
       
      STUTTERING PROBLEM: I noticed one day out of nowhere that in high gear at 15-20 MPH, I was already maxed out at 4500-5000 RPM  It would get to 15-20 mph, max out on rpms and start sputtering. It sounded like it was basically acting like it couldn’t go any faster than this.
       
      IDLING PROBLEM: I was fucking with the carberator the other day maybe thinking that is causing my sputtering, and now my idle will shoot up to 2600 on start usually, then I will turn the throttle adjustment down to the normal 1400. The rpms with then fluctuate 10-30 rpms back and forth repeatedly, it will then run for about another 30-60 seconds and the RPMs will slowly drop to about 900-1000 RPM and stall out. I replaced the carburetor and everything seems to be working perfect on that, no leaks and what not but it’s still acting strange. Also, I’ve noticed that when looking into the Electronic Throttle Control that two plates that aren’t supposed to touch have to be WAY past touching to even try to fire up. Even when set at a wide open throttle like that, I still have to give it some throttle to get it to fire up.
       
      Here is what I have done so far: 
      Checked the belt and clutch
      Changed out spark plug (Last one was covered in carbon)
      Cleaned the intake and air box
      Replaced the carburetor
      Replaced the inline fuel filter
      Checked that all lines on carburetor are connected into the right spots
      Checked If intake boot was cracked (Not from what I can see)
      Unhooked and reattached new carburetor (About 4-5 times)
      Cleaned battery terminals and battery off
      Shut on and off Gas Line Cutoff Valve
       
       
       
      My next thoughts are that maybe the TPS is fucked up or maybe the Spark Arrestor is plugged with mud. I was thinking tomorrow to purge the exhaust and also check the ohms output on the TPS.
       
      ANY HELP IS GREATLY APPRECIATED. I HAVE BEEN BATTLING THIS FOR WEEK AND REALLY WANT TO GO RIDING. THANK YOU!
  • Similar Tagged Content

    • By Kingquad1
      Hello I am new hear. I just purchased a 1998 Big Bear. It was sitting for 3yrs in storage. The guy I bought it from got the carb cleaned and it runs good. I am having problems with the neutral light. When I shift into neutral the light does not come on. If I mess with the gear shifter, I can get it to come on so I can start it. I can still pull the hand brake and start it that way. I cant find the neutral safity switch on this machine. Any suggestions would be great.
    • By atvinca
      I just picked up a really clean 1995 Moto 4 350. It runs great, but it will only go into one forward gear, neutral and reverse. I can run the shifter up and down and it will finally find a gear, or neutral. What should I do to trouble shoot this?
      Does anyone have a service/repair manual for this model?
      Thanks!
    • By allonroad
      2015 Polaris RZR XP 1000 EPS High Lifter Edition, There aren't many used Highlifters available on the market. Here is a chance to save $$$$$ on a very nice, well cared for.... For more information and photos contact me at [email protected]








    • By allonroad
      2015 Polaris RZR XP 1000 EPS High Lifter Edition, There aren't many used Highlifters available on the market. Here is a chance to save $$$$$ on a very nice, well cared for.... For more information and photos contact me at [email protected]








    • By bayouman
      I have a 1992 Kawasaki bayou 300 4x4. My initial problem it would not run unless full choke was on. So I tried cleaning carb and installed a rebuild kit and it ran bit better but not much. So I replaced carb and spark plug and regulator/rectifier. During testing of new carb the rectifier burned up so I replaced it. Now it fires up and idles fine but it backfires when you rev it up and then it will die as if the key was turned off. Now I know that the coil, cdi box, and stator are all connected. But I don't want to replace any unnecessary parts . This seems to be a ignition/electrical problem. I could really use some advice here as how to go about this. Thanks.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...