Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Fourwhels

2004 Suzuki 400 - Stator Problem

Recommended Posts

I am having a problem with my stator, I have a 2004 suzuki A400F 4x4 auto quad. I have been told that the stator may have built up a glaze because of old oil. My question is can the stator be cleaned up.

Share this post


Link to post
Share on other sites


yeah it should be able to be i havent had this problem with anything but yeah just pull it out and clean it up. I just replaced my with a ricky stator and it works great

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Ajmboy
      Disconnected the plow yesterday on my 2004 Yamaha Grizzly 660 and am getting ready to do some riding yesterday and the battery went weak, Starter cranked a few times but week. Put my trickle charger on that I bought and went to the garage today to start it up, but the starter is just spinning and not engaging. The solenoid is clicking. The pull start sucks and is hard to pull (never use it and need to look into that). Quick video of the starter spinning. Could it be the starter or  the starter clutch one-way bearing? I guess I need to take the cover off to see what's going on.

      2004 Yamaha Grizzly 660 Starter Spinning.mp4
    • By Tanner J Hawley
      Hey so i have a 85 Suzuki lt230s and it runs just fine except for some reason idk but wen i put it in gear and let off the clutch it wont move but the shifter goes threw all gears so idk what or how i would go about fixing it or were to even start?? Any help would b very much appreciated
    • By Kawiherder
      It starts and runs Ok but after a while the temp gage lights up and the fan fails to start.  Any suggestions on where to start looking would be helpful.  Thanks
    • By Rich1028
      Leota Quad Trails
      4-5-20
       
       
  • Similar Tagged Content

    • By Zacharia Maisonneuve
      i have a 1993 timberwolf yamaha and the compression is good and lights work but for some reason the electricity is not going to the spark plug(s)! i got a friend to check it out and they said its no use but im not giving up! please help with this!
    • By Homestead
      My bayou was running. Turned it off. Went to start it again about 20 minutes later and nothing.... no electrical power. No lights, no neutral indicator light. Battery good. Jumped starter and it turns over but doesn't start. I'm not sure what the problem could be. Maybe ci igniter or rectifier?
    • By JPRICE1981
      Hello everyone !! Looking for some help !! Im wanting to check my stator and pick up coil with a ohm meter and cant seem to find a guide that tells me what to read and what my reading should be !! Any help would be great !! THANKS IN ADVANCE !!
    • By JPRICE1981
      Hello Everyone very new to working on ATVs and pretty sure Im getting ready to ask a stupid question !! but here goes !! should i have oil in my stator compartment on my suzuki 500 ?? this bike is backfiring bad and running rich when i pulled the plug to set it at TDC to check the valves I find that there is oil on the flywheel and Ive never seen this on any other ATV before any info would help !! Pretty sure I already know the answer but if you all could entertain me I would be greatfu !! THANKS IN ADVANCE !!
    • By revid
      I have a 2003 trx 350 fourtrax thats not charging .I replaced the rectifier last yr and want to know how I can test it or the stator with a multimeter? I tried to download the manual here but the link must be dead cause I can't get anywhere with it. Iam attaching a pic of my meter so someone can tell me what settings cause I don't know alot about multimeters.Thanks


  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...