Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Candy

2008 polaris 500 EFI sportsman starter issue

Recommended Posts

Hoping someone can help me out here. Just stumbled on this forum while searching for info on 2008 polaris sportsman starter issues. I've got a 2008 polaris sportsman 500 EFI. I'm currently putting in my 4th starter! Does anyone know why I'm going through so many starters?

Share this post


Link to post
Share on other sites


the 500's usually don't have problems with the starters unless it's binding, a voltage or heat issue. when you replaced the starter, was it polaris or chinshu? get the polaris if it was a chinshu before.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By bren7176
      Doeas any have the actual electrical diagram for the distirbution block  for this atv > I had a few wire not worky worky so needed to replace ends plus dam thiing is dirty so needs to clean all the contacts ..
      Want to make shure I get eveything back in right place .... I have the repair manual but as we know it no help really .....
       
      Brendan
    • By jimsvtx
      I'm working on my brothers' 2002 Suzuki Vinson 500 . It sat for a few years before I got into it. I'm concentrating on the carb - I replaced orings, needle, etc. and soaked jets, bowl and anything that I could get off the carb that the solution wouldn't eat. I also removed the tank and flushed it with hot water - it's clean. The gas cap innards rusted away and the tank had a lot of rust and water in it before I cleaned it. I replaced the gas cap and installed a new fuel valve because the screens were broken in the old one. The bike will run but spits and sputters and backfires. If you "open it up" it falls on its face and stalls - but starts right up. Here is a link to an exploded view of the carb: Ohio Honda Yamaha Motorcycle ATV Dealer - J & J Motors - Kawasaki Suzuki Scooter Utility vehicle, parts, accessories, apparel
      Can anyone point me in the direction of the problem? It may still be a "clean carb parts issue" . My problem is that the parts list doesn't identify the parts to a degree that I understand. If you said" look at the pilot jet", I'm not sure which jet that would be....See what I mean? It'll run very good if I remove the air filter and cover the opening with my hand and part my fingers a little for the air to get in. Any help is greatly appreciated.
      Thanks in advance, Jim
    • By Matt John
      Charging issue?
      I have a 2017 Polaris Sportsman 570 EFI. Yesterday, I start the machine and it says low power (10.6-10.8). This machine is on its second battery. This is a new AGM battery with 50cca more than stock.
      Should I look at the regulator or stator?
      Thanks!!!
    • By JacobSlabach
      got 7 atvs off CL recently for a good price.  one of which is a yamaha warrior.  anyone know where the vin is printed on this bike?  Haha good place to start as I do not know year or size yet.  The former owner says needs exhaust ans and clutch work.  he said it ran fine until the clutch cable broke and then I couldn't get the new cable adjusted right and it would grind gears.  things I see:  clutch cable locked up again, no brakes, carb leaking (green with algae around the bowl and has gelled gas stalagtights on it), aftermarket exhaust melted the airbox so I need something different and a new air box.  I would like the use the current exhaust if I can but I have a feeling its a redneck fix as it looks like there is an ace bandage holding it to the exhaust pipe (its an aftermarket slip-on exhaust), so I'm not sure about that- lets get the bike running first.  also, battery (looks brand new, what a shame) is dead, 0 volts.  Otherwise, bike looks to have not been wrecked, and plastics are ok (it sat outside under a 'tarp' for 3+ years since it was run last).  any tips and advise on where to start first would be awesome as this is my first clutched bike (manual).
      the clutch is my main concern- I've never rode a clutched bike so I dont even know what its supposed to feel like.  lol I'm spoiled on my automatic polaris 
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...