Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

miwokdancer

2005 suzuki ozark 250 help..

Recommended Posts

trying to see where the hose coming out of the float bowl connects too please help...also need to know what the rear drive shaft hose fitting coming from top of drive shaft housing connect to

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Brian Simmons
      I am looking at a 90cc Arctic cat 90cc not sure what year right off hand . The shaft broke off right outside the motor . Can anyone help me ? What do I need to do to fix it ? Do you have any pictures or videos ? Let me know ?
       
    • By Kawiherder
      It starts and runs Ok but after a while the temp gage lights up and the fan fails to start.  Any suggestions on where to start looking would be helpful.  Thanks
    • By Colin James Krepela
      So here's the deal people, I have an old Avenger 350 4X4 Shaft Driven ATV. They only made them in the early 80's their thought of as the first four wheelers from around back when Suzuki made one in 1982. I believe the engine on it is a Kohler as I watched this video https://www.bing.com/videos/search?q=avenger+400+atv&view=detail&mid=1E10E939019CA07770031E10E939019CA0777003&FORM=VIRE but mine is a 350. That's if its original, and it all looks original. I am wondering where I can get parts for this engine, or really what engine is it. I have no way to find the year, unless you guys know where a serial number might be. Every sticker is worn off. IF anyone has any information at all on these old wheelers it would be greatly appreciated. I specifically need the gaskets for the carb, and don't tell me I could build them please I want to restore it as perfectly as I can. I can take pictures of the wheeler/carb if it'll help. Let me know.
    • By Kevin Nicoll
      Anyone familiar with these models? Its a new to me quad, picked it up for basically nothing... Just time and materials now, this looks expensive. 




    • By StolenATV
      went to sell this guy my bike and on his test drive he just took off and never came back.
      The post 2015 Yamaha YFZ450R Stolen During Test Drive appeared first on STOLEN 911.
      View the full article
  • Similar Tagged Content

    • By Michael Aiken
      Where can I find a wiring diagram for my 2005 450 Kodiak. Thanks.
    • By Mo Salem
      So my front hub broke, I’d like to put aftermarket on. Hard to find new oe ones. Please help. I’m new to all of this, I have some car knowledge and try to apply it
    • By oxidized_black
      tag : zukifreak
       
       
       
    • By LMI
      Was using the quad the other day to shuttle wood from my pickup to my wood pile.  When the job was done I turned off the Quad and heard a bit of a racket from the front end.  When I got down underneath the sound seemed to be coming from the fan housing.  fan was moving in spurts and not quickly... much like a computer case fan that's had it's day.  What I know.
      Temp sensor is ok, as the fan tries to activate fan is getting some voltage as it is attempting to spin.  When I first bought it used I tested the fan direct to battery and it was fine. The fan was working ok even not direct wired as I went on a couple of rides and when stopped and idling the fan did run Seems to be free spinning with my finger read up in the manual and they require me to drop the rad.  now I'm not opposed to that as the rad has some damaged areas I want to try and straighten out.  But if I can get the fan working without, I can leave the rad as it is until next year.
      Fan assembly is about 300 bills, any work arounds or alternatives?  I even thought large computer case brushless fan.  smaller ones are about $7 larger ones better quality probably far below the 300.  They run standard 12v DC.
      Anything I should be doing before dropping the rad... other than check for obstructions even though it seems to spin, and trying to hardwire it to the battery again for a test to see if it acts the same?
    • Guest Fox300exchic
      By Guest Fox300exchic
      The Hop-Up: You may be saying to yourself, “that’s a chick bike,” and you’re right. But honestly, it’s so much more than that. It’s one badass bike. http://www.quadmagazine.com/quad/features/article/0,24942,1587044,00.html
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...