Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

jimmyjoe912

2007 Arctic Cat 400 fis - Carb Problem

Recommended Posts



my first guess would be bad needle and seat, but swampcat07 may know of something else about the cat. he'll be on here today i'm sure and never ignores an arctic cat issue ...

Share this post


Link to post
Share on other sites

I would say it is carb relayted but I would wager a beer on a stuck float. Try taping on the side of the bowl and see if you can free it. If not a carb cleaning is in order.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Jeff Miller
      I'm trying to troubleshoot a starting issue. For a while, maybe a year sometimes I would hit the starter button and I'd hear a single loud click, but the starter wouldn't turn. Usually if I could pull the pull start or roll it in gear it would then start. (now I'm thinking that was coincidence) Now it only clicks. I tried to check what I could, battery is good, solenoid clicks strong, cleaned all connections (which were 80% clean anyway). I started thinking the starter wasn't spinning. I pulled it and it spins freely. The gear that it contacts in the engine-I can wiggle it maybe 1/16th to 1/8th inch back and forth. When I reinstall the starter I feel it jerk when I hit the button. I'm thinking maybe it's the starter clutch? It seems when there's a problem with them they usually just spin freely and don't engage at all. Is it possibly something is causing it to lock? I'm a bit lost now.
    • By Curtis Hicks
      Ring and pin stripped out along with rear axle ... gonna cost me about 2gs to have it fixed at the shop with all new parts ...wondering if anyone knows of any other bike that would match up or if I could replace whole thing from driveshaft back or from motor back ? ...very broke when it comes to putting money into this bike  just want it to ride again lol ....any help out here ?
    • By Lellwyn Griffin
      I think my rear brakes are stuck.  Is these parts in the right position?  Any idea how I repair?  I have to give it more gas to go and I can't push it when it's in neutral.  


       
    • By nix377
      Friend of mine picked up an LT80 that needs some work. The manufacture date is 11/1986
      The fuel and vacuum lines for the carb were all disconnected. I picked up a new card and was hoping someone on here has a photo or knows how the lines are hooked up
      Thanks in advance
    • By Lellwyn Griffin
      Thinking about buy a used 07 Prairie. Any feedback or suggestions on what to look for?
       
       
      Sent from my iPhone using Tapatalk
  • Similar Tagged Content

    • By mikeexplorer
      Wiring diagram for 2007 Arctic Cat 700 EFI 4x4
       
       
    • By gregj49
      Blows out black smoke when you rev it up how do you adjust the carb?
    • By ut1w7b
      I have a 94 sportsman 400. It sat for several years before i got it. I have cleaned the carb it will start and run for about 5 min then it will flood. I have torn it down and cant see anything wrong. has anyone else ran into this problem any hel would be great.
    • By chevyboy
      AL righty I did some trading around this weekend and ended up picking up a few 4 wheelers for cheap. I ended up with this one for $500 in it total and well the guy told me it dropped a valve. I haven't really messed with it at all. But this weekend I am going to try and start working on it some to get it running before winter time frame. So what I am asking is a couple of questions.
      1. First off where do I start I tried pulling the pull cord and could not get it to move at all.
      2. I need to get a service manual for this 4 wheeler where can I get it downloaded for free?
      3. what do I need to look for and how do I go about this really. I do have experience with 4 wheelers but this one is a little different to me than others because its a V2 and I have no clue where to start internal on the engines. Most of my experience is on the outside portion of troubleshooting on theses wheelers.
      Please no smart butt answers as i am new to here but just wanted opinions on where to start. Please and thanks wink:
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...