Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

bsstewrt

1995 Polaris Trail Boss

Recommended Posts

I have a Polaris 250, 2 stroke. The oil pump drive gear disintegrated due to age It’s made of plastic. I ordered a top end kit, crank bearings, oil pump gear (steal)!

I had the cylinder bore 10 thou. Starts right up and runs great until it warms up. Then want to die at an idle and seem to run hot like it is running to lean. I brought up the needle on the slide to richen it up but it runs very rich. ( 2 stroke pop chug pop) Like they do when running rich. I wonder if the WSM piston is not expanding when hot or if the bore job was a poor job.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Jordan Ritzman
      Any one on here fabricate there own pipes
    • By Tim Orr
      Installed new battery was told that’s what was wrong when hit start button I hear 1 click then nothing?  Can the battery just not have enough amps to crank the starter the first time ? I trickle charged it overnight thought it was enough!
    • By Reece Bowen
      x   just bought this expedition 425 and the Speedo needle does not work. The lights work for the shift indcator. So is this an electronic Speedo or cable? Is there a way to fix it or will I have to replace the unit? Thanks for any help you can provide.
    • By Kaj Colum
      Pushing the start button the engine turns and will forever without starting. But if I use the kick start it will start with one or two kicks everytime, any idea as to what is going on. New good battery and coil, I'm ready to try anything. It's a great bike, but this is getting anoying. Thank you.
    • By marcus23934
      I just bought a 99 sportsman 335. did some work to it got it running good my question is when I put a battery in it the atv starts and idles great once I give it gas it just spits and cuts out and will not ever clear up  thing is if I take the battery terminal off while its running it runs fine and no problem at all  could anyone help me out with what the deal is 
  • Similar Tagged Content

    • By Beb1041
      Looking for a download of a manual
    • By warkcol
      I am having an issue where it sounds like the gears are slipping if I hit the throttle really hard and also after letting off when the engine brake is applied. Also, the drive train that goes to the front also rides again the gear shift box. I will attach pictures and a video here shortly.
      Thanks in advance!
      [ame]
      [/ame]https://postimg.org/image/cdlu6fza9/
    • By Weldingrod47
      Trying to change front wheel bearings. I removed the cotter pin and castle nut. Hub won't budge. Is there an additional retaining clip? Seems to be one of those push on type that barbs on the thread of the spindle. How do I remove it?
    • By buzzar56
      I am looking for a free repair manual for a 2003 Polaris sportsman 500 ho atv. all the posts on here lead me noplace
      thanks fred.
    • By Sniderman
      Does any one have this manual?
      93 trail boss 350 2x4
      Thanx
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...