Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts





  • 2 weeks later...
  • 2 weeks later...


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Tagged Content

    • By Cyberballz
      As title says
      I registered for help, hoping fellow atv'ers can help me.
      94 honda 200 type ii.
      Need to split the case, factory service manual would be helpful.
      Sent from my One using Tapatalk
    • By suthernboy60
      Hello all. New member with a question: Where can I find manuals for a 1989 Yamaha 350 Moto 4? Just traded for one and it runs fine but needs oil change, a cover and brake work. Also needs one head light. Thank you.
    • By uncleal
      I took a quad in trade and was told that it was a blaster, thats it. Tried using the vin decoder in the stickies, but that didnt work. Tried other decoders none of them work.Im taking the vin from the frame in front of the foot peg, that matches the numbers on the engine, and when I put it into a decoder it tells me the vin isn t right. What can I do? thanks
    • By swampy
      i have found a link posted by one of the admin's for the service manual but the links are broken if anyone can please help me find a working link it would be greatly appreciated
      .....i have a 2001 artic cat 250 engine family code 13AXX.2462AA wheeler sat for almost 2 years and most of the machine was in pieces. replaced the front pumpkin,cleaned the carb(mikuni)(main jet 130) and replaced the seat and needle, machine will kinda run but is smoking and skipping like hell acts like its running extremely rich carb has proper jets but i think that someone has tampered with the fuel/air ratio on the machine.
      thank you in advance,Swampy
    • By Admin
      You may have noticed a white text box in the top menu, right side of the page. This is the new Site Search, powered by Google.
      Hopefully this makes it easy to find some things here in the community!
      The site search page is here: SEARCH » QUADCRAZY ATV Community
  • OEM Parts at Aftermarket Prices
  • Similar Topics

    • By Quad king
      I am not sure what is wrong with my King Quad. I had a new carburetor put in 6 months ago, just replaced the fuel pump and added an in-line fuel filter in. I have been trying to fix this quad for a while now and do not know what is wrong with it. It idles fine and runs great as soon as it is fired up, you can Rev it and stay in first gear with 100% power. As soon as I drive 10 feet it looses all power, I mean it is sputtering and doesn't move at all, but when I let off the gas after it sputters it idles fine. I will attach a video of what it is doing.
      Snapchat-1290161440.mp4
    • By lanow
      Hi Everyone,
      I am new to this forum and hope that someone out there can help me, I have an early Suzuki King Quad 300 (280cc) which starts intstantly every time but at about half revs or there abouts it starts spluttering and will not rev any higher, this fault is present whether choke is applied or not, some one suggested that silencer maybe be clogged so removed baffle but no improvement have removed carb and stripped 3 times but still no joy.
      Any ideas would be most welcome.
      Cheers Rob
    • By Puda
      I have 2006 king quad 300 keeps fowling plug any suggestions??
    • By k1ngquad
      I have a small oil leak from the valve cover. Doesn't affect the oil level, more of an annoyance as it creates smoke from burning off the exhaust pipe. I can't seem to find a replacement valve cover gasket, so I'm curious if it even has a valve cover gasket. If not, any ideas on why it would leak?
    • By Ajmboy
      Here is the Polaris online parts catalog, looks like you need to register with then first. I haven't used it since I'm not a Polaris owner and don't need any parts right now...
      http://parts.polarisind.com/Browse/Browse.asp
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...