Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Goodwrench

1st Timer at 64 yrs young

Recommended Posts



Welcome to QC !!! LOL The Greenies out here are trying to protect the praire Dogs !! :aargh: Same one want to protect the coyotes!! I still shoot them !!:laugh:

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By lanow
      Hi Everyone,
      I am new to this forum and hope that someone out there can help me, I have an early Suzuki King Quad 300 (280cc) which starts intstantly every time but at about half revs or there abouts it starts spluttering and will not rev any higher, this fault is present whether choke is applied or not, some one suggested that silencer maybe be clogged so removed baffle but no improvement have removed carb and stripped 3 times but still no joy.
      Any ideas would be most welcome.
      Cheers Rob
    • By StolenATV
      1987 Suzuki LT 80 and 2007 Honda CRF 50 dirt bike stolen out of my driveway on July 4th. Anyone with info that recovers them will get $400 no questions asked.
      Thanks
      The post Suzuki LT 80 Quad And Honda Dirt Bike appeared first on STOLEN 911.
      View the full article
    • By Sonders
      It appears that the Service Manual thread at top of forum is dead as all the links no longer work.  I'm actually looking for service manual for a 2000 KVF300 Prairie that I just picked up.  Does anybody have link to one that they can share, or know where I can find one?  Thanks in advance for any help.
    • By StolenATV
      Bike was on my 2003 Starcraft Starshuttle which was also stolen
      The post Stolen 2004 Suzuki LTZ 400 appeared first on Stolen 911.
      View the full article
  • Similar Tagged Content

    • By Gunny
      We had a few days of rain & then a cold front came thru our area. The claimed we had snow in the mountains, so I went for a ride to see for myself ... and what did I find ?? ........... SNOW !! ......... Not a lot mind you, but it was fun. When I unloaded the bike the temps were 27 degs F (-2.7c) & warmed up all the way to 33 degs F (0.5c) ... for about an hour. The rest of the day the temps stayed at 31 degs F (-0.5c) ... and then the storm came in ........ WOO HOO !!
      I will say however, there was no dust or bugs !! I did see a few people as the muzzle loader deer hunt was on & I think I was the only one that saw a buck !! ...
      Saw a few other deer & then a family of Mooses ... a cow & calf & a nice bull !! I got as close as I dared, making sure there were at least a couple trees between him & I & took what photo's I could ....
      Here's a short video of the days ride, make sure you watch it in 1080p & I hope you enjoy it !!
      [ame=http://www.youtube.com/watch?v=adwkD9J1Dmw]01 Oct 2014 First Snow - YouTube[/ame]
      ...
    • By rolloman
      What was the first year these went into production and sold?
    • By Gunny
      Got the tracks put on the Outty & decided to run up to the mountains today to check out the snow conditions, do some more testing of the Drift GHOST HD Helmet Camera I just got, test out some of the camera mounts I put on my helmet, and a few other things.
      The day was overcast, temps were cool at 23 deg F with winds 40 to 50 mph and light snow. It was GREAT !! :woot:
      I took some video in 1080p, 960p, WVGA & the majority in 720p. After looking at them when I returned home, to me, the 960 & 720p looked the best.
      I added two camera mounts to my helmet. One is on the side of the face shield & the videos with the camera there are pretty good with not much helmet in them.
      The other mount is on top of the helmet & you get an “Overall” view. Not sure which location I like better.
      Both mounts are stick-on with 3M sticky stuff, they seem to hold real well … however, I was walking thru the trees to take some photo’s, a branch hit the mount glued to the side of the face shield & popped that camera off like it wasn’t even glued. I’m sure the cold temps didn’t help either.
      I also took some video with one of my older HD170 cameras. The exposure setting on both the HD170 & the GHOST were set at zero … and you’ll see that the HD170 is much darker. So on overcast days, I’ll have to remember to set that camera at +1.
      I must’ve hit the remote too many times at some point today too, because I had 177 photo’s instead of video. Dang it, that means I’m gonna have to re-read the instructions ……….. again ….
      Here’s a short video of today’s ride, hope you enjoy it …
      [ame=http://www.youtube.com/watch?v=E8Mlhopr9KY]12 Dec 2012 - 1st Track Ride - 2012-2013 Season - YouTube[/ame]
      ....
    • By TEAMFASRACING
      Testing the waters on getting all the different SXS forum guys for a huge ride and party up at the pocohontas trail lodge this spring .....this event could be the biggest on the east coast if we all pitch in who interested?????- JT
      So Far it looks like these will be the things discussed to be included in the ticket price plus Much More! What else would everyone like to see?
      Dinner 1 or 2 Nights
      Raffles
      Giveaways
      250' + Long Open Mud Pit Play Area
      1st Annual East Coast SXS Rally Event Shirt
      Nightly Entertainment
      Nightly Bonfire
      Inflatable Rides and Games for Kids
      ATV / UTV Parade
      Meet & Greet / Show and Shine / Swamp Meet
      "Run what ya Brung Drags" Race your Buddies for Fun
      Group Pictures
      Guided Tours and Group Rides if Requested by PSEM Staff
      Vendors and Sponsor Exhibit Areas
      PSEM is also finalizing Vendor Info and anyone looking to support the event or sponsor it in anyway please contact me via PM.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...