Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

LTZRider14

Clutch Kit for LTZ-250

Recommended Posts

I was looking online and seen the clutch kits for my fourwheeler (2005 LTZ-250). I am interested in the kits and was wondering if anyone on here knew if they were any good? Or worth the price?

Thanks, LTZRider

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By John conway
      My quad will start sometimes than just die well it’s running than won’t start again for a day , put in new battery same problem and it seems to drain battery any help would be great
    • By xXDaveXx
      https://www.amazon.com/Primary-1998-2005-Polaris-Sportsman-Braking/dp/B01G2EEUV2
      Anyone ever try these? $500 for a OEM clutch seems high, But $120 seems a little cheap to me. Has anyone tried one with good luck? 
    • By BuckBilly
      Good morning to all !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
      Let's see if we can make this a daily event.
    • By w_r_e
      Well, after tinkering on my last project (a 2003 Kawasaki Bayou 300) I ended up putting it on Craigslist and it sold within a day. Then about two weeks after that a 2005 Mule 610 with 40 hours on it popped up, for about 1/3 the cost I usually see them, so... I didn't have much of a choice.
      The Mule's first issue was idle, it would die if you didn't keep a light toe on the accelerator. Turns out the idle screw had never been touched, five minutes after I got it off the trailer it idles just fine. 🤦‍♂️
      As of today, it runs great on flat land. And it climbs like, well, a mule.
      But it has one issue. Sometimes uphill it will suddenly lose power like the fuel isn't getting delivered. It never dies completely, it just sputters and won't go until you let off the gas pedal and let it recover. It tends to do it more with 2 passengers or some cargo and wide open throttle BUT occasionally will do it at only partial throttle and with just me on it. 
      I read a lot about how the fuel pumps on these Mule 610's suck, so I put in a new one today and a new fuel filter. It still had the same symptoms immediately after, so that was $40 wasted.
      Any ideas? I keep seeing folks saying they replaced the pulse pump with an electric fuel pump. This thread said so, and it gets brought up in this thread and also here. In each case somebody says "12v fuel pump solved my problem!" and then they promptly disappear from ever posting again, lol.
      I have some questions for y'all:
      1. Do you think fuel delivery is the problem? I have a hunch that it is, given the hill + throttle symptoms.
      2. The pulse pump on the Mule is located ABOVE the gas tank. Can an electric fuel pump pull fuel UP in this manner?
      3. What would I do with the spare line that goes from the fuel pump to the crankcase? Every electrical pump is just in & out, they don't have that third line...
      4. Any idea what kind of flow rate I would need or which pump works for this application?
       
    • By Cj Winds
      I have a 2005 Yamaha Kodiak 400 Automatic. It has an oil leak inside clutch cover. The middle gear has two oil seals, the front seal is leaking engine oil into clutch area. How do you change the leaking seal?
  • Similar Tagged Content

    • By xXDaveXx
      https://www.amazon.com/Primary-1998-2005-Polaris-Sportsman-Braking/dp/B01G2EEUV2
      Anyone ever try these? $500 for a OEM clutch seems high, But $120 seems a little cheap to me. Has anyone tried one with good luck? 
    • By Ssg
      Hello! This is my first bike with a cvt it's a 19 Outlander 850 xmr. I use the 30" cryptid tires that come with the bike during hunting season since I hunt in a louisiana swamp and I have some 27" interco reptiles during the summer trail rides. So this past hunting season I got stuck and squealed the belt do i looking at cluch kits /adjustments to help with the low end but I dont want to mess with my summer riding so I'm looking for advice 
    • By Bruce Sawyer
      1987 YFM350FWTB 350 4x4 Big Bear when going uphill will sometimes act like the clutch realeases then re-engauge all at once.
      Seems to maybe be little more often if the engine is at about 1/2 throttle instead of at lower rpms.
      I have the Factory Service manual and checked the external clutch adjustment screw as ok and the H/L/reverse shifter lever linkage as adjusted correctly. It appears to be maybe a internal (inside the case) clutch issue or ??
      This is the type Big Bear that has the manual shift lever on the left front fender and has the manual foot shifter lever with 5 speeds forward.
      Can someone tell me how the primary and secondary clutch operates? 
      I assume one is mechanical and one is centrifugal. (what I'm asking is one clutch for the higher rpms and one for the lower rpms or ???. (the clutch appears to only momentarily release at the higher rpms is why I ask. The cycle has about 3000 miles of low speed through the brush hunting and has been well maintained, oil changed, etc and no deep water or mud useage.
      Anyone been into a similar issue with the big Bear ATV????
    • By mrfartsalot
      i have a 2001 suzuki quadmaster 500 4x4 that the primary cvt clutch is rusted on any ideas on how to get it off i want to try to reuse it if possible.
    • By Tyler Autry
      Recently started shifting hard from neutral to first causing it to stall. I'm able to lift up on the shifter and throttle up and slowly let off the shifter, like driving a standard. That is the only way to get it In gear and stay running. Also if I come to a stop and keep it in gear it wants to continue moving, eventually stalling out. I don't have much experience with the bottom end or clutches. I just now replaced friction and steel plates and that made no difference. Don't know what to do now.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...