Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Prof_Turby

98 Arctic Cat 300 2x4 Carb Question???

Recommended Posts

Several months ago I repaired the carb to my sons 98 300 2x4...

My mechanic cleaned the carb and replaced a needle seat...

$6 part...

My question...

Is there anyway to prime the darn thing?

The high idle gas setting does not do a good job priming the carb for cold starting...

If you let the thing sit for a month or so it is the coldest natured engine I have ever owned...

Ever...

I understand that the newer carbed models came with a primer bulb...

Is there a fix for this issue other than ponying up for a newer carb???

BTW, I filled up the tank with gas and utilized ethanol treatment...

Many thanks for any replies...

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Buell
      Hey guys, figure you guys would have some helpful direction or answers.
      So, 05 Sportsman 700 carb, new carb, fuel pump, new plugs, new air filter, new everything I can think of that is usually the running issues. Starts up fine, seems to run fine, but if under load, two people, or even one person, up a hill, or pulling a drag chain for the driveway, it starts to cut out and sputters and loses all power, until I back off on the throttle and just barely try to let itself catch itself and then I can take off again.
      I am going crazy trying to figure this thing out. Other than that, the quad runs great. Parents bought bran new, just used around the property, 5000 miles on it. Any ideas???
    • By Ellery Zandt
      Does anyone have a redcat 250 or falcon 250cc that they can share where the two vacuum lines on the carburetor that you run antifreeze through I honestly have no idea where the lines are suppose to go to circulate the antifreeze. 
       
      Any help is greatly appreciated. 
       
    • By WILYUMS
      Took a little ride around the farm today. It was good to get away from the TV, Politicians, and all around bad news. Only an hour or two, but helped recharge me. This is in Western KY on our farm. About 85 degrees today here. I will still get you guys a run down in the newer ohv and atv parks here in this end of the state. But not today I'm thinking of heading back out for a night ride later.








    • By Joe Dickerson
      I decided to replace the rings and piston on this machine because it looked like the plug was being fouled by oil. When I removed the right side of engine to inspect the clutch pack, I found 2 small round pieces with tiny expansion rings in the bottom cover. It looks like "clutch pawls" according to the illustration, but Id like to be sure. I saw that there are 4 of these in the new gasket set.
      Can someone help me here?
      I thank you in advance
      Joe
       
       

  • Similar Tagged Content

    • By Quad Bug
      I most have a rare ATV, because I can not find a service manual without paying money to Kawasaki.  It's a 2005 Prairie 360 2x4.   4x4 manuals are all over the place, but nothing for a 2x4 .  Heck, Bike Bandit doesn't even list parts for a 2x4.   Any suggestions besides paying Kawa.  My machine is in limp mode and I've yet to find an applicable video or even procedure. 
    • By gregj49
      Blows out black smoke when you rev it up how do you adjust the carb?
    • By patricknperkins
      Ok, so got this thing, assembled, and even added acid/assembled the battery with a solid trickle charge and the battery is fine.
      As far as I can tell, I have checked all the fuses I can find, but I have ZERO power to anything. Even the console will not light up when turned to ON.
      Is there some sort of hidden parental/child disconnect or safety switch that I'm not aware of? ANY help would be appreciated.
    • By Sniderman
      Does any one have this manual?
      93 trail boss 350 2x4
      Thanx
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...