Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

dawghouse

2003 Kawasaki Mojave KSF 250 - Needing HELP!

Recommended Posts

My son has an 03 kawasaki mojave ksf 250 and the thing idles fine and starts right up but when you start off in first gear the thing brakes up and spits and sputters till your moving I noticed that as soon as you are off idle it is fine,I cleaned the carb and gas tank but still no better any IDEAS?

Share this post


Link to post
Share on other sites




Did the plug take care of it, then?

I tried the plug but no luck but I had a friend take a look at the carburator and he said there were a lot of hands in the carb before I got it and that the jetting was wrong and parts were missing he was surprized it ran at all so I am having someone who knows what they are doing to work on the carb cause I have no clue when it comes to carbs and jetting

Thank you for your help

Share this post


Link to post
Share on other sites

Hi all, I'm going to change the oil in the engine just did not know how many gallons pour. Do you know how much you can pour liters of oil into the Kawasaki KSF 250?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Mike Johnson
      Does anyone know what the 3rd item is behind the battery on this ATV ? I know 1 is the,  solenoid1 is the CDI box, what is the 3rd.
    • By Daniel Gibson
      Working on a bayou 220 that has been ran extremely hard it's whole life. Literally had almost an inch thick dirt/oil covering the motor. Yeah that bad. Surprisingly it runs though. I cleaned the carb and tank multiple times. They're clean enough to eat off of. Readjusted valve lash and set timing. Was about 3 teeth off. It cranks good and runs good only problem is I have to cover the carb intake basically choking the hell out of it for it to start. The com choke works fine. It does this each time I start it regardless of temperature both ambient or motor. Wth? Compression is at 115psi I get 130s if I put a little oil in the piston chamber. Please help. Thanks 
    • By JC4x4
      My Honda Fourtrax won't start. The starter is kicking the engine over, but it won't start. It sat for about a year while I was living away, so I thought it might have been bad gas. I completely drained the fuel, flushed the fuel lines and filled it with fresh gas. However, still nothing. It started and ran fine the last time I used it. Any suggestions on how to diagnose this? It could be fuel or electrical at this point. Is there an easy way to rule one or the other out? Thanks
    • By Andrew Baker
      I need help with wiring on a 1998 (I think, 10th digit of the VIN was W) Bayou. I'm not getting spark, I'm pretty sure it is due to grounds being off because the harness is pretty hacked as far as the electric start and charging system goes. I'm needing a good wiring schematic. I found one online and there are a few things that don't add up on it so I'm skeptical that it is really for my year and model. Any help would be appreciated. Thanks. 
       
    • By Quadrunner44
      I have an older 1980s Suzuki quadrunner red lt 4wd (250)
      so just finished putting it all back together and was running fine just needed to adjust the rebuilt carb
      bf decides to hook up an air chuck to the gas tank because it got a shot of air in the gas line well 120psi didn’t agree with any of the parts including the new carb 
      end result : new battery new carb now it just clicks (one single click) won’t turn over 
      hard to pull start gets hung up (unless I remove the spark plug ) gas flooded out the first time but now does nothing purchases a new starter waiting the arrival 
      could there be damage to the crank shaft or pistons etc? Or install the new starter and try to fire it up ? What caused the starter to die after he flooded everything with gas was working fine. 
      Thank you 
  • Similar Tagged Content

    • By kemperboy01
      i have a 2003 yamaha big bear 400 i have a jumping idle and at low speeds it cuts off untill warm i have bought a kit for carb adjusted carb it still doesnt work so im either going with valves or electic issue im wondering if it is my stator what yall think??
    • By dIrTee_dEEdZ
      Hello i have recently purchased my kids a second hand Kazuma as a beginners bike, i would love to add a speedometer and a RPM tacho if possible for a little added safety so they dont flip it but i really have no idea where to start, sorry if sounds silly, .....how and where do i connect the speedo to(I mean electronics wise) and also how and where do i wire/connect the tacho to?
      Thanks in advance
      Allan
    • By Jeremyv
      I just bought a 97 big bear 350 2×4 for the family to ride.. it's smokes real bad on start up and ride, the guy I bought it from said it just needs rings.. should I go ahead and replace the piston, rings, and hone and bore it if it hasent already been done? And where can I find the parts for a good price??? Also should I let my kids ride it the way it is, will it trash it out if they do??? Any info and options is helpful and welcomed, so please c him in!!!!! Thanks in advance!!!
    • By rootbeerkid89
      hi i just got me a 89 yamaha breeze 125 and i was woundering how to take the battery out thanks
    • By tuddyt
      im new here and have a problem bought a 04 honda 400 at and i change the centrfugal clutch,drum and one way bearing now when the engine is cold it grinds,boggs down until the motor warms up then everything works fine. put 20/50 gn4 honda oil in it also appreciate any help thanks
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...