Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

brandon07

2007 Yamaha Raptor 700 - Part Swap

Recommended Posts

does anybody know if the meter on a newer raptor 700 will work on an 07 model.

i know you half to change the hood out. but i mean like the tach/ speed/hour/time.

cost on that meter is 266 so i dont want to buy it if it wont work..

Share this post


Link to post
Share on other sites


does anybody know if the meter on a newer raptor 700 will work on an 07 model.

i know you half to change the hood out. but i mean like the tach/ speed/hour/time.

cost on that meter is 266 so i dont want to buy it if it wont work..

Are u talkin about a Trail Tech computer or something ?

Share this post


Link to post
Share on other sites

no the 07 raptors have only a small 4inch window. the newer 09 models have a diffrent meter on them it showes tach/mph/hours ridden/and my 07 just has that idiot light on it. its a yamaha part.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Venom
      Hi All,
      I did a total restoration on a 2003 Yamaha Raptor 80. Rebuilt the engine and tranny.. Started it up today and it runs great. Took it for a ride and the transmission worked perfectly. Adjusted the carb a little more and went for another ride. It ran awesome, pulled into the workshop shifted into neutral ( Neutral light came on) and shut off the bike. went to roll it and noticed she would not roll. Turned on the key and neutral light was on... After some troubleshooting I found that she is in first gear with the neutral light on and will not shift into neutral... It seems to up shift fine into 2nd and 3rd and then back down to 1st. I am hoping somebody can shed some light on what is happening... Thanks for any help...

    • By Venom
      Hi, All

      I started this project a while ago.. I have decided to make one thread I can continuously update..

      So , here we go. I got this Raptor 80 in really bad condition.. Rear end frozen, Engine toast, tires dry rotted, tons of rust..etc.. They admitted they beat on it very hard.

      Since they do not make these with a drive shaft anymore I decided to restore it from top to bottom..

      These are photos of when I got it home.

      Next up, the tear down..



      First, I needed to tear it down and determine if the rear end was still good... As we all know... That is where it would be cost prohibitive to restore if it is trashed..

      Got it completely stripped down and I lucked out... The rear Drum brake was caked solid inside with dried mud. That was causing the rear end to lock up. Took off the rear brakes and the rear end spun perfectly smooth.

      Once I got it all stripped apart I needed to take the finish off all the parts. I am going to be powder coating the frame and many parts.. Once the finish is off each part it will need to be sandblasted to white metal .. The guy I use for powder coating gives me a hefty discount if I bring the parts to him ready to go.

      You could just sand blast, but that would take a long time to get the finish off. First I used Aircraft Paint Remover.. That stuff is pretty toxic Goggles and Resperator are required. That quickly gets you down to the metal... Then you can sand blast to white metal pretty quickly...


      I had another thread I had started about a problem with the tear down... It has some great info .... here is the link... It is about removing the frame bushings. ....
       
      https://www.quadcrazy.com/atvforum/topic/14209-raptor-80-frame-bushings/?tab=comments#comment-104702
    • By jrhoads23
      I picked up a 2017 Polaris Sportsman 850. The previous owner rarely rode it and it only had 53 miles on it (10 hours). I believe the Polaris break in period is something like 250 miles / 50 hours or something like that at which point they suggest doing the first oil and fluid change. My question is should I do it sooner than that? I believe this was manufactured in fall of 2016 so that means the fluids in there are 3 years old. Maybe that isnt a big deal and it is still fine to wait until 50 hours, but just wanted to check
    • By Reece Bowen
      x   just bought this expedition 425 and the Speedo needle does not work. The lights work for the shift indcator. So is this an electronic Speedo or cable? Is there a way to fix it or will I have to replace the unit? Thanks for any help you can provide.
    • By wendi loden
      I replaced the fuel pump filter and it ran great for a week or so. Then while driving across the yard in 3rd gear it shut off and hasn't started since. It has fire and its getting fuel, all fuses are good, battery fully charged. The fuel pump relay seems to be warmer than it should be when spinning it over. Any help is appreciated!
  • Similar Tagged Content

    • By mikeexplorer
      Wiring diagram for 2007 Arctic Cat 700 EFI 4x4
       
       
    • By Admin
      2007 Arctic Cat 700 EFI 4x4 Wiring Diagram
    • By Admin
      View File 2007 Arctic Cat 700 EFI 4x4 Wiring Diagram
      2007 Arctic Cat 700 EFI 4x4 Wiring Diagram
      Submitter Admin Submitted 06/29/2019 Category Arctic Cat ATV  
    • By x
      It's time to replace the shocks and struts.  Looking for some stiffer springs than the OEM as I use this for farm work and I put heavy loads on the rear and haul small trailers frequently.  I've seen a couple aftermarket offerings that say they're 10% or so heavier duty.  Any other options for something a little stronger / stiffer?  Thanks.
    • By LMI
      The saga of the fan continues.
      The Pin attempt in the fan shaft failed.  I then moved on to trying to weld the fan hub to the fan shaft.  I took it for a run the weld broke.  Now it was truly F'ed.  To recap the dealer price, they want $400 + CND for a replacement fan assembly.
      I searched all sorts of after market places and no one carried one.  Ebay had some used ones but they were $120 USD + Conversion rate for something as old as what I have.  I went to Amazon and eventually settled on this.
       
      amazon link
       
      What I found... and was amazed... was that the fan mounted to the Suzuki fan assembly bracket.  I was prepared to manufacture my own mount conversions...  It also came with "Harpoon mounts" (nylon zip tie like things that go straight through the rad.   Anyways it mounted to the original bracket. It fit perfectly.  Cut the electrical plug off replaced it with the Suzuki... all good.  Let the quad heat up, thermo coupler kicked in the fan circuit, polarity was right... all was good....  Fan is under the circuit fuse rating.  
       
      so I finally have a solid fan solution.  $34 CND vs $400+ CND
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...