Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
Earthmover

Body Lift Kits

Recommended Posts

Hi I'm thinking of installing a body lift kit on my 02 F-250. Can any one tell me if there is any hidden costs involved for instance, do I need to extend my brake lines, steering collum transmission linkages or wiring

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By Hondasher
      I have a 2004 Polaris Trail Boss 330 and I want to eventually fix it up if possible, but the thing is the transmission or Gearbox that allows you to shift into forward and reverse and such isn't connect to the engine at all, it isn't even bolted into the frame. Anyways the Secondary Driven clutch is missing. The ignition was busted so I switched it out and tried to hook up power to it and the lights wouldn't light up and it wouldn't try to let me start it with the electric starter. 
       
      So I bridged the connectors on the starter solenoid and it cranks the motor. I was wondering if anyone knew why the dash lights don't work or any of the buttons. I did find a cable disconnected I have a picture of maybe someone can tell me what it's supposed to be connected to. It has 3 wires going to the connect Green Purple Red. I'll enclose a picture of it and where it is connected on the wiring harness. 
       


    • By Andrew Baker
      I need help with wiring on a 1998 (I think, 10th digit of the VIN was W) Bayou. I'm not getting spark, I'm pretty sure it is due to grounds being off because the harness is pretty hacked as far as the electric start and charging system goes. I'm needing a good wiring schematic. I found one online and there are a few things that don't add up on it so I'm skeptical that it is really for my year and model. Any help would be appreciated. Thanks. 
       
    • By Joseph Miller
      Hi guys im new here and ive been doing alot of research on my polaris predator i was wondering if anyone on here has wired a different cdi up on there quad? Not a direct replacement that would simply just plug in. I know my white an w/red wires go to my pulsar my green an blue go to my reverse coil but im unsure which is + and which is ground also brown/w is a ground correct? What about purple? Black goes to my kill switch and red is my 12v supply........then ive got yelloww/red , yellow / yellow that goes to my rectifier..........any input on this subject is greatly appreciated thank you all
    • By bradleyheathhays
      Have an '02 Ford Taurus that's been grandma driven for all of it's 95k miles. After doing some very easy driving in town for a couple hours today I accelerated up to about 50 and noticed the car didn't seem to be responding to the gas pedal anymore. Looked down and the engine was doing 4k rpm so I let off the gas. Pumped the gas a couple times to see if the car responded and got nothing. Coasted to a stop in a safe lane and tested it in all the gears...nothing. The car stays put if you put it in park but you can roll it back when in any other gear position. The gear leaver on the tree does still give resistance when you move between gears. No music was playing and there was no noticeable sound whenever the breakage occurred.

      Called a friend and was advised to check the gear shift linkage at the top of the transmission. I'm not familiar with what the arm's full range of motion is supposed to be but I noted it's position while in park and low 1 and it seems to be moving well. Felt the connections and they seemed solid.

      Without the benefit of being able to do a proper run-up to a transmission fluid check I wiped and re-dipped the stick and it read fairly high although I hadn't added any fluid for at least 10k miles. The fluid was just a shade darker than light pink and although I didn't check specifically it didn't seem to have a burnt smell.

      There's no way low engine oil could cause something like this is there?

      Any ideas?
    • By Ellery Zandt
      I have no idea where the antifreeze line coming off the thermostat goes too. The carb two nipples in the pic create a vacumme. Can someone help me on this please....!!! my email direct is [email protected]!!!!
  • Similar Tagged Content

    • By Gorilla_Whips
      Hey guys, if you need any LED safety whips or undermount kits, look no further than Gorilla Whips Safety Whip Flags. These are the best, brightest and toughest whips and undermounts you will find on the market today. And if you use promo code: DAR10, anytime, we'll give you a 10% discount off your entire order! This promo code does not expire!
      If you love Cyber Monday deals, make sure to check out this deal that runs through Cyber Monday
      CYBER MONDAY ONLY SALE: Get 20% off orders of $250 or more on December 1st. Light up your #ATV, #UTV, #RZR, truck, and more with the top rated color changing LED Xtreme whips and Undermount kits from Gorilla Whips Safety Whip Flags. Use PROMO CODE: FANS20 #StrongerBrighterBetterGuaranteed #CyberMonday #LEDs

    • By cdr42798
      Hey guys I just bought a new Honda es 250, and Ive been looking at buying a lift kit for it but Im unable to find one. Can anyone link me to one that fits the model. Or tell me if anyone can do a custom one.
      Thanks,
      cdr42798
    • By Getch
      Hi all,
      Thinking I may need to replace clutch disks on my 1990 Big Bear at some point in the near future.
      I've seen a bunch on ebay for anywhere from 40-70 bucks. Wondering if they are quality parts or better to stay away?
      Thanks!
    • By dirtjunkie85
      Anyone know of a good yet small and light weight flat repair kit I am looking for something I can carry with me during my desert races incase I get a flat tire and am out away from any help any suggestions would be appricated thanks!!
    • By Eiger400
      I have a New Moose 1-2in lift for an Eiger 400 4x4.
      $60 shipped lower 48
      Im in Maryland
      Email for pics
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...