Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

brandicomo

Honda rancher 2011 4x4 all jokes aside need help

Recommended Posts

Ok in short, sunk bike had engine rebuilt, rode it, ran great, started smoking the second time it was rode, brought it back to mechanic he said it was bad rings, over hauled again, rode great first ride, second time started smoking, brought it back, overhauled a third time, started smoking again when idling after riding for like 3 hours, smokes when giving it gas, big cloud of white smoke that smells like oil, oh and the first time it was ovehauled added programmer, don't know what else it could be, someone said packing in the exhaust, but I'm on my third mechanic and no one can figure it out! ! Oh and I'm a girl so if I said something dumb don't be mean! ! K thx in advance

Share this post


Link to post
Share on other sites


might be the top end leaking oil into the combustion chamber. also to eliminate the muffler packing, remove the muffler and run it for a little bit to see if it still smokes. Need a compression check and a leakdown test. Find another mechanic please. I hope these mechanics arent friends of yours.

Are you breaking in the lower end after the rebuilds? That is very important to ring life.

Edited by marioweldinginc

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By barracuda420
      Hi, I'm new to ATV/UTV's and am looking for any advice that would help to repair my 2018 Ranger 500.  I got it from an insurance auction and have never owned one before.
      It looks like it was sunk deep.  Found rocks and sand in the roof, milky oil in the air filter box, water in the fuse box, etc.
      So far, I've cleaned the air box out, vacuumed most of the rocks and sand, checked the engine, trans and diff casings for cracks/leaks.
      The battery would not charge while connected so I know there is some short somewhere...probably the wet fuse box.
       
      I plan on drying out the fuse box and all connectors with a hairdryer tomorrow, check the fuses, remove/dry out the ECM and disassemble/clean the air intake.  Then install the battery and see if i can get it to key on and see what kind of lights I get.
      Need to know what to expect with the engine/trans...
      Thanks.
       
    • By Scott Sirr
      I need to figure out how to clean/fix or replace my neutral switch assembly On my 2008 Yamaha big bear 400 as generally the neutral light doesn’t come on when it is in neutral. To get it to come on I have to wiggle the foot shifter and hold it in just the right spot.
      I have googled it and can’t find much on the 400’s. I can’t find a service manual online and the parts manual is super vague.
      I think it is in the right side engine cover area, but not certain. 
       Any help would be great. thanks
      Scott
    • By David Miller
      Does anyone know how to access the check engine codes on a 2018 450 sportsman. Just changed battery and spark plug . It runs fine but the light is on and I need this to plow snow and need it reliable. Any ideas . Thanks
    • By YamahaGrizzly
      So my Yamaha grizzly 700 wasn't going into reverse for some reason but Jon and George figured it out on what to do to fix that problem for me. Jon Talks about how he was able to fix that problem my Yamaha Grizzly was having with the reverse.
      On a side note we are so close to 1k subs! hell ya!
    • By bradley nelson
      Im cool with the police in my area so i can ride on public roads.
  • Similar Tagged Content

    • By sloundez
      Does anyone out there know where I can get a functional pair of wheel cylinders for subject ATV? Any suggestions welcomed. Thanks
    • By M0BJT
      Hi Everyone
      This is my first post and I was wondering if there is anyone who can help me solve a problem I have with my Yamaha Kodiak 400 4x4 Fitted with a Mikuni Carburetor . The year of the quad is around 1998, the reason I am not sure of the date is, there wasn't any paperwork and no details on the frame either.
      The quad had a bad leak from the carb overflow which indicated that the float needle valve was blocked or passing so I replaced this and put everything back together. The quad ran really well until I took it onto some rough ground to have a ride around, a few hours later the engine started to run really rough as if the engine was flooding. I have removed the carb again and cleaned the needle valve out and the whole of the carb just in case there where any dirt behind it. Engine now runs fine again but fuel has started to run out the carb overflow again.
      I have tried everything to try and stop the fuel leaking out the overflow but its still happening. My last thoughts where to adjust the float level and its still happening.
      Has anyone got any thoughts on the problem or could suggest whats causing the fuel leaking out the overflow.
      Thanks for reading
      Kevin
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...