Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

Yeah!!!!:bouncing_smiles:Glad to be back on here. Those website issues had kept me away for a little. :thatwasgay: All seems to be working well again, so what has everyone been up to?:cheer:

Share this post


Link to post
Share on other sites


Yeah!!!!:bouncing_smiles:Glad to be back on here. Those website issues had kept me away for a little. :thatwasgay: All seems to be working well again, so what has everyone been up to?:cheer:

Workin and shoveling snow !!:no:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By jimsvtx
      I'm working on my brothers' 2002 Suzuki Vinson 500 . It sat for a few years before I got into it. I'm concentrating on the carb - I replaced orings, needle, etc. and soaked jets, bowl and anything that I could get off the carb that the solution wouldn't eat. I also removed the tank and flushed it with hot water - it's clean. The gas cap innards rusted away and the tank had a lot of rust and water in it before I cleaned it. I replaced the gas cap and installed a new fuel valve because the screens were broken in the old one. The bike will run but spits and sputters and backfires. If you "open it up" it falls on its face and stalls - but starts right up. Here is a link to an exploded view of the carb: Ohio Honda Yamaha Motorcycle ATV Dealer - J & J Motors - Kawasaki Suzuki Scooter Utility vehicle, parts, accessories, apparel
      Can anyone point me in the direction of the problem? It may still be a "clean carb parts issue" . My problem is that the parts list doesn't identify the parts to a degree that I understand. If you said" look at the pilot jet", I'm not sure which jet that would be....See what I mean? It'll run very good if I remove the air filter and cover the opening with my hand and part my fingers a little for the air to get in. Any help is greatly appreciated.
      Thanks in advance, Jim
    • By Sonders
      Hey all, I recently bought an 01' Sportsman 500 HO from my brother in-law that he's had since new.  It runs awesome, just has 2 slight issues that I am addressing.  1st issue is fuel dripping out of overflow.  I did some searching around and saw that the O-rings in the carb wear out and allow fuel to leak, so I replaced both the Orings inside the carb.  This didn't fix it and still leaking which leads me to believe the float needs adjusted, I'm just not sure on correct way to check and correct this.  2nd issue is no speedometer.  Also in researching this it appears to be Hall Effect/speed sensor.  I'll be ordering one of those to replace, which sounds like a pretty straight forward process.  I guess really my only reason for the post is to get some help on the gas leak issue.  Any thoughts?  Other than that, I love the bike and really enjoy riding it.  Thanks in advance for any replies.
    • By quadtech62
      I have a 02 Warrior i am trying to build a wiring harness i have looked in the manual and  i am confused... the pick up has 2 wires.  W/R W/G The source rotation coil has 2 wires. One is Red other is white/blue. The manual shows the  the white and blue wire connected to the w/g  right after the stator... so why is these 2 wires connected?  Does not show w/b wire at cdi 
      i have looked at many options with no luck if someone has a 2002-2004 warrior and can take a pic of the wires and location at cdi i would really appreciate it. Thanks
    • By JacobSlabach
      got 7 atvs off CL recently for a good price.  one of which is a yamaha warrior.  anyone know where the vin is printed on this bike?  Haha good place to start as I do not know year or size yet.  The former owner says needs exhaust ans and clutch work.  he said it ran fine until the clutch cable broke and then I couldn't get the new cable adjusted right and it would grind gears.  things I see:  clutch cable locked up again, no brakes, carb leaking (green with algae around the bowl and has gelled gas stalagtights on it), aftermarket exhaust melted the airbox so I need something different and a new air box.  I would like the use the current exhaust if I can but I have a feeling its a redneck fix as it looks like there is an ace bandage holding it to the exhaust pipe (its an aftermarket slip-on exhaust), so I'm not sure about that- lets get the bike running first.  also, battery (looks brand new, what a shame) is dead, 0 volts.  Otherwise, bike looks to have not been wrecked, and plastics are ok (it sat outside under a 'tarp' for 3+ years since it was run last).  any tips and advise on where to start first would be awesome as this is my first clutched bike (manual).
      the clutch is my main concern- I've never rode a clutched bike so I dont even know what its supposed to feel like.  lol I'm spoiled on my automatic polaris 
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...