Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Guest yokochrist

Yokochrist Video Thread

Recommended Posts

Guest yokochrist

Figured I would start one thread instead of starting a new one every time I share a video.

Here is a link to my YouTube channel for past videos: yokochrist - YouTube

Share this post


Link to post
Share on other sites


Guest yokochrist

Not a new video, but we should have some after this coming weekend:) Enjoy!

Share this post


Link to post
Share on other sites
Guest yokochrist

May 18th Ride

Share this post


Link to post
Share on other sites


Guest yokochrist

Thanks!

Share this post


Link to post
Share on other sites


Guest yokochrist

Thanks!

Share this post


Link to post
Share on other sites
Guest yokochrist

07petersty's 850 Front Diff Goes Boom!!

Share this post


Link to post
Share on other sites
Guest yokochrist

2013 Mud Nats Hill City, MN

Share this post


Link to post
Share on other sites


Guest yokochrist

Thanks more to come!

Share this post


Link to post
Share on other sites


Guest yokochrist

Nice thank you!

Share this post


Link to post
Share on other sites


Guest
This topic is now closed to further replies.

  • Similar Topics

    • By Ajmboy
      Tonight is the first presidential debate and it should be a record breaker for viewing. Might as well have a mini poll here on QUADCRAZY to see how they stack up. Make your choice in the poll and feel free to comment in this topic. I'm going to pin this topic and keep it going through the elections in November. 
    • By Ben Lennon
      Hi guys new to this forum and thought I’d jump on as I’ve just bought my first quad a Kawasaki bayou klf300c 89 model. It had starting issues when I bought it so I’ve gone thru and replaced the cdi, voltage regulator and starter solenoid aswell as rebuilt the starter motor after all this it was still free spinning on electric start so I pulled the stator cover off to find the fly wheel wasn’t spinning so replaced the one way clutch bearing put it all back together and still not engaging at all. I’m at a loss and looking for some ideas on we’re to look next to solve the problem
      cheers Ben 👍
    • By Dana Hudson
      Hey everyone, hoping to get some help here... my kids 03 KTF 50 Quad has always ran great... they were riding it a couple of hours a few days ago and it died a couple of times (not normal) but started right back up. A few days later my 5 year old wanted to take it for a spin so I started it (2 pulls) and he took off.. he made it a couple hundred yards and it died and we havnt been able to start it since. I have new gas, good spark and 120 psi compression.. it will not start with starter fluid in the intake or even in the cylinder.. the fuel bowl has fuel at the carb... what am I missing? It’s driving me crazy!!
    • By BuckBilly
      Good morning to all !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
      Let's see if we can make this a daily event.
    • By bradleyheathhays
      So I got this '96 Jeep Cherokee XJ that cranks but doesn't start.  It's got around 180k on her but I keep everything in good shape.  Batt seemed strong.

      I used to drive it everyday but this past year I've driven it only about twice a week.  It's been just slightly slower to start in the last couple of months, but just barely slower.  Was guessing it had something to do with aging plugs or something.

      Drove it yesterday and everything was normal like always, sat overnight and today it cranked but didn't catch.

      Any ideas on where to start?
  • Similar Tagged Content

    • By Reedygillespie
      Good after noon everyone, new here and really sure how to post anythang or get back to the topic I was lookn for so maybe u quad fans can help me out. I've got a 300 king quad that I really need info on. It's drivin me nuts . It starts and idles great but when I give it gas it spits and sputters. Anyone that could help me get lined out on this forum and my old quad u be a blessing .
    • By OutlawGade
      Hey guys. Starting a Grizzly Tracker Video Thread.
      [ame]
      [/ame]
    • By OutlawGade
      Starting a thread to keep our Videos in one spot. Thanks for watching and I hope you enjoy.
      If you like you can join the Group at www.facebook.com/groups/NOSatvs
      [ame]
      [/ame][ame]
      [/ame][ame]
      [/ame]
    • By Tamio
      Hi, me and my friend were out and riding the other day and filmed some so I tried to do an edit from the videos that I got. So this is my first ATV edit and I need you guys to tell me what I can improve in my filming and editing. Please give rewarding comments!
      [ame]
      [/ame] Thanks!
    • By ddiggerr
      1983 Yamaha YT175
      Fired up for the first time after total rebuild. Now I have no idea whats going on. Compression is 120, new plug, new fuel and oil lines, new choke and fresh fuel. Carb cleaned and reeds are good (no gaps).
      Will not start without choke and stalls out when choke is off. Played with choke adjustment and doesn't change.
      It fires up first pull and only idles if I play with idle screw. As soon as I touch throttle, it goes bezerk on me and I have to shut it down as you can see in video .......

      You can here the recoil lever tinging in the video. I lost the spring. D"oh!!
      So far I have swapped ignition coil, spark plug, CDI with no change. I have removed flywheel to check keyway and it is where it should be.
      Checked resistance on stator ... I get 10ohms +/- 10% on pickup coil within specs as per manual and I get 273ohms on charge coil. Manual states 300ohms +/- 10%, so that is also within spec.
      I have also swapped out jet needle and played around with different settings. Eventually I put it back to the 3rd line.
      The engine already has new seals and bearing so I am completely baffled as to what I am missing here.
      Any takers?
      Any and all suggestions will be appreciated.
      Thanks
      I have also swapped carbs from a running YT175. Same results.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...