Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

youngbucklakela

2007 Suzuki 450AXI Kingquad - Locked Up

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Fred Colby
      TPS on  Polaris  SPORTSMAN  500 efi 2007 shows as bad original part number is 3140173 bought the replacement part it came in as 3131705 the diameter of the ring on the face is 26 mm the original is 18 mm any thoughts on how this "factory" replacement parts fits as i cannot get it to go in?
    • Guest
      By Guest
      It seems like a gas problem but I've changec, fuel injector, gas cap. I have lots of fuel pressure but after four wheeler has run for 20-30 min I have no power and sometimes stalls and won't start. Any ideas?
    • By Admin
      View File 2007 Arctic Cat 700 EFI 4x4 Wiring Diagram
      2007 Arctic Cat 700 EFI 4x4 Wiring Diagram
      Submitter Admin Submitted 06/29/2019 Category Arctic Cat ATV  
    • By Locke DoBay
      Hello I'm new here and not sure on where this should be posted but here goes. I have a 2007 Kawasaki 360 4x4, it started to make a small knocking sound and few weeks ago. I checked all the normal things and didn't find anything. I just used it around the house as my yard machine, no real heavy loads or stress on it. And it ran fine with no problems. Well one day I went to roll my yard with my roller that i filled with sand. It put the 4wheeler under a load for the first time, well it ran fine for about 20 mins then i stopped to do something and it started but there was nothing there. It would not rev up enough to engage the belt drive and the knock got a lot louder. Sounds like the knock is coming from the top end. And ideas in where to start. I have worked on some stuff and mechanically inclined just never tore into an engine before.
    • By 87tecate4
      View File 2007-2009 Suzuki KingQuad LT-A450X Service Manual
      Suzuki KingQuad LT-A450X 2007-2009 Service Manual
      Submitter 87tecate4 Submitted 07/14/2018 Category Suzuki ATV  
  • Similar Tagged Content

    • By mikeexplorer
      Wiring diagram for 2007 Arctic Cat 700 EFI 4x4
       
       
    • By greatwhite
      I looked through many of the threads and could find it was wondering if anyone could post a link to a PDF Service Manual 2008 Kodiak 450.
      I found one for 2005 but I am sure there are differences.
      Thanks all
    • By Srx_Man
      Hey I own stock why Yfz 450 and I'm just looking to slap a turbocharger on it.. I was just wondering if they're pretty compatible with these machines it is the carburetored version Yfz 450. I have all the piping hook ups / kit that's threw HURON SPEED an i also have turbo lined up for it gt 12.. I was just wondering what else I need to make this work? I know i would need to up the Jets and stuff for starter but Is it just that simple or do I need blow off valves and like some time on regulator on it or so forth? Trying get ideal what i would need
    • By Jesper
      Hi guys
      Does anyone have a link to a service manual for the 2008 KingQuad fs 400 4x4.
      I would be very happy to get my hands on a file
      Thanks. :-)
    • By deadrider
      I have a kq 450 4x4 that I an have a problem with.the bike does not want to move.i am not very familiar with the sheave or clutch that it has on it.my buddy who owned it beat on it prolly never maintained it just so that's out there. The belt is fairly new primary and secondary clutchs are pretty ruff looking the rollers are toast I think but idk. Everything moves fine except for the primary it moves but does not push in to move the belt only at a high rpm will it move sometimes any clue on what it could be other then going out to spend 6 or 7 hundred on a whole new assembly of the clutchs
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...