Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Chopermech

Prairie / Brute SRA front strut mods

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By YamahaBB350
      I have a Yamaha Big Bear 350 and the reverse doesn’t work, it shifts from low to high easily but it won’t go back to reverse. I’m new to this stuff, so I’ll take any help. Any ideas? 
    • By Scott Sirr
      I need to figure out how to clean/fix or replace my neutral switch assembly On my 2008 Yamaha big bear 400 as generally the neutral light doesn’t come on when it is in neutral. To get it to come on I have to wiggle the foot shifter and hold it in just the right spot.
      I have googled it and can’t find much on the 400’s. I can’t find a service manual online and the parts manual is super vague.
      I think it is in the right side engine cover area, but not certain. 
       Any help would be great. thanks
      Scott
    • By David Miller
      Does anyone know how to access the check engine codes on a 2018 450 sportsman. Just changed battery and spark plug . It runs fine but the light is on and I need this to plow snow and need it reliable. Any ideas . Thanks
    • By Sturgeon
      Hello everyone, did a search and not successful. Purchased new 2017 Sportsman 570 sp and my power steering is not working. Seems to have a mind of it's own. Works then it doesn't. Dealer says there's not a fix. Thought it was just me and it being a brand new machine with 4 hours on it. Dealership said it's this model only ? Not sure what a person in this spot is suppose to do and wondering are your thoughts mite be. Thanks 
    • By David Terzian
      Hi, Name is Dave, I am new to the site. I have UTV 2018 Textron Stampede... cant get the 4 wheel drive to work.
      I recently had blown out the fuse for the acc... while hooking up my turn signals,,, and ever since then
      4 wheel drive doesn't work, I can lock in the rear,,, while having the key on motor off,, I can hear the clicking
      sound,, which sounds like a relay in the rear... but when I switch to 4 wheel drive, I hear nothing. shows up on
      the dash that its working, anyone can help would be greatly appreciated. All Fuses and relays under hood are
      good, and under rear seat. Thanks  Dave 
  • Similar Tagged Content

    • By pizzaman_288
      How hard is it to change the outer seals on the rear differential mine are leaking fluid and I have no idea on how to change them out any help would be great thanks
    • By Percherongal
      Turn on key, put it in Neutral, lights on steering column light up. NO head lights and the electric start switch will not work. Let is sit for a few hours, started right up. Sat over night and same issue. Checked fuses and they were good. Battery is giving 12 volts. Opened up the ignition assembly and it isnt getting any power it comes up as a .01 on the volt meter. Pulled the spark plug to check for spark and NO spark. Will not pull start either. Unhooked the battery checked the spark while trying to pull start it and got a weak spark.
      Pushed it into the garage and it sat for 2 days. Turned the key and pushed the start button and it cranked but the spark plug wire was off so plugged the spark plug back in and pushed the start button and nothing. If you jump the solenoid it will crank over but not start. Soo confused , anyone have any ideas?
    • By a65val
      Hi all...new member here...looks like an awesome site! I searched around, but couldn't find a service manual for an 02 Prairie 650. If someone has one we could download, we"d really appreciate it! We"re needing to replace the front cylinder and head, etc. for this new machine we just bought.
      All responses appreciated. Thanks much!
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...