Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

mendou84

700 RAPTOR vs 450 LTR

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By DUBLT
      Looking to purchase a windshield for my ATV, suggestions of what to buy with quality in mind and will fit without doing any modifications. 
    • By StolenATV
      Blue and White Raptor 90
      White, Black and Yellow Raptor 90
      Blue and White WR450F Motorcycle
      VIN’s for ATVs
      RF3AB11Y2HT006593
      RF3AB11Y5HT006815
      Stolen from the yard at my home at night on 10/26/19.
      $2,000 reward for information leading to their return.
      The post Two (2) Stolen Yamaha Raptor 90 ATVs and a Yamaha WR450F Motorcycle appeared first on STOLEN 911.
      View the full article
    • By Ted Aregi
      I've got a king quad 750cc has anyone converted the fuel pump relay to a stronger fuel pump relay on there king quad?
    • By josephnbl91
      My four wheeler when i first got it seemed like it was very slow when i first got it and it had no throttle response so i replaced the belt and cleaned all of the rollers thinking that would solve the problem from what i read on the forums. well it turned out that it wasnt. so i went to the next thing i took out the injector to check it out and i seen that there was a tiny bit of debree in it so i cleaned it and it seemed to improve a little bit. but still did not solve the problem. i later found out how to find the trouble codes out from the lcd screen using a paper clip on the diagnostic port and it showed the code which stood for no codes C00. i also forgot to mention that the throttle position censor is working perfect. before i started all of this the four wheeler ran just not to its potential. after my friend and i did the trouble code test the bike wouldnt even start anymore and the injector would spray for a few seconds for the start up then it stops and the fuel injection light comes on and blinks. the four wheeler wouldnt start anymore. i took it over to the local shop and they hooked it up to the computer to see if there was any codes and it still showed it was free of codes. they hooked it up to the fuel pressure gauge and we found that it was making 22 pounds and it should be making around 43. i then bought a new fuel pump and put it in. it now starts and runs for a few seconds and then it stalls out and the fuel injection light comes on again. which then leads me to think it is the ecu now but i want to be sure before i invest around $500 more into it. any opinions on whether or not anyone thinks this is the problem or if they have had a similar problem before would be really appreciated. sorry for writing a novel and not spelling very well. also i forgot to put the year in the title it is a 2007
    • By My kiwi shed
      Hi there everyone. Just seeing if there is advice on a problem I have before I start digging too deep. 
      I recently bought this creally nice 2004 King quad ltf300 with only 2400km..
      Everything things works great except when engaged into 4wd or diff lock it has a clicking noise ( sounds like broken teeth etc) are the front diffs known to blow?  Or the transfer from engine?
      I am yet to test on some loose ground to see if I'm getting drive at front .
      I will be driving in to find problem in next few weeks but thought I'd see if anyone might know what it is first. Cheers


  • Similar Tagged Content

    • By Kristpj
      I know this tooic has been addressed by many, I’ve looked through many forums and pages. I did not find anything like the problem i have.
      I have a 2007 Kingquad 450. I have a new fully charged battery. When i turn the key, the dash flashes and seems to struggle before getting fully lite. We can hear a small relay near the computer clicking, i think it is the fuel pump relay. When i turn off the engine kill switch and press the starting button relays click and all the power shuts off, i turn the key off, engine kill switch then start over, power is there. Atv will start with pull start, but not elextricly. if i try to use my winch, all power cuts and engine dies. 
       
      Can anyone tell me what it may be? or has anyone fsced an issue like this before?
    • By chuckufarlie
      I have a 2018 Kodiak 450 EPS that just this past Sunday I ran through a bit of water.
      After the puddle the belt was slipping, so I pulled over and drained the ultramatic housing and the slipping problem went away. This was all in L and everything seemed to work fine. Later when I got on a road, I put it in H, but it still rode like it was in low... i.e. I had to rev it up a lot just to get to 30mph.
      When at home I pulled the ultramatic cover off to inspect, and it looked okay in there. Not much dirt, belt and everything are clean, but when I rev up the engine (with cage in place, of course), the belt doesn't get to the top of the clutch (maxes out about an inch or 1.5" from top of clutch, so maybe it is normal).. I put it back together but same thing... H seems like L still.
      Do you think the clutch needs to be further dissected for cleaning, or could this be an issue with the gear selector?
       
    • By Steven Alter
      I have a 2018 450 and the digital gause has started flashing on an off while driving. The backlit also goes on and off. It is worse when I hit the gas. The battery died a few weeks ago and I jumped it but its been fine until last night. Called the dealer and showed them a vid and they recommend replacing the gauge and its like 600 bucks. The machine has less than 100 hours on it. I would really hate to have to change it out. also the unit sometimes has trouble starting. Any ideas?
    • By Admin
      View File 2014 Arctic Cat 450 ATV Service Manual
      2014 Arctic Cat 450 ATV Service Manual
      Submitter Admin Submitted 02/08/2019 Category Arctic Cat ATV  
    • By Admin
      2014 Arctic Cat 450 ATV Service Manual
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...