Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

NZATV

LTF500F Vinson Clutch install

Recommended Posts

Good evening from New Zealand

I own a 2003 LTF500F and am trying to install a new clutch kit but the are two large nuts in my way and I can not get them off. The manual says to unlock them but I cannot see any form of locking mechanism.

Can anyone help?

Cheers

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By JacobSlabach
      got 7 atvs off CL recently for a good price.  one of which is a yamaha warrior.  anyone know where the vin is printed on this bike?  Haha good place to start as I do not know year or size yet.  The former owner says needs exhaust ans and clutch work.  he said it ran fine until the clutch cable broke and then I couldn't get the new cable adjusted right and it would grind gears.  things I see:  clutch cable locked up again, no brakes, carb leaking (green with algae around the bowl and has gelled gas stalagtights on it), aftermarket exhaust melted the airbox so I need something different and a new air box.  I would like the use the current exhaust if I can but I have a feeling its a redneck fix as it looks like there is an ace bandage holding it to the exhaust pipe (its an aftermarket slip-on exhaust), so I'm not sure about that- lets get the bike running first.  also, battery (looks brand new, what a shame) is dead, 0 volts.  Otherwise, bike looks to have not been wrecked, and plastics are ok (it sat outside under a 'tarp' for 3+ years since it was run last).  any tips and advise on where to start first would be awesome as this is my first clutched bike (manual).
      the clutch is my main concern- I've never rode a clutched bike so I dont even know what its supposed to feel like.  lol I'm spoiled on my automatic polaris 
    • By Ssg
      Hello! This is my first bike with a cvt it's a 19 Outlander 850 xmr. I use the 30" cryptid tires that come with the bike during hunting season since I hunt in a louisiana swamp and I have some 27" interco reptiles during the summer trail rides. So this past hunting season I got stuck and squealed the belt do i looking at cluch kits /adjustments to help with the low end but I dont want to mess with my summer riding so I'm looking for advice 
    • By WILYUMS
      Took a little ride around the farm today. It was good to get away from the TV, Politicians, and all around bad news. Only an hour or two, but helped recharge me. This is in Western KY on our farm. About 85 degrees today here. I will still get you guys a run down in the newer ohv and atv parks here in this end of the state. But not today I'm thinking of heading back out for a night ride later.








    • By Gilbey
      Just got 2018 Suzuki King 400 ASI, getting ready to install winch on it. Noticed the wire loom up front on top of frame to pass wires through but not quite sure where the loom comes out at. I am assuming by the battery but it is not visible........would you guys just wire direct to battery as I had on previous quad or is there a better spot to wire to? I had noticed a wire junction on top of driver rear wheel with nothing connected to it and was curious if my leads could bee run to that? May have to go to dealer to see if a mechanic there can give me some insight to this process. Thoughts and ideas greatly appreciated.
  • Similar Tagged Content

    • By Ssg
      Hello! This is my first bike with a cvt it's a 19 Outlander 850 xmr. I use the 30" cryptid tires that come with the bike during hunting season since I hunt in a louisiana swamp and I have some 27" interco reptiles during the summer trail rides. So this past hunting season I got stuck and squealed the belt do i looking at cluch kits /adjustments to help with the low end but I dont want to mess with my summer riding so I'm looking for advice 
    • By Bruce Sawyer
      1987 YFM350FWTB 350 4x4 Big Bear when going uphill will sometimes act like the clutch realeases then re-engauge all at once.
      Seems to maybe be little more often if the engine is at about 1/2 throttle instead of at lower rpms.
      I have the Factory Service manual and checked the external clutch adjustment screw as ok and the H/L/reverse shifter lever linkage as adjusted correctly. It appears to be maybe a internal (inside the case) clutch issue or ??
      This is the type Big Bear that has the manual shift lever on the left front fender and has the manual foot shifter lever with 5 speeds forward.
      Can someone tell me how the primary and secondary clutch operates? 
      I assume one is mechanical and one is centrifugal. (what I'm asking is one clutch for the higher rpms and one for the lower rpms or ???. (the clutch appears to only momentarily release at the higher rpms is why I ask. The cycle has about 3000 miles of low speed through the brush hunting and has been well maintained, oil changed, etc and no deep water or mud useage.
      Anyone been into a similar issue with the big Bear ATV????
    • By mrfartsalot
      i have a 2001 suzuki quadmaster 500 4x4 that the primary cvt clutch is rusted on any ideas on how to get it off i want to try to reuse it if possible.
    • By Tyler Autry
      Recently started shifting hard from neutral to first causing it to stall. I'm able to lift up on the shifter and throttle up and slowly let off the shifter, like driving a standard. That is the only way to get it In gear and stay running. Also if I come to a stop and keep it in gear it wants to continue moving, eventually stalling out. I don't have much experience with the bottom end or clutches. I just now replaced friction and steel plates and that made no difference. Don't know what to do now.
    • By Ulf Löfstedt
      I just bought a Yamaha Big Bear 350 from 1992. The previous owner has run it on regular engine oil and I have problems with the clutch slipping. I think that's the reason.
      So what should I do?
      - Just change oil and it will be OK?
      - Clean engine/clutch + new oil?
      - Or do I need a new clutch?

      It is guessing the centrifugal clutch that slips. It has two clutches , it also has a "regular" clutch .
      Anyone who has any experience of using wrong type of oil?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...