Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

rockwell16

2001 Polaris Scrambler 500 2x4 - Upgrades

Recommended Posts

Ok I've finally done me research and got my products on amazon for my polaris scrambler 500 2x4 it is a fast bike to begin with but i wanted to improve throttle response and ad a little bit more power to the bike also bought other stuff for riding like stuff to improve the quad not just parts accessories to so I bought...

FMF POWER CORE 4 MUFFLER-$205

ACERBIS HANDGUARDS-$34

EXHAUST WRAP-$25-$35

K&N AIR FILTER-$33

K&N AIR FILTER SCREEN-$12.50-$13

SANDPAPER TAPE FOR EXTRA GRIP ON FLOOR PLATE-$13.04

LED LIGHT BAR 7 INCH -$30 PLUS METAL FOR MOUNTING SO ABOUT $40

TOTAL UPGRADE COST=$357.04 after clutch kit -$190 = 547.04

This will add better throttle response and ad more power and with the k&n a little better fuel economy I got the handguards for protection from cactus trees tree branches flying rocks mud and cold air you know the everyday riding awareness's / watch outs (EVERYONES WITH A POLARIS SCRAMBLER THIS IS THE STUFF TO ADD OH AND ADD A CLUTCH KIT WELL WORTH IT

Share this post


Link to post
Share on other sites


ya its an EPI is a clutch kit hard to install i saw a vid and the guy said if you want to take the clutch or remove it from the bike you need a specialty tool but when he was doing he said you need like a clamp to compress the spring and stuff is it worth doing it yourself DUI or having a shop do it -SFI-shop fix it.

Share this post


Link to post
Share on other sites


if you think you are confident doing it yourself, do it. good experience and you keep your money in your pocket ... lots of people here that can help you out if you get into difficult situations ...

Share this post


Link to post
Share on other sites

ya i am very experiences with fixing just about anything with a motor from the 70's and up cars trucks atv's but i don't know just clutch you have all the springs and stuff ill problem do it my self anyway but i have done them before just not on something with this big of a clutch and a centrifugal force clutch but it looks easy by the video i will comment if i have any further questions are you just one person you answer all my questions every time

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Zad
      1994 Polaris 300 2x4 project won’t start. Seems like we have spark and have tried straight starting fluid in cylinder and still not getting a fire.   Kind of has me stymied 
    • By donerightautomotive84
      Ok so 2000 sportsman new.caltric carb new fuel pump new jug and piston new cdi and coil finally get to start it and itll idep for 5 to 10 seconds and die what am i missing people any help id love ya forever lol
      Sent from my LM-Q720 using Tapatalk
    • By mkibbe
      My 2014 750 king quad stalls sometimes when I touch or turn the handlebars,the problem has gotten worse,my machine has 475 miles and is only trail ridden,I have a new factory battery and i have 14.2 volts when the quad is running and 13.3 on the battery when not running,also using a multimeter there is no change in volts when turning the bars until it does stall,If I pull the 40 amp power steering fuse it will not stall.......I've been told its the ECU,Hate to buy one if thats not the problem,but its kinda leaning towards that,,,,,need some opinions.

    • By Halley
      Could anyone take a look at the picture and let me know if I’m needing to replace the actual throttle cable or the throttle handle ? Its for a can am 2018 outlander XMR 1000. It’s in limp home mode and throwing code P1619


    • By JacobSlabach
      Hey just picked up another scrambler 850 was told the tps was bad.  This atv has been beet to hell.  Wiring has been tinkered with the crankcase has been replaced recently and the motor rebuilt (can see horizontal scores thru spark plug hole where it’s just been honed out and rebuilt)
      my guess is it was ragged out till the motor blew a rod and rebuilt but the clown that did it couldn’t get it to run again and sold it.  When I bought it it would pulse and smoke black at idle and die with throttle.
      New tps installed and it won’t run period.  I went to celebrate it and I’m getting 5 volts on 2 of the 3 wires running to the tps.  Is this normal and if so how should I celebrate it?



  • Similar Tagged Content

    • By Quad Bug
      I most have a rare ATV, because I can not find a service manual without paying money to Kawasaki.  It's a 2005 Prairie 360 2x4.   4x4 manuals are all over the place, but nothing for a 2x4 .  Heck, Bike Bandit doesn't even list parts for a 2x4.   Any suggestions besides paying Kawa.  My machine is in limp mode and I've yet to find an applicable video or even procedure. 
    • By gregj49
      Blows out black smoke when you rev it up how do you adjust the carb?
    • By Beb1041
      Looking for a download of a manual
    • By warkcol
      I am having an issue where it sounds like the gears are slipping if I hit the throttle really hard and also after letting off when the engine brake is applied. Also, the drive train that goes to the front also rides again the gear shift box. I will attach pictures and a video here shortly.
      Thanks in advance!
      [ame]
      [/ame]https://postimg.org/image/cdlu6fza9/
    • By Weldingrod47
      Trying to change front wheel bearings. I removed the cotter pin and castle nut. Hub won't budge. Is there an additional retaining clip? Seems to be one of those push on type that barbs on the thread of the spindle. How do I remove it?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...