Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

I just got an 2006 Suzuki ltz 400. New to sports bikes I just found the oil tank. I noticed that the oil level was at the bottom hash mark of the dipstick. I wanted to make sure that the oil fill level should be at the top of the hash mark. Please correct me if I am wrong. I didn't get a manual with the quad so Im not sure of the correct oil levels or the amount of oil after an oil change.

Share this post


Link to post
Share on other sites


i think you are ok with the bottom hash mark, not alot will go in to top it up i dont think.

this manual should be good for your bike, 2003 thru 2008 ...

just click "to download" and a new page will let you get this manual

https://rapidshare.com/desktop/download/997p1/158558615/MjAwMyBTdXp1a2kgTFRaIDQwMCBTZXJ2aWNlIE1hbnVhbC5yYXI=/49490/0/0/1:25600/6635861DDCD2883DDC15023D93D8D4A8/referer-356939A27F9465EEABDD63953D1B02CC

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By Mike Johnson
      Hello again guys ,. I have a Quadmaster that has a very bad lean to my passenger side wheel. I replaced the a arm bushings with no change in the lean,  I see no bent parts and no adjustments available. It's always been there since I got it but became really noticeable when I put the lift kit on it. I'm going to add a picture of the problem if allowed.

    • By jake Stillman
      Hello I am new to this forum and lt80s I have an 87 that has burned up 3 coil/cdi combos my question is can I out the newer set up on it and if so how do I do it I know they have different number of wires going to the cdi mine only has 2 please help
    • By Nick Brooks
      Working on a 2002 Quest 500 and the grommets in the tank are rock hard and leak.  Any tips on replacing without having to pull the tank, hands are too big to get to the bottom gromment which is the worst one.
    • By Quadrunner44
      I have an older 1980s Suzuki quadrunner red lt 4wd (250)
      so just finished putting it all back together and was running fine just needed to adjust the rebuilt carb
      bf decides to hook up an air chuck to the gas tank because it got a shot of air in the gas line well 120psi didn’t agree with any of the parts including the new carb 
      end result : new battery new carb now it just clicks (one single click) won’t turn over 
      hard to pull start gets hung up (unless I remove the spark plug ) gas flooded out the first time but now does nothing purchases a new starter waiting the arrival 
      could there be damage to the crank shaft or pistons etc? Or install the new starter and try to fire it up ? What caused the starter to die after he flooded everything with gas was working fine. 
      Thank you 
  • Similar Tagged Content

    • By Jers
      I need to know what I have and what tire really go on it, Mine has 24x11x10 on the back and 22x8x10 on the front and I need new tire but I don't think are the right size. Also I can't find the model number listed but it looks like a 250 quadrunner 2wd and I think it is a 1987 maybe, can anyone help me, also I it has a rich running sound and I put a carb diap in it and cleaned the carb. is there a jet needing replaced?
    • By pickytar
      I have a Chinese Hybird 250 or that's what I was told it was. I found 17 numbers on the frame. Will these numbers tell me exactly what it is that I have? (I know that its a 2006 from a plate on the front)
    • By patricknperkins
      Ok, so got this thing, assembled, and even added acid/assembled the battery with a solid trickle charge and the battery is fine.
      As far as I can tell, I have checked all the fuses I can find, but I have ZERO power to anything. Even the console will not light up when turned to ON.
      Is there some sort of hidden parental/child disconnect or safety switch that I'm not aware of? ANY help would be appreciated.
    • By Steve1266
      I went out to ride my quad today. When I started it up it ran for a minute, then died. Since then it will turn over but won't start. I've check the spark plug and get great fire. I have had this quad for about 6 months, and very new to breaking it down. But need help. Thanks
    • By upper_tanker
      Hey all, new guy here. I am wondering if anyone has one of these machines, that can possibly take a picture/tell me where the hoes goes from the timing chain cover. I took this machine apart in the fall of 2014, planning to rebuild the top end, and didn't get around to doing it until about a month ago. motor is back together, and I'm just curious as to where this hose goes. One end has a plastic ribbed fitting in it.
      Also, the rear upper nipple on the carburetor.....what goes there? is that just a breather also or?
      I have the rubber piece that slides into the rear of the gas tank with 3 hoses: 2 go to the rear, and 1 is just a clear piece of hose that isn't connected anywhere.
      I have another one of these machines, but it is 5 hours away.
      I guess that's what I get for waiting a year and a half to put it back together lol.
      Thanks
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...