Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

grapeape

1998 Yamaha Kodiak 400 - Engine Swap

Recommended Posts

Hi I have a 1998 Kodiak 400 that locked up the bottom end. 2 actually....

I am looking for used engines or parts and I have run into some questions. The local shop isn't so helpful.

What years are the same? I have a 2002 400cc motor in a box already.

Could a 350cc from the same year bolt in there? I have a wrecked one in hiding out back.

I work on a ranch we have several of these monsters. All have a shton of miles on them. These things are easy to work on and work with. We plow with them. Maintain power lines and fences from them. Any info would be really helpful..

Thanks

Share this post


Link to post
Share on other sites


the 350s and 400s are the same block, the 400 has a longer stroke. i would assume yamaha didnt change the motor mounts, but dont quote me ... looking on the parts list, a kodiak in the year 1996 to 1998 uses the same frame, the 350s used a different frame ... i would say take some measurements and cross your fingers. the connectors will probably be different from different years/bikes too ... im sure you will run into a few mods you have to do along the way ...

Share this post


Link to post
Share on other sites

I'd imagine that the cylinder head mount is a different size but the driveshafts should be in the right place and bolt up. Run the 350 carb and wiring/cdi.

Share this post


Link to post
Share on other sites

All wiring connections will be different iv got a 350 wolverine 97 and kodiak 400 98 i use for parts on my 02 bb400 if u need help with matching up parts i can help im trying to find out if the wolverine and bb/kodiak have the same clutch part# right now n cant find em anywhere

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Spartacus Stroppel
      View File 1999-2002 Kawasaki KVF300 Prairie Service Manual
      1999-2002 Kawasaki KVF300 Prairie Service & Repair Manual
      Submitter Spartacus Stroppel Submitted 08/25/2019 Category Kawasaki ATV  
    • By sprad22
      Hi I have a 2002 arctic cat 500 auto.starts and runs but will not go forward or reverse.the outer clutches/pulleys and belt spins but it will not move when put in gear.Any ideas as to what to to check for?clutckes,broken gear????
      thanks for any ideas..
    • By 06kfx440
      My retaining wall fell 20 feet up my driveway from the entrance. I called my insurance company and was told that there isn’t a lot they can do.
       
      So I called the town to see who built it and the old homeowner did 4 years ago! With no contractor! And the building department passed it for inspection.
       
      There is no geo grid, no drainage, and dirt as a backfill. I bet you I can pull the rest down by hand.
       
      My question is who is responsible? This is not right.
       
       
      Sent from my iPhone using Tapatalk
    • By Dimelol
      I have a 2003 Kodiak 450 that i purchased a while back with around 300 hours on it. It has never ran right from the beginning. Initially i thought it was just a carburetor issue because it was all clogged up from sitting for months. It has been cleaned, rebuilt, and taken off probably about 10 times troubleshooting this problem. I have quadruple checked everything including float height ect and it is set correctly, the jets are also brand new, needle and seat have been pressure tested as well. So after all of that I am convinced that the carburetor is not the culprit. I have an issue where the idle is very choppy, almost as if it is misfiring with a rich condition on top of that. I can use a brand new plug and run the machine for just a few minutes and it will be a dry and and coated in black carbon build up. The exhaust also has a strong smell at idle. I had trouble restarting it when hot for a while, but i adjusted the valves and it seemed to solve that issue. They were both way out of tolerance (tight). The weird thing is, outside of idle it seems to run pretty well. 
      So with all that being said I have ruled out the carb/valves/compression and moved on to the ignition and this is where i have a few questions about factory specifications. I guess the main question I have is, how strict are these tolerances? And could them being off by this amount cause the issue I am having? Do all three of these parts really need to be replaced? I would like to know before I spend the money on these new parts, and it not fix my problem. Below I will list what the specs were in the service manual along with the reading i got.  This is my first experience testing ignition components. I just found it odd that all 3 are out of spec according to the service manual.
      Spark plug cap resistance: 10 kΩ at 20 °C (68 °F)
      My Reading: 8.90 kΩ
      Primary coil resistance: 0.18 ~ 0.28 Ω at 20 °C (68 °F)
      My Reading: Fluctuated between 0.4 - 0.5 Ω
      Secondary coil resistance: 6.32 ~ 9.48 kΩ at 20 °C (68 °F)
      Reading was within the specified range.
      Pickup coil resistance: 459 ~ 561 Ω at 20 °C (68 °F)
      Reading was within specified range.
      Rotor rotation direction sensing coil resistance: 0.085 ~ 0.105 Ω at 20 °C (68 °F) 
      My reading was 0.3 Ω
    • By RCNY1
      Seems impossible to find a pair of front shocks for my 02 Yamaha Kodiak,newer or older listings are they the same as a big bear ?  Factory are $245 each !!! Any help appreciated 
  • Similar Tagged Content

    • By Wali
      I was riding my 400ex one day and when i shut it off to put it in the garage i tried to start it put again to drive it into the garge and it wouldnt start.I put a compression tester on it and its like 30 psi with out throttle and 0 psi WITH THROTTLE.
      when i put my finger over the hole it fell likes its pulling my finger in more then its pushing it out 
       
      Has good spark.When i took it into the shop the said it had 1oz of oil in it and a tiny pit of metal shaving(TINY BIT LIKE 30 flakes)
      When i try to pull start (push start/roll start) it made a not normal sound  and wouldnt stay running.
      If my bottom end is blow why would it still turn over fine,
      Are my valves siezed or not working properly 
      or is my timing off causeing valves to not open in correct order with fire 
      PLEASE HELP all help is appreciated 
    • By Hunter Aldridge
      Some times I get spark some times not can ride then it just dies and wont get spark it has new cdi box and stator but I don't know if it has the pickup coil I'm at a loss
    • By William Sims
      I have a 400 4by4 ,2005 green model,
      wounding how many different CDI boxes will work on it
       
    • By jerry houston
      Eiger 400 Suzuki runs fine Cook-Out joke face off the handlebars put it back on and will not start now will crank no no spark
    • By colin james
      View File 2012-2014 Polaris Sportsman 400 HD Service Manual
      This the factory service manual for the 2012- 2014 sportsman 400 hd service manual 
      Submitter colin james Submitted 02/08/2019 Category Polaris ATV  
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...