Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

FastJimmy

1995 Suzuki King Quad Electrical Issue

Recommended Posts

Hey all and thanks for the welcome.

I bought a Suzuki King Quad 300 new in 1995 for use on the farm.

We used it several years without it hardly missing a beat. Then about twelve years or so ago it started acting like a loaded up two-stroke, blubbering and spitting.

At that time I had owned motorcycles for about thirty-six years. I had worked for pretty good sized dealer, raced bikes and later I had two bike shops so I had a little mechanical experience.

First thing I did was disassemble and clean the carb, which made no difference at all. After trying everything in my bag of tricks I broke down and took it to a “professional” who assured me that it was a worn needle and seat. I doubted that to be the case but approved the $125 or so “repairs”. It was of little consolation to me that the “professional” couldn’t figure it out either for his “repairs” made absolutely no difference whatsoever.

Reluctantly I carried it to another shop. As soon as I started it to unload it off the truck the mechanic said, “That’s an electrical problem.” Well this “professional” knew what he was talking about and after replacing an electrical part it ran great again for another five or six years before it started doing the same thing.

I discovered that if I turned on the light that it would smooth right out run normal.

By that time we had bought a Kawasaki 610 Mule and the Suzuki didn’t get used much. A few years ago the blubbering and spitting came back even with the lights on. I kept meaning to track down its electrical issue and fix it but other things took precedence. It has been a year or more I suppose since I even started it.

I tried to find the paperwork from the original repair to see what was replaced but couldn’t.

Although I can hold my own on mechanical issues I have never been very proficient at electrical issues (if they were very complex).

I have had the Clymer’s repair manual for any years and I’m sure there is an electrical trouble shooting section I just need to take time to check it out.

My thoughts are that it is the rectifier regulator but before I spring for $100 or so I need to do some checking.

I have a fencing project through the woods coming up and the Mule is just too big to go through some areas so I need to get the Quad back in service.

I have rebuilt the starter a couple of times over the years and will do that again and get a new battery for it.

I noticed that in another recent post a King Quad owner had a similar issue.

I welcome any thoughts.

Thanks again

FJ

Share this post


Link to post
Share on other sites


i have read on some suzuki forums that it is the regulator right down to turning the lights on ... and to have a fresh battery too. some suggested to clean the ignition switch also. i will look thru the service manual for troubleshooting and post it up if i find anything ...

Share this post


Link to post
Share on other sites

oxidized_black,

Thanks for seconding my assumption.

I actually dug out the Clymer's service manual and it does have a section on checking the voltage rectifier regulator.

One VOM check and another check if you have a special Suzuki tester.

It calls for a steady 5,000 RPM using a portable tach. I don't have one and at my age it's getting unwise to invest in more tools but I may have to spring for one. I have had need of one a few times in the last few years.

Thanks again

FJ

Share this post


Link to post
Share on other sites

I'm assuming that the starters and voltage rectifier regulators were common on all the 1995 Suzuki 250 / 300 (actually 280) models.

I contacted an ebay seller who had a starter rebuild kit listed for a 1995 King Quad 250.

When I inquired if he meant King Quad 300 he took offense, said his listing was 100% correct and doubted if I really knew what I had.

Perhaps scans of the 1995 Suzuki ATV brochure and my MSO will make him aware that Suzuki didn't know what they were selling either.

Anyway, I need to order a starter rebuild kit and possibly the voltage rectifier regulator and can't imagine that there is a difference on those two parts for the 250 / 300 models.

Thanks

FJ

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Orangejbird
      My Dad's 03 Manual Vinson has milky oil. He changed oil and ran it everyday for a week being sure to keep it running for an hour each time. Fresh oil is getting milky again..
      Thinking it's the water pump seal. Has anyone here successfully changed the seal or even replaced the whole pump assembly?
    • By Amboyjim
      Having serious problems with quad it completely stopped running on me took carb off and tore apart cleaned everything put back on and it started idled but when driving it had no power at all so took carb back off and noticed their was a puddle of gas and oil in the bottom of the air filter box and also their was gas in the vacuum line HELP
    • By JacobSlabach
      I have a gentleman that asked me to service his bayou for him.  I have always wondered what oil should be used in atv engines?  Pros?  Cons?  What weight should be used in what type of weather?  Is there one kind that I could bulk buy and safely used in any quad I worked on or owned?  What about performance?  Engine Life?  This has always been a 🤔🤔🤔 area for me with quads as far as why you would use one type of oil over another....
      Thanks!
    • By bren7176
      Doeas any have the actual electrical diagram for the distirbution block  for this atv > I had a few wire not worky worky so needed to replace ends plus dam thiing is dirty so needs to clean all the contacts ..
      Want to make shure I get eveything back in right place .... I have the repair manual but as we know it no help really .....
       
      Brendan
  • Similar Tagged Content

    • Guest Fox300exchic
      By Guest Fox300exchic
      The Hop-Up: You may be saying to yourself, “that’s a chick bike,” and you’re right. But honestly, it’s so much more than that. It’s one badass bike. http://www.quadmagazine.com/quad/features/article/0,24942,1587044,00.html
    • By Jers
      I need to know what I have and what tire really go on it, Mine has 24x11x10 on the back and 22x8x10 on the front and I need new tire but I don't think are the right size. Also I can't find the model number listed but it looks like a 250 quadrunner 2wd and I think it is a 1987 maybe, can anyone help me, also I it has a rich running sound and I put a carb diap in it and cleaned the carb. is there a jet needing replaced?
    • By crazynordlander
      Hi All,
      I live in Minnesota and bought a 2016 CFORCE 500 HO. I am in hope to see if there is anyone in the US that is experiencing this sudden drop off in RPM below 4000 RPM. I have uploaded some videos of my issue on YouTube. I will list three of the four I posted. The fourth can be found on my channel but it is a comparison between my Polaris 570 and my CFORCE 500.
      I quit on my first dealer because we just did not mix well together. I brought it to another CFMOTO dealer that just became a CFMOTO dealer in January 2016. They are in a large ranch and agriculture area in a neighboring state that is pretty close to where I live. They have close to every brand available. They are a much larger dealer than the first one I bought the unit from.
      I brought the unit three weeks ago to them and they have worked on it a good solid week and have given up on it. I have read reports from owners in Canada that the dealers there were aware of the issue and have had success in fixing the herky jerky drivability issue.
      I am picking it up tomorrow and bringing it back home. It has been to the trails of the Black Hills this year and was new in late April. 300 miles on it. It has never changed. Very hard to ride on the trails or when I herd livestock.
      Here are the links to my videos.



      I can't accept that this is normal operation. Does anyone from CFMOTO China scan these posts?
      I need help that CFMOTO USA has not provided.
      Thanks
      Kevin
    • By skgw1
      Feul pump went out. Replaced. At times quad cuts out like its not getting gas. Saw article on new pump needs to be calibrated. Told how to go into a service mode. Does not tell how to calibrate after going into mode. Can anyone shed light on this procedure.
    • By katasha2
      I took apart the carburator to clean out and I can't remember exactly where the springs that are inside the float are supposed to go I've tried to look up schematics but I think I am missing a spring maybe need helpt:confused::confused:
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...