Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

davidiz420

2006 Yamaha yzf450 - Fuel/Oil

Recommended Posts

this is completely bone stock 450 atv my ? is what kind of gas and oil should I use??? I know to use premium but should it be 110 or v-power???:biggrin:

Share this post


Link to post
Share on other sites


i know regular unleaded works, but higher octane keeps bike running better, any good brand oil is ok as long as it is atv oil ... yamaha will have you believe yamalube is the best for your bike, but like i said, any decent brand ATV oil 5-10W40-50 regular or synthetic, depending on conditions (extreme cold/hot)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Bleuu
      Hello so I’m new to the atv seen, and was wonder why my stock light didn’t turn on , and it figures that the black and white wire and the black wire were ripped apart everything else is connected fine, what could to reconnect them
    • By Shane Pillar
      Talk about what kind of atv you have and what you do with it.
    • By PissAnt
      How old were you when you got your first ATV and what kind was it?
    • By JD430
      Time to trade in my 2009 outlander 650 XT. I’ve always been BRP for sleds, and this 650 owes me nothing just ready to trade up. I feel compelled to stick with cam am, however, the Polaris 850 sp premium really caught my eye at the dealership. Looking for some real input from real people on opinions on the 2 options. The 650 outlander has been great to me, I use the quad for crop scouting on our farm mostly, the only thing about the 650 is it seemed like it runs a little on the hot side at the slow speeds. Wondering if anyone knows if the newer big v twins cool a little better now. What about the Polaris what are the thoughts there? I really like the looks of the Polaris, I think it’s a really sharp ride. Really the biggest thing is which is more dependable, since I use for work I don’t have time for it having glitchy issues. I also like to be impressed when I snap the throttle, of course... that’s the reason I want to go to an 850  thanks in advance! 
  • Similar Tagged Content

    • By Michael Aiken
      Where can I find a wiring diagram for my 2005 450 Kodiak. Thanks.
    • By Kristpj
      I know this tooic has been addressed by many, I’ve looked through many forums and pages. I did not find anything like the problem i have.
      I have a 2007 Kingquad 450. I have a new fully charged battery. When i turn the key, the dash flashes and seems to struggle before getting fully lite. We can hear a small relay near the computer clicking, i think it is the fuel pump relay. When i turn off the engine kill switch and press the starting button relays click and all the power shuts off, i turn the key off, engine kill switch then start over, power is there. Atv will start with pull start, but not elextricly. if i try to use my winch, all power cuts and engine dies. 
       
      Can anyone tell me what it may be? or has anyone fsced an issue like this before?
    • By chuckufarlie
      I have a 2018 Kodiak 450 EPS that just this past Sunday I ran through a bit of water.
      After the puddle the belt was slipping, so I pulled over and drained the ultramatic housing and the slipping problem went away. This was all in L and everything seemed to work fine. Later when I got on a road, I put it in H, but it still rode like it was in low... i.e. I had to rev it up a lot just to get to 30mph.
      When at home I pulled the ultramatic cover off to inspect, and it looked okay in there. Not much dirt, belt and everything are clean, but when I rev up the engine (with cage in place, of course), the belt doesn't get to the top of the clutch (maxes out about an inch or 1.5" from top of clutch, so maybe it is normal).. I put it back together but same thing... H seems like L still.
      Do you think the clutch needs to be further dissected for cleaning, or could this be an issue with the gear selector?
       
    • By Steven Alter
      I have a 2018 450 and the digital gause has started flashing on an off while driving. The backlit also goes on and off. It is worse when I hit the gas. The battery died a few weeks ago and I jumped it but its been fine until last night. Called the dealer and showed them a vid and they recommend replacing the gauge and its like 600 bucks. The machine has less than 100 hours on it. I would really hate to have to change it out. also the unit sometimes has trouble starting. Any ideas?
    • By Admin
      View File 2014 Arctic Cat 450 ATV Service Manual
      2014 Arctic Cat 450 ATV Service Manual
      Submitter Admin Submitted 02/08/2019 Category Arctic Cat ATV  
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...