Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

hammerhead1022

2007 Polaris Outlaw 525 rear wheels locked

Recommended Posts

I have a 2007 Polaris Outlaw 525 KTM. The rear wheels locked up while riding. I read where it could be a retention bolt or retainer plate. Could anyone tell me where they are located and how difficult it is to fix. Thanks

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Tim Orr
      Installed new battery was told that’s what was wrong when hit start button I hear 1 click then nothing?  Can the battery just not have enough amps to crank the starter the first time ? I trickle charged it overnight thought it was enough!
    • By Reece Bowen
      x   just bought this expedition 425 and the Speedo needle does not work. The lights work for the shift indcator. So is this an electronic Speedo or cable? Is there a way to fix it or will I have to replace the unit? Thanks for any help you can provide.
    • By Rich1028
      Well I will be Off the Trails for awhile...who will be riding ??
      I said awhile ago that we would be done for awhile,and we made it back out,but now I know we are off for at least two weekends,Wife is on Call.
      and I might send mine out for some due repairs,that I do not want to do because of the timing,and that I have not done them before.
      I need new brakes,front and rear!
      and A Chain and Gears.
      Deer Season is Nov.15th thru Nov.29th so no riding during that.
      And we need to clean the Garages to get the daily drivers out of the snow,and cold weather.
      So I hope that others step up and get in some riding while we are down.
       
    • By marcus23934
      I just bought a 99 sportsman 335. did some work to it got it running good my question is when I put a battery in it the atv starts and idles great once I give it gas it just spits and cuts out and will not ever clear up  thing is if I take the battery terminal off while its running it runs fine and no problem at all  could anyone help me out with what the deal is 
    • By Flipper Tiffany Roper Jones
      All I have been through everything. Bought brand new.
      Throttle safety switch 
      Cam and rockers
      ECM
      Carborator
      Stator
      Fuel safety switch 
      Battery
      Everything every forum has spoken of I've bought sealed airbox completely tight unplugged black wire on trans. I have literally done everything in the book.Checked oil today full of gas anyone no anything what might b wrong. Next I'm taking head off and making sure valves seat any ideas.
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...