Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Fox500

03 Predator 500 bucks

Recommended Posts

I have a 2003 Polaris predator. Been sitting for about 6-7 months. Put brand new gas in it, new plug, cleaned the carb. Starts up no problem. Idles well. As soon as I put it in first and release the clutch to ride it, it rides but kind of bucks a little. Like its not getting fuel. As I give it gas it like sputters and breaks up. If I stop put it in neutral it idles perfect. Any suggestions?? Thanks

Share this post


Link to post
Share on other sites


Sounds as if there is still some funk in the carb to me. Id give it a complete tear down, cleaned and put it back together unless that is what you did, only other thing I can think of is a very dirty air cleaner.

Share this post


Link to post
Share on other sites

I just cleaned it quickly. Seemed to help a lot. I will probably end up taking it apart this weekend. Someone else had told me the clutch plates could be sticking together from it sitting for a while? Which would be why it's bucking? Thanks Jon.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By HeWasRidinDirty
      I got this 400, that wouldn't start. It would try, but wouldn't catch. I checked the valves and the L intake was tight at .002. The compression came in around 120. It didn't improve after a couple of drops of oil into the cylinder. So,I figured it was the valve causing the problem. So, I got the valves squared away, but it still won't start. I checked the spark and it seems like it's getting an intermittent spark. It fires a few times then nothing. If l let up on the button and then hit again immediately, it will fire a few more times, then repeat. So, what am I looking at as a possibility? Electrical issues are not my strong point. LOL
    • By flyinbrian365
      View File 2020 Polaris Ranger XP 1000 61 HP Service Manual
      2020 Polaris Ranger XP 1000 61 HP Service Manual - Full service manual
      Submitter flyinbrian365 Submitted 09/19/2019 Category Polaris UTV  
    • By flyinbrian365
      View File 2018-19 Polaris Ranger XP 1000 Service Manual
      2018-19 Polaris Ranger XP 1000 Service Manual - Full service manual
      Submitter flyinbrian365 Submitted 09/19/2019 Category Polaris UTV  
    • By flyinbrian365
      View File 2018-19 Polaris Ranger 900-1000 XP Crew Service Manual
      2018-19 Polaris Ranger 900-1000 XP Crew Service Manual - Full service manual
      Submitter flyinbrian365 Submitted 09/19/2019 Category Polaris UTV  
    • By flyinbrian365
      View File 2018-19 Polaris Ranger 150 Service Manual
      2018-19 Polaris Ranger 150 Service Manual - Full service manual
      Submitter flyinbrian365 Submitted 09/19/2019 Category Polaris UTV  
  • Similar Tagged Content

    • By Alois Specht
      Hi there , have a KAZUMA 500 JAGUAR the rear diff is permanently locked , how can I get it out of lock just about tried everything I think, ?? .  Thank you your help is appreciated.
       
    • By mrfartsalot
      i have a 2001 suzuki quadmaster 500 4x4 that the primary cvt clutch is rusted on any ideas on how to get it off i want to try to reuse it if possible.
    • By Paul Maple
      I have a 1999 Sportsman  500, it was running fine, than started to lose power in the winter, I adjusted the idle screw and away I went, than a few weeks ago it died, I have found that i am flooding the engine, compression was at 70PSI and due to the compression release mech. i assume i am good as it compared to the same PSI on a 2000 sportsman 500 i have. i cannot start the atv unless i go full throttle and it starts an runs for about 30 sec than dies, again it is flooded. i ordered a new carb off ebay as i could get one for around $40. put that in same issue, i have checked the timing, (good), valves out of adjustment i adjusted to .006 still same issue, i have found the exhaust lobe and rocker arm to have some wear, i have ordered new ones, but am looking for any other input in this area as well. would the exhaust cam and rocker arm cause the engine to flood? i have used a bore scope and the piston liner has good cross hatching still? any input would be great.
    • By colin james
      View File 1996-2000 Polaris Sportsman 335/500 Service Manual
      This is the factory service manual for the polaris sportsman 335 & 500.
      You can download the section you need  or download all of the chapters for the complete manual 
      Submitter colin james Submitted 10/19/2018 Category Polaris ATV  
    • By colin james
      This is the factory service manual for the polaris sportsman 335 & 500.
      You can download the section you need  or download all of the chapters for the complete manual 
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...