Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

dblR

06 King Quad timing

Recommended Posts

Thanks for the bits and peices of info. Fired this 06 with 5-6k and Never serviced! Timing had jumped 6 teeth on the intake, due to no 0 psi oil pressure to keep the cam chain tensioner tight enough to prevent cam from spinning. Added oil stripped the front end and checked the timing notches repeatedly. Never lined up parallel 6 teeth off to realignment with exhaust valve cam. Reset to parallel bolted intake cam shaft with exhaust cam, installed spark plug wire and vawalla! It friggin runs, smokes bad but I would too after 5k miles and never check a service manual or oil or maintenance schedule. My problem now but She is mine and running! Hats off to the forum I got a skeeter beater here in Maine!

dblR

Have a great day in the woods!

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By MarkinAR
      Passing thought here and thought I'd pitch it to the group for debate.  I'm working through a Kodiak which is basically a Big Bear in a heavier bike and the same as about anything Japanese made for 30 years as far as clutch function and design goes.  This Kodiak is odd though in that the centrifugal clutch slipped a bit with good clutch material remaining and the main clutch pack seems to slip a bit as well at high RPM but also still has good clutch material left.  Much like the Kawa race bikes from what I've read.  Do you think it's an option to add a thin washer to the pressure bolts to put a bit more pressure on the main clutch and force it to use a bit more of the clutch material before having to replace?  There's seriously like 50% of fiber left on the main clutch pack and it seems silly to replace it all before it's truly worn down.
    • By Gilbey
      Does everyone run the tire pressure as stated on tires or perhaps a couple # below to soften the ride a little?
    • By Tahj
      Do I need to remove the balancer driven gear to remove the timing chain.
      If so, how?
      Thanks

    • By Tahj
      I am looking to see why my 2005 Grizzly  660 won't crank. I have set the valves but suspect a loose timing chain.
      When working to remove the valve cover I found a "cap tensioner case" - parts #25  - #299 on Babbitts site.
      The  cover seems to bridge the valve cover and the cylinder head. What the hell is it and what surprises will I  find if I remove it?
      Uncharted territory for me.
    • By David Land
      About 6 months ago I had a new fuel pump, ECM, stator and heaven only knows what else installed on my 05 King Quad.  It has been running great until the other day when I went to get it off the trailer, and it would not start.  Pulled the plug, and it was a little dirty, but not bad, but I put a new one in just for good measure.  Still would not start.  Pulled the fuel line connector underneath and turned on the switch and fuel was coming out, but with little to no pressure.  I turned the switch off and on multiple times to fill up a water bottle with fuel, and the fuel was good.  As it turns out, the fuel pump is out of warranty (go figure).  So, I'm going to put a pressure gauge on it tomorrow and see what it is pumping.  Is there anything else I can check?
      Many thanks,
       
      David
  • Similar Tagged Content

    • By LMI
      The saga of the fan continues.
      The Pin attempt in the fan shaft failed.  I then moved on to trying to weld the fan hub to the fan shaft.  I took it for a run the weld broke.  Now it was truly F'ed.  To recap the dealer price, they want $400 + CND for a replacement fan assembly.
      I searched all sorts of after market places and no one carried one.  Ebay had some used ones but they were $120 USD + Conversion rate for something as old as what I have.  I went to Amazon and eventually settled on this.
       
      amazon link
       
      What I found... and was amazed... was that the fan mounted to the Suzuki fan assembly bracket.  I was prepared to manufacture my own mount conversions...  It also came with "Harpoon mounts" (nylon zip tie like things that go straight through the rad.   Anyways it mounted to the original bracket. It fit perfectly.  Cut the electrical plug off replaced it with the Suzuki... all good.  Let the quad heat up, thermo coupler kicked in the fan circuit, polarity was right... all was good....  Fan is under the circuit fuse rating.  
       
      so I finally have a solid fan solution.  $34 CND vs $400+ CND
    • By johnwayne
      i have a 2000 suzuki king quad lt-f300f that i picked up as a project bike. it didnt run well when it was parked outside 5 years ago. it cranked after putting fresh gas - but would not run below half throttle, i took apart the carb, cleaned debris, and re-assembled. i suspect that the pilot needle is sheared off - it never protrudes into the throttle body through the pinhole. now to get the bike to ALMOST idle, the throttle idle adjustment knob is all the way up/in. the pilot needle is turned almost all the way in/up (if i understand correct, it should nominally be out 2 1/4 turns or so). and like i said, it will ALMOST idle. floods easily, rides rough.
      wanted to hear from those more experienced than me with suzukis - and im self-taught atv repair, so dont laugh too hard if my verbiage/part names is way off. 
      facing the driver's side of the bike [US] there are three hoses on this side of the carb. without a service manual or way of knowing what was messed up before i got it, i think i have them right: front hose as a vacuum to the petcock, middle hose as vacuum to the fuel pump, rear hose as fuel line from the fuel pump. running the bike in prime position results in flooding even while riding. with all hoses disconnected from the carb, fuel slowly drips from the vacuum line connected to the petcock.
      so just my speculation is that the diaphragm in the petcock is split, and the pilot needle is broke off - causing my inability to not quite idle and the rough ride. this suzuki is hoses and cables everywhere compared to the honda ranchers and yamaha warriors i am used to. I would like to have a plan rather than: replace everything at once.
      is my speculation on the right track, or could something else be at play? say, if the compression was non-existent, would that cause non-idling? i am all ears, look forward to the input.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...