Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

I own a 2005 KVF 650 Brute Force I was rebuilding the clutch and as anyone knows this is a crazy exspensive adventure, but I came across a Promo code for Procaliber.com offering 5% off any purchase of OEM parts, their prices were already super low and this saved me a ton of extra money! super great find!!!!!! I listed the code below for all of my ATV brothers!

Procaliber.com

promo code : SAVEBIG

Share this post


Link to post
Share on other sites


Guest
This topic is now closed to further replies.

  • Similar Topics

    • By MarkinAR
      So just as a general FYI, it might be good to check replacement parts before installing.  If possible, check clearances with a micrometer before going through the trouble of assembly.  I say this as I bought a new driveshaft yoke for a Kodiak because the ujoint dropped a cap and got the yoke in a bind...blowing the yoke and middle drive gear to shreds.  So I replaced the middle drive gear and bought a new yoke and ujoint kit from Caltric.  Caltric is usually pretty solid replacement parts.  The new yoke however was a good 4mm too narrow for inside lock ujoint caps.  Disappointing since it came as a kit from Caltric.
      Ended up taking an angle grinder to the new yoke and thinning material off to get it to the needed 41.25mm opening size.  Sucks having to disassemble everything again and start over but my fault for trusting replacement parts.  Nearly 40 years of turning wrenches and I made a rookie mistake.
    • By JacobSlabach
      got 7 atvs off CL recently for a good price.  one of which is a yamaha warrior.  anyone know where the vin is printed on this bike?  Haha good place to start as I do not know year or size yet.  The former owner says needs exhaust ans and clutch work.  he said it ran fine until the clutch cable broke and then I couldn't get the new cable adjusted right and it would grind gears.  things I see:  clutch cable locked up again, no brakes, carb leaking (green with algae around the bowl and has gelled gas stalagtights on it), aftermarket exhaust melted the airbox so I need something different and a new air box.  I would like the use the current exhaust if I can but I have a feeling its a redneck fix as it looks like there is an ace bandage holding it to the exhaust pipe (its an aftermarket slip-on exhaust), so I'm not sure about that- lets get the bike running first.  also, battery (looks brand new, what a shame) is dead, 0 volts.  Otherwise, bike looks to have not been wrecked, and plastics are ok (it sat outside under a 'tarp' for 3+ years since it was run last).  any tips and advise on where to start first would be awesome as this is my first clutched bike (manual).
      the clutch is my main concern- I've never rode a clutched bike so I dont even know what its supposed to feel like.  lol I'm spoiled on my automatic polaris 
    • By Barry Troxtell
      I have a 2005 Sportsman 500, Instrument cluster will not illuminate, hi/lo beams work though.  Any tips or troubleshooting info is greatly appreciated!
    • By marek porowski
      Hi, I got a check engine light and a diagnostic code 520194 2 and i know it has something to do with throttle voltage out of range
      I'd like to know if thats something that can be adjusted ? Or does anybody know what should i test  ?  I just bought this atv and I'm fixing it as its been in an accident. 
      I also changed throttle leaver as original one was broken and I noticed inside the 4x4 selector assembly there are 2 contacts but I'm not sure if they're suppose to make contact at idle. I found some info online but some are saying they're suppose to touch and some say they're not. I think id depends of the year of the machine but I'm not sure. I'd really appreciate any help that i can get with this
      Thanks 
    • By Nate Hanson
      I am a new atv owner...I bought a used atv this summer (pretty sure it is a wolverine but reg card from last owner didnt actually say that so idk for sure). It ran great for most the summer and early fall but one day I tried starting it and it turned over a while without starting and then suddenly it quit turning over at all. No click or anything.
      I charged battery and light turns on showing neutral and heatlight can go on.
      A few other things that may be pertinent: The pull start is missing, I have a fluke multimeter but not many other advanced tools (or relevant experience), there is an extra aftermarket led light attached to front but it doesnt work either... never looked into why since I didnt need it. 
      I looked for a fuse box and didnt find one.
      Please recommend some easier things to try first as I really want to avoid taking it in if I can (having one income and 4 kids can keep out extra cash, plus I want to learn). Pictures would be awesome if possible. Thanks! 
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...