Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

sirphobos15

yamaha moto 4 200 air filter case

Recommended Posts

Hey I have just recently purchased a 1985 Yamaha moto 4 200 and found that the air filter case is not only busted open but also missing the filter and element. I have searched for these parts online and have yet to find any out there for sale. I was wondering if there is a way to make my own air filter case with filter or some way to go about fixing this problem. Any help would be much appreciated thank you . Can post pictures if need to

Share this post


Link to post
Share on other sites


Depending on how bad the outer casing is beat up, plastic jb weld will work just fine and give you a strong fix. I have a 1986 Yamaha moto 4 200 and when I bought it, it had cracks, it was beat, missing the element, the filter and the back cap. I repaired the cracks with jb weld, and I bought a 2 1/2 inch pipe to 2 inch pipe conversion for 4 dollars to replace the element, with this I chopped it down to shorten it tp about two inches long, and jb welded that on over the hole to the carb. With that I bought a 20 dollar filter from ebay. It was a 50 mm or 2 inch flange uni airfilter which fits nicely over the end of the conversion pipe. For the back I used some spare plastic laying around, cut it shape, used silicone as a seal and used some screws I had.

Hope this helps

Share this post


Link to post
Share on other sites

you can make your own using a milk jug and old inner tube- just make sure when done it can take air in and it goes through the filter. plus the entire system is closed so only the air going to the card come from the filter

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Ajmboy
      Unfortunately I didn't notice some of the rust hitting the undercarriage of my 2004 Yamaha Grizzly 660, but saw it the other day when I was doing some maintenance, oil change, air filter, spark plug, etc. The left side footrest broke and that's causing the plastic to hit the front wheel. It broke right at the welds from too much rust. Looks to me like what I need is (looked this up on yamahapartshouse.com):
      YAMAHA FOOTREST BOARD 5KM-27481-10 Left side (broken)
      YAMAHA FOOTREST BOARD 5KM-27488-10-00 Right side (rusted and will probably break eventually)

       
      Does anyone have a less expensive source? I did see on ebay a couple of listings but it still comes out to @ $50 each, 
    • By Asen_77
      Hi All,
      My name is Asen and I am from Eastern Europe, Bulgaria. Riding a Yamaha Raptor 700R and this is my first Quad wanted for a vey long time :)

       
    • By Tinscissors 428
      I have a 01 blaster kickstart won’t work but bump start does work
    • By StolenATV
      Blue and White Raptor 90
      White, Black and Yellow Raptor 90
      Blue and White WR450F Motorcycle
      VIN’s for ATVs
      RF3AB11Y2HT006593
      RF3AB11Y5HT006815
      Stolen from the yard at my home at night on 10/26/19.
      $2,000 reward for information leading to their return.
      The post Two (2) Stolen Yamaha Raptor 90 ATVs and a Yamaha WR450F Motorcycle appeared first on STOLEN 911.
      View the full article
    • By quadtech62
      I have a 02 Warrior i am trying to build a wiring harness i have looked in the manual and  i am confused... the pick up has 2 wires.  W/R W/G The source rotation coil has 2 wires. One is Red other is white/blue. The manual shows the  the white and blue wire connected to the w/g  right after the stator... so why is these 2 wires connected?  Does not show w/b wire at cdi 
      i have looked at many options with no luck if someone has a 2002-2004 warrior and can take a pic of the wires and location at cdi i would really appreciate it. Thanks
  • Similar Tagged Content

    • Guest
      By Guest
      Ok...I'm gettin' me juevos ready to do an oir filter clean....
      Went to my local harley/quad dealer and he had me purchase the No-Toil kit (Cleaner, Air Filter Oil, Rim Grease)
      What I've read is that the No-Toil cleaner will NOT clean
      other oils off air filters....just the No-Toil oil....
      So, I've also read that others have cleaned their air filters
      in the kitchen sink, used gasoline, or used flash solvent....
      Looking for advice as I've mentioned I'm very mechanically
      DECLINED!
      I'm going to wash the air box seal in the sink and give it a good dry....
      One more thing......No-Toil or Bel-Ray for filter oil?
      Thanks!
      -TD
    • By Anthony Marceau
      Hi everyone! I have a 1986 yamaha moto4 200 that's been sitting for a while! Cleaned the carb, replaced engine oil, put fresh gas in it. Got it running and went for a ride! It was running great just a little backfire once in a while! I barely made it home on the way back and now the bike won't run at all since then! It will start if I give a little bit of throttle but dies instantly as soon as I let go off the throttle! And even if I try to rev it up it'll sound like its not getting enough gas.. it revs up a couple hundred rpm's and backfires through the carb.. it almost sounds as if I was trying to take off from zero in 5th gear! Nothing is seized though! I dissasembled the head and the piston and cylinder are fine! Rebuilt the carb, replaced the ignition source coil.. I don't know what to do anymore.. compression test shows 90 psi Specs are 128 psi but i'm not sure if I trust my compression tester.. any ideas? Thanks!!
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...