Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

dIrTee_dEEdZ

Kazuma Meerkat 50cc needing some advise please.

Recommended Posts

Hello i have recently purchased my kids a second hand Kazuma as a beginners bike, i would love to add a speedometer and a RPM tacho if possible for a little added safety so they dont flip it but i really have no idea where to start, sorry if sounds silly, .....how and where do i connect the speedo to(I mean electronics wise) and also how and where do i wire/connect the tacho to?

Thanks in advance

Allan

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By amharrison24
      i have a 91 moto 4 100. has electric start only. for as long as i could remember we have always pushed start it. after riding for while you shut it off. you are able to hit the start button and it will start right up. anyone know where i should start with fixing this issue? im fixing it up for my niece. thank you in advance.
    • By Steven Urban
      First time using this forum.  Owned a Kawasaki dirt bike once, had no issues.  But I picked up this 4 wheeler at an auction.  They stated it ran, but only needed a battery.  Well I do not believe that was all true.

      Some pictures are attached.  Not sure why, but the whole air filter stuff was removed.  They had some small thing inserted as a make shift air filter.

      I purchased a battery to try this all out.  Waiting to return it and get the proper size, as it was too big for the battery box.  But here is my issue I had while the battery was connected.

      1 - The lights on the steering column did not come on.  Not sure if they work or not.

      2 - The starter solenoid seems to be bad.  I have a new one on order. 

      3 - In the pick, there is another rusted part.  Not sure what that part is or what it is used for.

      4 - What is the 12v rectifier?  square bodied part.

      So when I hooked the battery up.  Pushing the start button did nothing.  Pulling the cord to try and pull start, it turned, but would never fire.  I have put in a new spark plug as well, it looked worn out.  With electric start, I crossed over the posts on the start solenoid, it turned over, but would never fire and start.

      I have read a few other threads and it stated something about needed the neutral light on.  SOmething about a kill switch.

      Any help would be appreciated.



    • By Mike Strayhorn
      last year I bought led lights when I was riding my 4 wheeler the lights started getting dim shut off
      now my 4 wheeler will not start the battery is hot everything is dead I checked the fuse and its good 
      would there be another fuse I am missing I'm took the led bulbs out and replaced them with the ones that was in there 
      wonder what meh problem is
       
    • By Aj Hurtibise
      I have a 2000 Honda trx90 I got from a buddy for free he said it needed a carb so I put his old carb back on it to try to get something out of it and it does not have any Spark. I already replaced the ignition coil I don't know much about four wheelers but I am a technician so I do know my way around a motor any electrical help would be wonderful or specs I don't have the best digital multimeter either.
  • Similar Tagged Content

    • By Ajmboy
      2003 Scrambler 50, Predator 90, Scrambler 90, Sportsman 90
      SERVICE MANUAL
    • By Ajmboy
      View File 2003 Scrambler 50 Predator 90 Scrambler 90 Sportsman 90 Service manual
      2003 Scrambler 50, Predator 90, Scrambler 90, Sportsman 90
      SERVICE MANUAL
      Submitter Ajmboy Submitted 05/28/2017 Category Polaris ATV  
    • By PWRUMLEY
      Need some advise pls. Couldn't get the quad to start put a new cdi on it fired right up rode for about a week, now it starts just fine but will only idle for a few minutes then die, but will fire right back up...now it's running a little rough I rode it for about an hour and it started missing out when I even touched the throttle. I cleaned the carbs and cleaned the plug rechared the k&n air filter, still fired right up but same thing, it won't stay idleing and misses out and wants to die when I give it gas. It seems like it's getting too much gas or not enough not sure, or possibly a vacuum issue. Any suggestions
    • By atvfarm
      Ok Im new here. I was given a cougar 250 and i put a new carb on it and it will idle great but anything above low rpms spits and sputters. also is this thing suppose to have a fuel pump or just gravity feed from petcock?
    • By atvfarm
      Ok Im new here. I was given a cougar 250 and i put a new carb on it and it will idle great but anything above low rpms spits and sputters. also is this thing suppose to have a fuel pump or just gravity feed from petcock?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...