Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

I have a 2005 Sportsman. The starter continues to engage after the key is turned off. I have to disconnect the battery to make it stop. It reengages the starter when I place the positive back on the battery even with the key off. Suggestions????:aargh:

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Cj Winds
      I have a 2005 Yamaha Kodiak 400 Automatic. It has an oil leak inside clutch cover. The middle gear has two oil seals, the front seal is leaking engine oil into clutch area. How do you change the leaking seal?
    • By colin james
      View File 2018/2019 Polaris Sportsman XP 850/1000 Service Manual
      This is the factory service manual for the 2018/2019 Polaris Sportsman XP 850/1000
      Submitter colin james Submitted 08/01/2019 Category Polaris ATV  
    • By colin james
      View File 2017-2019 sportsman 450/570 with eps factory service manual
      This  is the factory service manual for the 2017-2019 factory service manual for the sportsman 450/570 with electronic power steering 
       
      Submitter colin james Submitted 09/06/2018 Category Polaris ATV  
    • By bodon
      Anyone know what the fuse terminal marked UNSWITCH  does  .  Even with the key off it is causing a drain on my battery and I'm trying to figure out  what that terminal goes to.  It's a 10 amp fuse. If I pull it the "short" goes away.  Thanks in advance.
  • Similar Tagged Content

    • By Zacharia Maisonneuve
      i have a 1993 timberwolf yamaha and the compression is good and lights work but for some reason the electricity is not going to the spark plug(s)! i got a friend to check it out and they said its no use but im not giving up! please help with this!
    • By Homestead
      My bayou was running. Turned it off. Went to start it again about 20 minutes later and nothing.... no electrical power. No lights, no neutral indicator light. Battery good. Jumped starter and it turns over but doesn't start. I'm not sure what the problem could be. Maybe ci igniter or rectifier?
    • By Snowden
      Hi everyone,
      I have a question, if the starter clutch gear looks fine but is still not working correctly then all I should need to replace is the one way bearing, right?
      thanks,
    • By Blue
      Hey all I have a question on my 94 fourtrax 4x4. The electric start won't work. When I hit the button I hear the solenoid clicking but nothing happening. I put on a new solenoid and same thing happened. So I took off starter and checked it, brushes looked good nothing looked out of the ordinary. My battery is putting out 11.2 volts. I wouldn't think that would be it since I put a newer battery in from my other quad and still got same results. Any ideas I'm scratching my head on this one.
    • By Pure_Michigan
      I bought this old three wheeler that I found in a barn. It looked pretty rough, but I have it running now and functioning.
      With the switch set to "run" and the key in the "on" position the electric starter does not work when I push the starter button,
      However, if I cross the solenoid it will work and it will start the engine - so I know the starter motor is good and it works.
      Now, it gets a little mysterious. When the engine is running, AND the headlight is on high beam, the electric starter will engage when the starter button is pushed.....When its already running! (when the headlight is off or on "low" the starter button does nothing, only when running and in high beam will you hear the starter motor zing when you push the starter button) So, I know the button actually works, but only after the engine is already running and the high beam is on!
      So to recap: with the key on, the starter button does nothing. crossing the solenoid will make the starter work, and after the engine is running the starter will work with the button!
      Has anyone else had this problem? Can anyone point me in the right direction on solving this one?
      Thanks!
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...