Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

outodoors

New guy here

Recommended Posts

Hey all, I am new here, new to quads well owning them anyway, I am a certified Chrysler mechanic and we just got 3 quads. a 99 Honda trx300 fourtrax 2wd, and 92 Yamaha YFM80 Badger, and a Suzuki lt50. So far it has been a great thing for me and my boys to do together. Looking forward to learning a ton of information.

Share this post


Link to post
Share on other sites


Welcome to QuadCRAZY, you've come to the right place!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By AimlessMoto
      Hey guys, new here, but haven't found ANY answer to my specific problem on a Suzuki dedicated ATV forum, so here's to hoping!
      I acquired a 95' Quadrunner 250, 4x4, (LT4WD) for practically nothing with no spark. The PO had tossed in a used stator which didn't fix the problem... so I went all routes (though cheaply) to narrow down the initial problem of no spark. 
      Plug, coil, CDI (caltric) and stator w/pickup (caltric) were purchased and installed. And it RAN, but bogged horribly and would not rev past 1/4 throttle. 
      I checked fuel flow, vacuum lines, all the normal stuff, no issues. I decided to check the valves and cam... well, there was one problem. The cam was 1mm under the lowest spec in the manual. So, in-came a new cam, Stage 1 Hotcams... also threw in a new set of shindy valves, lapped them, replaced the valve seals, and the timing chain. 
      Back together again (w/stock airbox and new oiled filter). Now it idles even better, still boggs at 1/4 throttle, but will rev past it if you hold the throttle open for a second. Ahaha... success!
      So I was able to ride it above 1/4 throttle once I had momentum... could shift through the gears, all was good as long as I kept it over 1/2 throttle. Took a long enough ride to break in the cam properly at least so I won't have to worry about that. 
      Now, I start fiddling with the carb. It's clean as a whistle, stock, with stock jets (new replacement Mikuni jets). Same problem. 
       
      I start thinking, maybe this is fuel related and the bike is having an issue transitioning from idle jet to main jet... so I LOWER the needle by raising the clip 1 spot. Now it revvs up in neutral with no bog, but it boggs about the same trying to ride it. So I move the needle down again with the clip on the top slot. Better, but still has a bit of bog at 1/4 throttle. 
      The last bit of advice I got was to ditch the CV carb... so I sprung for a brand new Mikuni VM30-83 round-slide. Bolted it up, blew into the vacuum tube to fill it with fuel (no vacuum port on this one) and she fired right up... but there is still a bit of bog, it's just masked by the fact that I'm not waiting for the vacuum diaphragm to open. 
       
      So I feel like each little step brings me closer, but not perfect. I'm now wondering if this is still in-fact a carb tuning issue (I have some jets I can fiddle with and maybe lean-out the idle jet a little.) OR if the cheap-a** Caltric Stator/Pickup is what's causing these issues. 
       
      I have a 95' KingQuad with 400 miles on it... like new.. runs like a top... I've tried both the stock QR and the Caltric CDI boxes on it, and it revvs up and runs like a champ. 
       
      The only unknowns between the two systems are the carb, and the stator/pickup. My next step in troubleshooting is to rip apart the King Quad and test it's CDI on the Quadrunner... but considering there is no change to how it runs I doubt it will lead to a solution. 
       
      HOWEVER... I tried the stock CDI just recently after running the Caltric this whole time, and the bike runs like garbage. Hardly idles, and won't rev up at all. So, that is my one smoking gun telling me that it's either the pickup coil or the stator itself. 
       
      Has anyone had a problem even CLOSE to this? I can't image the carb would be causing this many issues, especially going to 2 different ones, both with stock jetting to OEM, and exhibiting the identical symptoms... the only change is when different CDI's are plugged in, or when the needle valve leans out the mixture. 
      Also, I checked the piston, rings and bore when I had it apart and they're like-new... no scoring, rings are loose, cylinder is still round and has honing marks still int he bore. Stock piston, stock bore size and it has 160psi compression. Battery is brand new, and I've tried 3 different R/R's, none of which change any symptoms, but slightly vary the charging voltage by .2-.5 of a volt depending on which unit. Also tried a new coil which changed nothing. 
      ANY help would be appreciated. Too much invested to not get it running right. 
    • By oxidized_black
      these are what i have in my collection ... always looking for more
      1985 - 1990 Suzuki LT230 & LT250 Service Manual
      http://rapidshare.com/files/3408466380/1985%20-%201990%20Suzuki%20LT230%20%26%20LT250%20Service%20Manual.pdf
      1987 - 1998 Suzuki Quad Runner 250 & King Quad 280 Service Manual
      http://rapidshare.com/files/4183862408/1987%20-%201998%20Suzuki%20Quad%20Runner%20250%20King%20Quad%20280%20Service%20Manual.pdf
      1987 - 2006 Suzuki LT80 Service Manual
      http://rapidshare.com/files/2550473580/1987%20-%202006%20Suzuki%20LT%2080%20Service%20Manual.rar
      1987 Suzuki LT500R Quadzilla Service Manual
      http://rapidshare.com/files/4261907986/1987%20Suzuki%20LT%20500R%20Quadzilla%20Manual.rar
      1988 - 1992 Suzuki LT250R Porting Instruction
      http://rapidshare.com/files/2211227601/1988%20-%201992%20Suzuki%20LT%20250R%20Porting%20Instruction.pdf
      1988 - 1992 Suzuki LT250R Quadracer Service Manual
      http://rapidshare.com/files/2017114826/1988%20-%201992%20Suzuki%20LT%20250R%20Quadracer%20Service%20Manual.pdf
      1988 - 1992 Suzuki LT250R Tuning Guide Instruction
      http://rapidshare.com/files/2646189275/1988%20-%201992%20Suzuki%20LT%20250R%20Tuning%20Guide%20Instruction.pdf
      1999 - 2004 Suzuki King Quad 300 Service Manual
      http://rapidshare.com/files/4083575866/1999%20-%202004%20Suzuki%20King%20Quad%20300%20Service%20Manual.PDF
      2002 - 2007 Suzuki 500LTA Service Manual
      http://rapidshare.com/files/117478118/2002%20-%202007%20Suzuki%20500%20LTA%20Service%20Manual.pdf
      2002 - 2009 Suzuki LTF250 Ozark Service Manual
      http://rapidshare.com/files/487503898/2002%20-%202009%20Suzuki%20LTF%20250%20Ozark%20Service%20Manual.pdf
      2003 Suzuki LTZ400 Service Manual
      http://rapidshare.com/files/158558615/2003%20Suzuki%20LTZ%20400%20Service%20Manual.rar
      2006 Suzuki 50LTZ Quad Sport Service Manual
      http://rapidshare.com/files/4135680547/2006%20Suzuki%2050%20LTZ%20Quad%20Sport%20Service%20Manual.pdf
      2004 Suzuki 250LTZ Quad Sport Service Manual
      http://rapidshare.com/files/1048588852/2004%20Suzuki%20250%20LTZ%20Quad%20Sport%20Service%20Manual.pdf
      2005 Suzuki LTA700 King Quad Service Manual
      http://rapidshare.com/files/1790653344/2005%20Suzuki%20LTA%20700%20King%20Quad%20Service%20Manual.pdf
      2007 Suzuki 90LTZ Quad Sport Service Manual
      http://rapidshare.com/files/4042730335/2007%20Suzuki%2090%20LTZ%20Quad%20Sport%20Service%20Manual.pdf
      2008 Suzuki 400FLTF King Quad Service Manual
      http://rapidshare.com/files/3004786025/2008%20Suzuki%20400F%20LTF%20King%20Quad%20Service%20Manual.pdf
      2008 Suzuki 750 King Quad Service Manual
      http://rapidshare.com/files/630050962/2008%20Suzuki%20750%20King%20Quad%20Service%20Manual.pdf
      2009 Suzuki 400LTZ Quad Sport Service Manual
      http://rapidshare.com/files/3513183033/2009%20Suzuki%20400%20LTZ%20Quad%20Sport%20Service%20Manual.pdf
       
      ALSO CHECK SUZUKI ATV SERVICE MANUAL DOWNLOADS
    • By KJINTF
      Been slow in starting up, in the recent past it would start up in <1/2 second of the button press with a snap. Now it takes several seconds of cranking to get going. Once going runs as it always did. Replaced the plug no change. Battery is good.
      Before I tear it apart and look things over was hoping others might have had the same experience and have a quick fix for me
      Thanks in advance for any and all suggestions to get this old machine starting quickly again as it has for 20 years.  
    • By Asen_77
      Hi All,
      My name is Asen and I am from Eastern Europe, Bulgaria. Riding a Yamaha Raptor 700R and this is my first Quad wanted for a vey long time :)

       
    • By Jordan Ritzman
      What are some good online vendors for parts
  • Similar Tagged Content

    • By bilzhorse
      New guy from Stafford, Va. I'm about an hour south of Wash, DC and and hour north of Richmond, Va. My sons and I love to go wheeling. We have been going to Taskers Gap in Edinburg, Va. We have four ATVs: 1991 Honda Fourtrax 300, 1995 Honda Fourtrax 300, 1996 Yamaha Big Bear 350 4x4 and an Arctic Cat 500 4x4.
    • By br1ck5
      Hi all, Looks like this forum is a good way to connect with other atv riders and share knowledge. I own a 01 Foreman 450 and 08 Teryx 750. See you around guys!
    • By dakotasnake
      this is my 1st atva kawisaki bayou 300 4x4. its alot of fun. im in the process of retireing from farming so i have plenty of time and plenty of places to ride. iv been useing the beast for checking fences and my trap line. i wasnt sure how it would do in the snow, thats why i call it the beast, havent been stuck yet. looking at the map it appears im the only one on here from s dak. i guess s dak. is one of the few states you can lisence and drive atv's on public roads. not sure if ill do that yet or not. theres nothing i have to work on yet on the beast but im sure ill eventually be looking for a manual to make adjustments etc.
    • By trg804
      Hey everybody,
      I am in Southeastern Washington State (Kennewick) and would like to find others in this area that are interested in ATV riding (quad) around here or places near here (SE Oregon, Idaho, etc.).
    • By theteacher
      Hello All, The KYRider site I was a member of for years has shut down. So, here I am. I currently own a 450 Kodiak with several mods and some yet to be installed. Tomorrow, I will look at a Blaster thats in great shape. It starts and runs great. However, It will not go into gear. Im pretty sure I can fix this relatively cheap. I have not priced Blasters in years but the asking price is $600 firm. Is this reasonable? Thanks,
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...