Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

:aargh: I have been trying to get this suzuki to run right it starts great and idles for about 1 or two minutes. Carb rebuilt,new reed assembly,new fuel tank valve. everytime you give it a little gas it falls dead. Tried all I know but lost has a goose, only thing I havent done is a new spark plug but it seems to spark good when I check it. Alls I need now is a stick of dynomite and a match. Please any ideas you can direct me in I would appreciate Iam to old to loose any more brain cells on this Thanks All

Share this post


Link to post
Share on other sites


Id check the compression.

Is the pipe plugged?

Share this post


Link to post
Share on other sites
:aargh: going to check pipe today when it runs it seems to put out plenty but its cold doesnt seem to get hot like most of them

Share this post


Link to post
Share on other sites

thanks for the thoughts figured it ran to good when it ran but it was all a game .

checked compression by finger since my compresson gauge was never returned ( dont lend tools out of site lol) Found head gasket leaking just enough that oil in gas must of sealed it to run. Anyway ordered new parts will find out next week if this is all thats left. Thanks for your help i jogging my brain

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Brad Leeson
      What's going on party people? First, thank you for allowing me the opportunity to be here. I recently purchased a 2005 yrs 450 and have yet to run the bike at full throttle. The bike fires up, idles, seems like everything runs fine except a little popping when you let off the throttle or until you hit 5th gear. It runs strong; no bogging or sluggishness until you hit 4th gear and open it up. Then it begins to act like it's out of gas or the about to be out. I can pull over and sit for 5-10 min and it runs strong again until you open the throttle. I have the carb off the bike to clean and wrote down a list of factory and what I found installed. I also listed other key factors and hope someone can help and explain. I'm new to the scene and have no prior mechanical experience but my theory is worst case scenario I have to take it to the shop anyway so why not learn. I actually enjoy it. Lol. Thanks a million. Hope to get back on the trails soon. 

    • By Jordan Ritzman
      What causes a rod bearing to overheat and seize 
    • By Jordan Ritzman
      How long between rebuilds 
    • By Jordan Ritzman
      What are some good online vendors for parts
    • By Bud03420
      I just got this bike and not getting any spark I know nothing about it so before I spend any money on it I like to see if it fires dose it have to have a battery to complete a circut and spark cause it dosent have one
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...