Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.


Recommended Comments

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Tagged Content

    • By Joseph Miller
      Hi guys im new here and ive been doing alot of research on my polaris predator i was wondering if anyone on here has wired a different cdi up on there quad? Not a direct replacement that would simply just plug in. I know my white an w/red wires go to my pulsar my green an blue go to my reverse coil but im unsure which is + and which is ground also brown/w is a ground correct? What about purple? Black goes to my kill switch and red is my 12v supply........then ive got yelloww/red , yellow / yellow that goes to my rectifier..........any input on this subject is greatly appreciated thank you all
    • By Christian Brindle
      I have a 2000 Polaris Sportsman 500. The Speedometer got water inside of it and it sat for a long time. So now that speedometer is trashed to say the least and i need to find a replacement. I don't want to put up the cash for an oem one so i was wondering if anyone knew any good speedometers out there i could use. I've found many speedometers i like but don't know how i'd wire it up without the same connection points. Thanks, any input is appreciated
    • By Christian Brindle
      I've already posted here once about this ATV. Lots of people suggested i check the cam and after a couple months i finally got around to attacking it. I got it all apart and got the cam/rockers out. I'm almost positive they need to be replaced, they're pretty scored up and don't look too hot. Just wanted some final opinions before i drop the money on it. I'll also take feedback on the new cam i've chosen.
      Old Cam: 
      New Cam: https://www.amazon.com/hz/wishlist/ls/2GM2J05FQQPCD?ref_=wl_share
      Old Forum: 
       
       
      Thank You.
    • By james p
      Hey all new member so I'm sorry if this isn't the correct place to post, but I'm having trouble with a 2000 polaris magnum 500 I just acquired. The quad ran when I got it but was having problems that sounded like the camshaft, and sure enough camshaft lobe was pretty much gone, so we replaced the camshaft and exhaust rockers and now the quad doesnt have spark. We had the quad running right before we tore the old camshaft out and now no spark. Anybody else ever have a problem similar? We've been checking for loose wires, checked grounds, and double checked timing but cant get it figured out so any advice would be appreciated! Thanks 
    • By Mo Salem
      So my front hub broke, I’d like to put aftermarket on. Hard to find new oe ones. Please help. I’m new to all of this, I have some car knowledge and try to apply it
  • Check these out!


×
×
  • Create New...