Quantcast
Jump to content

Search the Community

Showing results for tags ' trailboss'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Community Discussion
    • General ATV Discussion
    • General Talk - Anything Goes!
    • New Members Area!
    • Where To Ride Your ATV
    • ATV Picture and Video Sharing
    • ATV Racing & ATV Events
    • ATV & Off Road Modifications
    • ATV Tires and Rims
    • This vs. That ATV & Off Road Comparisons
    • ATV Trailers, Haulers, and Attachments
    • Hunting, Camping, & Outdoors Forum
    • ATV Laws, Legal Issues, and Policing
  • Regional ATV & Off Road Forums
    • Northeast ATV & Off Road Forum
    • Midwest ATV & Off Road Forum
    • South ATV & Off Road Forum
    • West ATV & Off Road Forum
    • Other Region ATV & Off Road Forum
  • ATV Manufacturers
    • ATV Forums By Brand
  • UTV Side x Side Manufacturer Specific
    • UTV & Side by Side Forums By Brand
  • Other Powersports, Offroad, and All Terrain Vehicles
    • Kids ATVs and Youth Off-Road
    • ATC 3-Wheeler Forum
    • Dirt Bike Forum
    • 4X4 Trucks and Jeeps
    • Water, Snow & Other Powersports
  • QUADCRAZY Classifieds
    • ATV For Sale? Post it here.
    • Stolen ATVs
  • QUADCRAZY Supporters
    • ATV Links & Partners
  • ATV News, Magazine Articles, Product Reviews
    • ATV News, Articles & Press Releases
    • New ATV Products, Reviews & Tests
    • Manufacturer & Aftermarket Promos
  • QUADCRAZY Announcements & Support
    • Announcements/Support
    • Website How To & Feedback
  • Yamaha Grizzly Owners's Topics
  • New York ATV Riders's Group Forum
  • Michigan ATV Club - St Helen, Mio, West Branch, Rose City's Lets ride Michigan trails this season!
  • Michigan ATV Club - St Helen, Mio, West Branch, Rose City's Up coming season
  • Kawasaki Bayou 220 Restoration and Repairs's Topics
  • Ride Red's Videos
  • Ride Red's Ride Red Forum
  • NYC 2 Poconos/ Scotrun ATV Riders's ATV Upgrades
  • NYC 2 Poconos/ Scotrun ATV Riders's Quads
  • Mechanics Club's Topics

Categories

  • ATV News and Articles
  • ATV New Products & Reviews
  • ATV Racing & Events
  • ATV Ride Reports
  • ATV and UTV Vendors

Calendars

  • Community Calendar
  • ATV Racing Events
  • ATV Poker Runs and Riding Events
  • ATV Swap Meets
  • Other ATV & Off Road Events

Categories

  • ATV Repair Manuals
    • Arctic Cat ATV
    • Can-Am BRP ATV
    • Cannondale ATV
    • CFMOTO ATV
    • Hisun ATV
    • Honda ATV
    • Kawasaki ATV
    • Kazuma ATV
    • Kymco ATV
    • Polaris ATV
    • Suzuki ATV
    • Textron Off Road ATV
    • Yamaha ATV
    • Other ATV
  • ATV Owner Manuals
    • Arctic Cat ATV
    • Can-Am BRP ATV
    • Cannondale ATV
    • CFMOTO ATV
    • Hisun ATV
    • Honda ATV
    • Kawasaki ATV
    • Kazuma ATV
    • Kymco ATV
    • Polaris ATV
    • Suzuki ATV
    • Textron Off Road ATV
    • Yamaha ATV
    • Other ATV
  • UTV Side by Side Repair Manuals
    • Arctic Cat UTV
    • Can-Am BRP UTV
    • Hisun UTV
    • Honda UTV
    • Joyner UTV
    • John Deer UTV
    • Kawasaki UTV
    • Polaris UTV
    • Textron Off Road UTV
    • Yamaha UTV
    • Other Brands UTV
  • UTV Side by Side Owner Manuals
    • Arctic Cat UTV
    • Textron Off Road UTV
    • Can-Am BRP UTV
    • Hisun UTV
    • Honda UTV
    • Joyner UTV
    • John Deer UTV
    • Kawasaki UTV
    • Polaris UTV
    • Yamaha UTV
    • Other Brands UTV
  • Other Files

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location

miles from

About Me


My Garage

Found 8 results

  1. so I seem to have some trouble getting my old 85 trail boss to put out a spark. when I first got it it fired just fine but had no compression. After I rebuilt the top end and tried to start it there was no spark so I got on the internet and ordered a used coil that came off of the same bike and it worked and ran good for about two weeks. When I really got the engine going good it would lose power and start to bog down but would quickly recover after a few seconds. Then one day it wouldn't starts and I found that it was not firing at all. Now I`ve put a brand new coil and there is still no spark. Everyone I know seems to think its the cdi box. However when I search on the internet everything points to the stator. Is there a way of testing either one?
  2. Had a starter issue so I pulled it out cleaned it up and it Started so I took it for a spin and it died in the field I tried starting again and it seems to be jammed somewhere in where wants to turn the clutch but seems stuck any suggestions ??
  3. Hello fellow members, I recently tore down my grandsons 1995 250 Polaris Trail Boss to replace the rings. Problem is, its been bored over and now mics at 72.60 at the top, and 72.54 at the bottom. I only honed the cylinder to remove the glaze. What size over piston and rings do you think I should use?
  4. Does anyone know the difference between a 2001 and a 2002 trail boss? I have been looking for a front rack for my '01 trail boss, but couldn't find one. I did locate one for an '02 trail boss, and I'm wondering if it will fit. Thanks, Tim
  5. I have a1992 polaris trailboss 350l that after I run the machine for awhile It will not idle, but when I let it sit it starts right up and idles. When I start it up first thing for the day it starts right up and idles it quits ideling when it gets warm any ideas or thoughts would be great.
  6. my brother in law has a 91 polaris 350 liquid cooled i think its a trailboss. anyways out yesterday riding and it quit. got it home and piston skirt is destroyed. looks like a complete rebuild. can cylinder be bored or is it nicasil.? any ideas would be great. thanx. cylinder doesnt look that bad but piston is destroyrd.
  7. Hello All, I am in need of a little professional help. I have a 1993 350l. The other day It was running great. I took it for a ride around the house and pulled back into the garage. This is when it all happened. It was idling fine for a few min when all of a sudden it back fired (sounded like a shot gun going off) I could not get it started. I left it for several days and tried to start again with no luck. The only way I could get it to even pop was to spray starting fluid in the carb. I figured it was a carb issue so I rebuilt it again with no luck. Tore top of engine down to discover a hair line crack in the bottom of the piston skirt. Rebuilt top end with a wiseco piston. Had it bored and matched to the new piston .5mm over. I have great compression 125psi. However the engine will still not start same simptoms. Is it possible that when the engine back fired it took out a crank seal? What else could be the issue. I have good spark, fuel, and compression. Thank you
  8. Need help to start what i have done new piston and cylinder bored crank seal plugs carb kit (Had bad piston when bought atv) problem I have no power runs rough and smokes have 110 compression looks like good fire stator is in correct position just dont know how to tell if there is a carb issue any help?

×
×
  • Create New...