Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Bleuu

Yamaha blaster stock light help

Recommended Posts

Hello so I’m new to the atv seen, and was wonder why my stock light didn’t turn on , and it figures that the black and white wire and the black wire were ripped apart everything else is connected fine, what could to reconnect them

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By jay rear
      Hi im new to the site. I have a 99 sportsman 500. I has been sitting for about a year now. I bought a new battery for it the other day and now i dont have any power to anything but the winch. Any help would be great. I already cut the pouch and checked voltage on both sides of the circuit breaker. 
    • By Beretta7
      Need help trying to figure out how to find the open wire for turning off my Big Bear.  Will srat with no issues and both the kill switch and main switch fail to kill the motor.  Any ideas where the open is
    • By Tiffany Rowland
      I am working on a Honda sportrax I just got my daughter for get birthday and the reverse and neutral light are not working. When I traced the wire down I saw that it wasn't plugged in but I don't see where it is supposed to connect. Does any one have a general idea of where I should look?

    • By Duane Steward
      I purchased a CDI box from Ebay that was listed as the one for a 200trx with round plug.....when I plugged it in the reverse light stays on.....what did I do wrong ? or is it just a bad CDI box?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...