Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Nor7

New Member: Howdy All!!!!

Recommended Posts

I just wanted to say hi and introduce myself. You'll probably be hearing alot more from me since I just bought my first ATV and I'll be hitting everyone up for advice and what not.

Oh, and the model is either a late 80's or early 90's QuadRunner 250.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Jon Emrich
      Does anybody out there have a link to the PDF manual download for a 1988 Suzuki Quadrunner LTD 4 x 4? If not does anybody have this on digital file they could possibly email to me or guide me in any direction to where I don't have to buy it? Thank you very much everybody in advance! Have a great day!
    • By Rich1028
      Hitting the Trail in the Morning.
       
      Heading out to Leota Trails 
      It's the Wife's Birthday Weekend,and I asked Her what,or where she wanted to go,she said  she wanted to go riding trails!
       
       
    • By Rich1028
      Hitting the Trail in the Morning.
       
      Heading out to Leota Trails 
      http://www.upnorthtrails.org/trails/leota-trail.html
       
      Breaking in the Wife's New Ride.
       
      Have Fun and Ride Safe People!
       

    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By mmmPUDDIN
      I've had this machine for 2ish years, has ran great up until winter. Sometime during then, I managed to break the exhaust right before the muffler. The summer before it had a hard time idling, but we fixed it by cleaning the carb, and messing with idle. Near the end of last year, the only way for it to fire was the have full choke, and full throttle, and the engine bogged down and you had to keep on throttle for 25mins. Over winter, the throttle had dislocated, and I got it back in place. We got it running, and all was good. Spring came along, and now it doesn't start at all. A fluid is coming out of the exhaust, and I'm told it could be water from over winter. I checked the airbox, and the air filter isn't for this quad, it also is barely sucking air. There appears to be little to no compression, based on this. I'm pretty sure the engine is flooded, as the spark plug produces a spark, but is oxidized. I don't know how the previous owner treated it, or when it's last oil change was. A bolt on the engine has either oil or gas seeping through it,abd was loose. I tightened it and it consisted. The engine is basically positioned in the rear, and it needs a good clean, I don't have a pressure washer, so I can get the built on dirt off. any recommendations on how to get the beast started again?
  • Similar Tagged Content

    • By Cobra_GT
      What’s up people I am new to the forum and am glad to be here. I have been into bikes for oh I guess 40+ years or so. I haven’t had one in a while but my 27-year-old son has always wanted a Banshee and he finally got one and the guy he bought it from had two of them. I almost bought the second one but I did not want to spend the next month on the sofa. So he had a LT-Z 400 Suzuki and I picked it up for $800, I could not pass that deal up. We could have bought both Banshee for $7000 as he wanted $7900 for both of them. But He wanted $4200 and was not budging for the one my son bought and $1400 for the Z400 and we got both of them for $5000. He wanted $4200 for the Banshee so I got the Z400 for $800, a steal. Anyway it’s good to be here. Peace.
    • By spark1051
      Hello Im new here. I have a Kawasaki Bayou 220 And just purchased a used Linhai 260 Four wheeler. It has an electric choke. The carb is brand new on it. The guy that owned it before me installed it. I am having a problem getting it started when it is cold. I think the choke is not working properly. I have checked to see if it is getting power with key on and when it is running but I am not getting power either way. I hope I am not having a problem with the magneto. The battery is losing voltage the longer it runs. Especially when I run headlights. It quit on me one day. The battery was half dead. I had to be towed home. Does anyone know where I can get a decent manual on it. Any help would be appreciated. I think I may have junk it seems to be built well though. May try to get rid of it.
    • By SlickRock
      Found this site by accident, looks like a good place to hang out. Ive looked around and I can see that there are a lot of knowledgeable folks here. Hoping to get to meet some of you and swap stories.
      Slick Rock
    • By cdscycleandatv
      Hey All, Just purchased a 2000 Suzuki Quad Master 500 4x4, and like all the quads I have owned, and still own I like to have a service manual for them. I noticed Oxidized Black listed a 02-07 Quad Master in his Manual Sticky. I got it, but there are some differences like the 2000 has a Mikuni Carb. and the 02-07 has a Kehein Carb. that has been the first difference so far. It would just be nice to have the correct year manual. If anyone knows where I can find a free download it would be greatly appreciated. Thanks!
    • By serious3
      hello all, i've just been given a 2002 yamaha big bear 400, its not quite the gift horse it seemed to be..... turns out the frame is rather rusty and the front a-arms are fubar... carby is trashed too, ah well i've got plenty of time and a shed full of tools. biggest problem i have is that here in ireland the big bear 400 wasn't sold her so bits and bobs for them are thin on the ground, ebay is now my best friend
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...