Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By spark1051
      I have a 1999 Polaris sportsman 335. It idles and runs good at low speed. But when you give it gas it bogs down. The carb has been rebuilt. If anyone has any suggestions it would be appreciated. Thanks
    • By tundrawolf
      Hi,
      I have a 1991 Suzuki King Quad 300.
      I bought it not long ago, and it has never run right. I bought a new diaphragm for it. It's sealed in that department.
      It barely ran good before, and actually I got it to run fairly good, with a good pull with a clamp in air cleaner.
      I put a snorkel on it, making sure to use pipe that would allow an ID as big as the carb intake flange, so there's no restrictions, and the same clamp on air cleaner.
      I went through the carb again, even put a top quality Japanese rebuild kit in it.
      It starts and idles perfectly. Has good power from idle to about 1/3, then anything past 1/3 throttle, or thereabouts, it just bogs down and completely dies. If I pull the choke in, I can get it to half throttle without it bogging down or dying.
      It pops and backfires and sputters the whole time, then past a certain point the engine acts like I hit the kill switch.
      It IS getting gas in the carb by the way, I put on a electronic fuel pump which helped things immensely. I put on a fuel pressure regulator and got the fuel to around 2 PSI.
      I am at about 5,500 feet elevation, and the main jet is a 120.
      I am considering coring out the main jet to a larger size to see if that helps anything. This quad is already such a gas hog, but maybe if it is jetted right it won't be so had?
      Edit: It does actually run a tad better when it is warmed up.
    • By data89
      I don't have any lack of power on short hills, but when I get a long uphill road the ATV will slow way down to about 30KPH. If I work the throttle to give it more gas it just gets worse. Then if I let up on the throttle it runs better, but of course slows down even more. Am I looking at a carb problem, or what? I tried getting at the air screw, but can barely get a screwdriver in it and then can't adjust...won't turn at all. I cannot find a fuel adjustment screw anywhere I can see on the carb, and the manual does not show one. My plug is burning black, wouldn't that be too much fuel, and how do I correct that? It may be that the engine is flooding when I go uphill and throttle up.
  • Recently Browsing   0 members

    No registered users viewing this page.


2019 MX Gear Sale
2019 MX Gear Sale
×