Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Cobra_GT

05 z400 carburetor ?

Recommended Posts

i am buying a z400 and am wondering what smooth bore carburetor you guys are running for performance on this quad. Flat or round slide and what size. i would like to get that cv carburetor off of there for performance, thanks. peace.:aargh:

ct

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

    • By amelia slabbert
      Hi I have a YAMAHA RAPTOR 660R 2003
      I have taken of my Air filter and sprayed in my air inlet some carberator cleaner while starting it. That causes some problems. It struggles to start now. Please look at my attachedment video. 
      What can I do now.? 
      MOV_1402.mp4 MOV_1401.mp4
    • By bradley nelson
      What is the best and easiest way to tune your carburetor? Any tips or tricks?
    • By Anthony Marceau
      Hi everyone! I have a 1986 yamaha moto4 200 that's been sitting for a while! Cleaned the carb, replaced engine oil, put fresh gas in it. Got it running and went for a ride! It was running great just a little backfire once in a while! I barely made it home on the way back and now the bike won't run at all since then! It will start if I give a little bit of throttle but dies instantly as soon as I let go off the throttle! And even if I try to rev it up it'll sound like its not getting enough gas.. it revs up a couple hundred rpm's and backfires through the carb.. it almost sounds as if I was trying to take off from zero in 5th gear! Nothing is seized though! I dissasembled the head and the piston and cylinder are fine! Rebuilt the carb, replaced the ignition source coil.. I don't know what to do anymore.. compression test shows 90 psi Specs are 128 psi but i'm not sure if I trust my compression tester.. any ideas? Thanks!!
    • By hoghead
      Anyone have experience with after market carbs.
    • By BeardedBackWoods
      Bought a 01 bear tracker and a trailer from a local guy last week. I rebuilt the carb 2 days ago and ran damn near perfect for 2 hours. Parked it and came back the next day. It suddenly won't hold an idle at all and pops when I'm going downhill or at a slow speed. Almost like I'm dragging the whole power train with the weight of the ATV. It still has decent power (80-90% maybe as it is now) but I can't figure out why it's popping and won't hold an idle suddenly. even with messing with the idle screw next to the bowl on the exterior of the carb. No changes. . ANY ideas would be great. I'm far from a carb king, but I've never had this issue before. The fuel was bought 2 days ago and it has a brand new intake manifold as of yesterday when I rebuilt the carb (whole rebuild kit). I sprayed around the carb and did not find any leaks. 
       
       Thanks y'all. 
  • Similar Topics

    • By Curtis01
      OK, sooo  I finally did the old skid plate and screen removal to clean out my oil sump during an oil change...  This bike only has a couple thousand miles on it.  Runs like a top still...  Very few issues over the years after buying it used.
      But boy I wasn't expecting to see this!  Piece of a circlip, stuck up in the screen, and a another shard of metal and maybe a piece of gasket material.  Nothing in the oil but that...  Pristine otherwise, and still runs like a top.  Always has.
      Soooo, is it a wrist pin clip?  That's the only thing I can think of like this that could end up in there.  But definitely wanted to throw it out to guys that have seen the innerds of these more than I have.
      The valves on this thing are still within the factory spec even.  Been a really good lil workhorse...
      Any other ideas?

    • By Chrism
      Hi all, new to this forum so thanks in advance for the help.

      I have recently brought a 2013 power steering fuel injected foreman 500.

      It has a crack in the front casing and was running rough. I have since replaced the front engine casing and this has made no difference to the engine performance.

      It starts and idles but bogs down and starts to die once throttle is applied.

      It maybe be but it also sounds very load.

      I have uploaded a video link of it.
       
       
       
    • By Countryboy57
      Hello I’m new here and I need help finding out what kind of quad I recently got for free. When I looked up the vin all it showed was 2004 and made in China. Any help will greatly appreciated thanks.
       

    • By Hunter19
      How are you doing guys I just joined I have a 1998 Suzuki King quad I’m having problems with high RPMs the ATV idols perfectly but soon as a throttle up it doesn’t stall but it just bogs down it has no power any suggestions thanks
    • By smitht18
      Looking for the rectifier.  Most bikes have near magneto.  It appears the KQ has it in front.
      Can someone tell me exactly where it is? 
      Bike not charging and magneto checks out ok
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...