Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

I have an 07' TRX-90. The throttle was sticking in the wide open position. Changed throttle cable, still kept sticking. Changed the carb completely, throttle still sticking. After troubleshooting many different things I noticed that as long as I had the carb unattached to the intake manifold the throttle works fine. When I mount the carb to the manifold, and do not tighten the bolts, the throttle works fine. As soon as i put any torque whatsoever on the bolts attaching the carb to the manifold the throttle begins sticking wide open. I have attempted to put gasket material between the manifold and carb to allow for less torque. It shows slight improvement, but still sticks enough to prevent me from allowing my child to ride. Has anyone ever experienced this problem before? The only thing I can think to do now is change the intake manifold. Otherwise I have nothing. Any input would be greatly appreciated.

Share this post


Link to post
Share on other sites


I apologize, The year on the bike is 1999. I was thinking of the year on my other bike.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Ed Zeppeli
      The play on my KQ 300 (1998) choke doesn't allow for the full movement downward on the thumb lever. So it goes about halfway down and if I push a little too far the cable pops out of the plastic setting it sits inside of. Then of course I have to take the control unit apart and put it back into position.
       
      Is it normal for the thumb lever to not go all the way down?
       
      I have no play left in the adjustment screw on the cable in the correct direction. The only play I have left would make it worse.
       
      It'a a new-to-me quad so I'm not sure if it's a replacement cable or OEM.
       
      Thanks
    • By JacobSlabach
      got 7 atvs off CL recently for a good price.  one of which is a yamaha warrior.  anyone know where the vin is printed on this bike?  Haha good place to start as I do not know year or size yet.  The former owner says needs exhaust ans and clutch work.  he said it ran fine until the clutch cable broke and then I couldn't get the new cable adjusted right and it would grind gears.  things I see:  clutch cable locked up again, no brakes, carb leaking (green with algae around the bowl and has gelled gas stalagtights on it), aftermarket exhaust melted the airbox so I need something different and a new air box.  I would like the use the current exhaust if I can but I have a feeling its a redneck fix as it looks like there is an ace bandage holding it to the exhaust pipe (its an aftermarket slip-on exhaust), so I'm not sure about that- lets get the bike running first.  also, battery (looks brand new, what a shame) is dead, 0 volts.  Otherwise, bike looks to have not been wrecked, and plastics are ok (it sat outside under a 'tarp' for 3+ years since it was run last).  any tips and advise on where to start first would be awesome as this is my first clutched bike (manual).
      the clutch is my main concern- I've never rode a clutched bike so I dont even know what its supposed to feel like.  lol I'm spoiled on my automatic polaris 
    • By Derrick Lenz
      So I bought a brand new carb that was set and everything. Put it all together and it runs and idles good. The downside is the bottom of the bowl is leaking fuel not a small leak either. I bought one previous and it was a cheap one and it leaked as well so I figured I'd spend the money and by an OEM one and it still leaks. Should I send it into the mechanic and have them adjust the float? I mean for a new carb I was kinda disappointed. Any help would be great! Thanks in advance.
    • By Mudrecon
      Now I need some settings and maybe the "what not to do for Gods sake" before I start dis-assembling. Anything guys. I see there is an idle adjust cable Is there any other settings on this carb? My drain screw appears well used

    • By weblex
      Problem: The ATV starts and runs at idle perfectly. But as soon as I open the throttle, the engine starts to slow down until it stops. On the attached video you can hear the sound of how it works: see video below
      Prehistory: there is a Polaris Sportsman 500 1998, which for about 1.5 years stood in repair, including also replacing CDI with one taken from the same ATV. Finally, the vehicles were on wheels, traveled several kilometers and overheated - forgot to fill the antifreeze Came back home in small moves. The next trip started well, but after 10 km there was a feeling of a small drop in power (even as the vehicle got warm completely) but still drives. Next trip - the situation is repeated. The next test of ATV through time and a huge loss of power from the very beginning. The engine sneezes, does not want to go more than 5 mph.

      What has been done: the carburetor has been replaced with a new one (inexpensive, $ 40), a new spark plug, a new ignition coil, the engine head has been removed, the piston is in good condition, valves were corrected - but the problem was definitely not in them.

      Ignition control unit is suspected. Who faced similar? Please help in solving the problem.
      Thanks in advance.
       
       
  • Similar Tagged Content

    • By teelee1
      View File 1993-2005 Honda TRX90 Service Manual
      1993-2005 TRX90 Service Manual
      Submitter teelee1 Submitted 11/16/2018 Category Honda ATV  
    • By teelee1
      1993-2005 TRX90 Service Manual
    • By reacoomin
      It was running well one day, and then the next it just wouldn't start (It has been very cold while trying to start it). I checked spark, it was meh, so I replaced it. After that it got blue spark. Still won't start. Cleaned out the carb (It was quite bad), still wouldn't start. Bought a new carb, put it on, still won't start. Gas is getting to the carb and the plug is dry. It's got compression (Not measured, just put hand in front of exhaust), spark, and gas. It'll start for a second it I put gas in the plug hole, but then I'm back to a dry plug. Any ideas on why it won't start?
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...